Arlo|Smart Home Security|Wireless HD Security Cameras|NETGEAR
Reply
Aspirant

HomeKit Update

I got the Homekit Firmware update today but need a secuity code to finish setup? Can anyone help me setup my Arlo 2 for Homekit? Or is this more lies from Arlo and netgear....

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Message 101 of 437
Aspirant

Re: HomeKit

From the 9to5 Mac article and the Aug. 2nd release notes it should be out and ready to go. But, of course, no answers from Arlo.
Message 102 of 437
Apprentice

Re: HomeKit

Has anyone actually been able to get Homekit working yet?

Model: VMB4500 | Arlo Pro/Pro2 Base Station
Message 103 of 437
Star

Re: HomeKit

I updated the firmware on my hub this morning.  Checking my Arlo app for the Nth time today, I had a window pop up that said:

 

"Arlo cameras no work with HomeKit

Apple HomeKit provides an easy, secure way to manage and control your Arlo cameras by using Siri.

The HomeKit security code will auto-populate during setup

<picure of HomeKit house>

[Add Cameras to HomeKit]

[Maybe Later]"

 

I chose to add cameras to HomeKit (of course) before it could change its mind.

Next screen says "Looking for Arlo..." and finds the "Basestation"

Next screen asks me to "Select a Home" (I have two homes configured in HomeKit)

Next screen asks me to select a room.  I foolishly(?) asked it to create a new room for "Outside"

It created the room, but then when I tried to select ANY room -- the new one, the "Default Room", or any other room -- it gave me an error up the top of the app in Orange:

 

"Object is not associated with a home."

 

That's as far as I got.  I also foolishly logged into Arlo via the web and it kicked off my iPhone session.  I haven't been able to get back to the setup process yet, there doesn't seem to be anything in the GUI to trigger it, it just popped up by itself, the first time.

Message 104 of 437
Star

Re: HomeKit

Screenshot of the first setup screen
Message 105 of 437
Apprentice

Re: HomeKit

This came up in the Arlo App for iOS right?

 

Have you had a recent update to the app? Are you running the beta of iOS13?

 

The last Arlo app update I had was 3 weeks ago. No new one has been released to me at this point.

 

Thanks for the info!

Message 106 of 437
Star

Re: HomeKit

This is iOS.  Standard version from the App Store 2.7.12 (99) Released 10 Jul 2019.  The app had NOT received an update in the last few days/weeks, believe me, I'd been hitting "refresh" on the App Store looking for some.

 

I'd just launched the app, it came up to the main Devices tab showing me the latest shot from each camera, then the "Add to Homekit" dialog popped up over the top.

 

Here's the sad error message that dashed all my hopes and dreams.  I don't know if it's just me -- because I have two "Homes" in HomeKit and/or because I tried to add a new room.  But I haven't been able to get it to show me the "Add to HomeKit" to try again.

 

For what it's worth, adding the new room ("Outside") DID successfully add it to HomeKit, I can see it in the other HomeKit apps (it's empty)

 

 

Message 107 of 437
Star

Re: HomeKit

No, I'm not running a beta of either iOS or the App

Message 108 of 437
Star

HomeKit

Just upgraded to Arlo app version 2.7.13 on iPhone. Please note I had to relaunch the Arlo app 3 times before seeing the prompt to add HomeKit. For those trying to add the cameras, do not do this through the HomeKit app directly
Message 109 of 437
Star

Re: HomeKit

I've reported my experience to Arlo's front-line support "live chat" in case it can help others avoid running into the same setup error.  The chat agent didn't know how to fix it (either to get the invitation back to try again, or how to avoid the error) so they'll get back to me via email.

Message 110 of 437
Aspirant

Re: HomeKit

cant set it up, I don't get the setup screen.

Model: VMB4500 | Arlo Pro/Pro2 Base Station
Message 111 of 437
Initiate

HomeKit on VMB3500r4 (Round Base)

Been trying to look everywhere for this answer.

With HomeKit finally
arriving on VMB4000/VMB4500 base stations, is there any word on whether it will come to VMB3500 base stations and when?
Model: VMB3500 | Arlo Base Station
Message 112 of 437
Highlighted
Star

Re: HomeKit

Keep closing and launching the Arlo app (as in, forced close, not just hiding in the background). Eventually it will appear. I assume you updated the app in the App store
Message 113 of 437
Star

Re: HomeKit

OK a new version of the iOS app is out.  2.7.13 (103) released 26 Jul 2019.

 

Under Settings, in the "Account" section, there is a "HomeKit" option just under "Subscription", although I noticed this had appeared just before I updated the app.

 

When I go into "HomeKit" it's just blank, with a settings cog in the top right, which takes me to "Advanced Settings".

 

"Advanced Settings" doesn't seem to help me do anything useful.  I can see my two homes listed, with the option to add a new home.  I can drill into the list of rooms, add or remove rooms.  That seems to be it.  I haven't found a way to trigger the "add to HomeKit" process again.

Message 114 of 437
Star

Re: HomeKit

In Advanced Settings, there was a big red "Reset HomeKit" button.  I thought, sure, maybe that'll trigger the process.

 

Nope.

 

My entire HomeKit configuration is gone.  Both houses, gone.  All devices, gone.  Not just the Arlo stuff.  In the Apple's own "Home" app... all gone gone gone.

 

I advise that nobody should touch that button.

Message 115 of 437
Aspirant

Re: HomeKit

I managed to add the cameras but sound is not working and no way to use 2 way communication. Did you get these to work?

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Message 116 of 437
Star

Re: HomeKit

OK, HomeKit support is working for me now.

 

I disabled the HomeBridge Arlo plugin I'd been using to arm/disarm the system.  If you don't know what that is, you don't need to worry about it.

 

I re-entered my entire HomeKit config.  Not because I wanted to, or because it was necessary, but because I'd accidentally deleted it through the Arlo App (see above).

 

By the time I'd done all that, a HomeKit Setup option appeared in the base station device settings as per the screenshot

 

The process to configure it all into HomeKit was a bit different in this latest version of the app, but this time it worked perfectly.  I can see a periodic snapshot of the cameras through HomeKit.

 

Message 117 of 437
Apprentice

Re: HomeKit

Awesome, thanks for info. After I updated the app, and opened the app, it immediately asks if I want to delete a “temporary home” it created? Running IOS 13 here
Model: VMB4000 | Arlo Pro/Pro2 Base Station
Message 118 of 437
Star

Re: HomeKit

I didn't encounter anything about a "Temporary Home".  Maybe you didn't already have a "Home" configured in HomeKit?

 

Having spent the last two hours rebuilding my HomeKit config, I wouldn't encourage anyone to press anything that sounds like it might delete anything they're attached to :-/

 

Roughly, the sequence was:

1. "Discovering your device" screen.  Chose "Basestation"

2. "Select a Home".  Chose my one and only home (since the other one's gone for now, sob)

3. "Requesting HomeKit info..."

4. "Add Bridge?"  Heck yes -> Continue

5. Flashes through all the cameras and motion detectors that it finds and says they're ready for use

6. Step through naming first the Base Station, then the child devices.  You can set a name here and assign to a room.  Add to favourites, or not.  Standard HomeKit screen, believe me, I've seen a lot of them in the last two hours.

7. I think there was an Arlo-style gui where you could rename things after that.  I just hit "continue" or "skip" until my devices were safely part of HomeKit, and renamed everything in Apple's Home app itself.

 

Note:  At no time did it ask me to record a HomeKit setup code, or enter one.  That much was all fully automatic.  If there's a HomeKit setup code assigned to my base station, I didn't need to enter it, and I don't know it.

 

Message 119 of 437
Aspirant

Re: HomeKit

Hi,

it is working for me ...

After ios update of the app

regards

dom

 

Message 120 of 437
Apprentice

Re: HomeKit

 I’m up and running. I think those temp homes appeared maybe due to IOS 13 Beta?

Thanks for your help

 

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Message 121 of 437
Apprentice

Re: HomeKit

Yep, app update did it; up and running. Thanks

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Message 122 of 437

Re: HomeKit

Arlo Quality Assurance Dept.,  please take note.

 

I received the Home Kit prompts this morning and I Allowed and followed them.

 

The Arlo app correctly found the two local base stations in this home and ignored the devices in a second home on this same account as well as those shared by other accounts and in other locations.

 

I selected one base station and selected the default room for this base station.  The app incorrectly called it a “camera”, but close enough,  

 

Home Kit warned that the Arlo system was an unauthorized device and prompted me to Allow Anyway or disallow the addition of these cameras.  I chose Allow Anyway.

 

I then selected the second base station and tried to add that, but I receive a “failed” message screen.  I repeated that attempt twice and “failed”   to add my second local base station on all three attempts.

 

At this point the Arlo app only allows Retry, the developers apparently  having never considered the possibly of the user NOT wanting to retry forever in the event of an unrecoverable failure. (Unbelievably naive design mistake).  My only choice was to quit the app and restart it.

 

I then entered Apple Home and the five cameras associated with the one base station that I was able to associate, showed up.  A low resolution image eventually showed up, but the camera names were all just serial numbers.  None of the actual camera names pulled over to Apple Home.

 

I touched one of the images.  It filled the screen and showed “Loading...” at the top of the screen.  This initiated a Live View after a few seconds.  At this point there is what appears to be a volume slider at the bottom with no icon confirming that fact.  There are no icons for taking a snapshot, initiating a manual recording, starting up the microphone, etc.   In addition to the slider at the bottom, we have “Done” on the top left and “Settings” on the top right.  I selected settings and was able to enter my correct camera name here as a replacement for the serial number.  I then noticed a “Bridge” selection and chose that.  This gave me information about the base station and allowed me to enter the correct name of the base station.  I can see a number of cameras and base station attributes in these settings.  I can change only the Name and Room associated with the camera.  It appears I might be able to associate each camera with a different room here.  I was not offered that option when initially setting up Home Kit in the Arlo app.

 

Among the attributes displays is: Home Kit Certified = No.  Perhaps this requires a newer version the the Pro of Ultra base station.  My Pro base station is a 4000 from a few years ago.

 

While perusing and changing settings, I noticed I was still in Live View on the camera so it appears we waste battery life when we are in here and there does not appear to be any way to adjust settings from the Home screen without selecting a camera and initiating a Live View, which most likely then also turns off motion recordings.

 

I’m not sure what Arlo’s plan is for Home Kit integration, but it seems like it is a long way from being worth bothering to set up.  I also wonder what, if any, Security exposure I have created by allowing an unauthorized accessory to join my Apple Home app.

Message 123 of 437
Star

Re: HomeKit

HomeKit is not working for me. I go throught the setup and it finds the Base Station. Then it appears to try to add the camera and it fails and says the camera is not certified and that is as far as I can get.  frustraing, has anyone else encountered that?

 

Now whe nI try to set it up, it won't even find the BaseStation.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Message 124 of 437
Apprentice

Re: HomeKit

Did you update the app? It found all my 5 cams

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Message 125 of 437