Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Arlo Pro 2 video won't playback on iPhone through Arlo app

Reply
Highlighted
Aspirant
Aspirant

It does work on iPhone 8S Max....

Highlighted
Master
Master

@mrhaynes01

I don't know what Apple did with the latest iPhone models, but this is a known problem and Arlo engineers are working on it. Be advised that whatever fix they come up with, it must be compatible with users using other phones and operating systems.

 

Brian

Highlighted
Master Master
Master

You are quite right to feel frustrated.

You are one of many with the XS problem.

If it's any consolation, Arlo is well aware of the issue and is working on a fix is a priority of theirs.

 

Highlighted
Guide
Guide
My Arlo is working fine after I updated to public beta 12.1
Highlighted
Luminary
Luminary

Looking increasingly likely that all this will soon be behind us Man Happy

Highlighted
Guide
Guide
So for anyone still having trouble this is what I did. I update my iOS to public beta 12.1. Not 12.0.1. I googled public beta 12.1 and the instructions were there to guide you. I updated this morning. I also got new emojis. Lol. Anyways that’s what I did and my videos from my Arlo are finally working fine.
Highlighted
Virtuoso
Virtuoso
So imagine my delight when I signed on to look at my useless 1500 dollar 10 camera system to see a firmware update. No generally this spells big trouble because every time this POS company does a firmware update all I have to look forward to is 10 drained batteries and 3 days of the cameras rejecting the new firmware. However today I was happy to endure the upgrade pain hoping that it would fix the frozen video problem. WELL YOU GUEST IT. NO LUCK. SAME USLESS SYSYTEM. This company should be thrown off the stock exchange and their third world engineers should go to work in a Disney Vacations call center.
Highlighted
Guide
Guide
Update your software to public beta 12.1. It will work. Mine did.
Highlighted
Initiate
Initiate

How do I complete that public beta 12.1 software update?

Highlighted
Tutor
Tutor

As I said earlier, when I updated my iPhone XS Max to the iOS beta software 12.1, my Arlo videos started playing on my phone, through the app, like they are supposed to. I have the original Arlo cameras. I don't undertsand how this worked for me and for so many others, yet some people say it still isn't working for them. Why would it work for so many yet not work for some? Doesn't make sense. 

Highlighted
Aspirant
Aspirant
I have been also encountering this problem. I have found that recordings less than 12 seconds are the ones having trouble and it is hit or miss if it will play depending on what phone i use as i own both Android and IPhone.
Highlighted
Guide
Guide
Mine also worked. Thank you.
Highlighted
Guide
Guide

Installed the beta 12.1 and the videos now work .

Highlighted
Tutor
Tutor
 
Highlighted
Guide
Guide

@Stefan24 wrote:

How do I complete that public beta 12.1 software update?


On my phone I went to beta.apple.com and  followed the directions.  Took about 15 minutes.  I did back up my phone to my computer before I did it.

Highlighted
Aspirant
Aspirant
I have the iPhone xs and I’m having the exact same problem.
Model: VMC3030 | Arlo Wire-Free Camera
Highlighted
Guide
Guide

This is ridiculous. Why do people keep repeating same stuff over and over. The problem was with Apple. Not Arlo. Public beta 12.1 is the solution. Update your phone to beta 12.1. Not 12.0.1. Ugh! Read the last to pages.

Highlighted
Aspirant
Aspirant
I had exactly the same issue with my iPhone XS Max. As above, updates to the iOS 12.1 beta and the playback is now working fine.
Highlighted
Aspirant
Aspirant

As others update to the public beta 12.1 and videos playback with no issues. This tells me that it isn't a Arlo issue it's an Apple issue!! 

Model: VMC3030 | Arlo Wire-Free Camera
Highlighted
Guide
Guide
Just read the release date for 12.1 to the public is next week when the XR phone comes out. I’ll wait a few more days instead of downloading the beta
Model: VMC3030 | Arlo Wire-Free Camera
Highlighted
Apprentice
Apprentice
I guess that person or persons who were threatening Arlo or Netgear that their product does not fit the purpose for which it was advertised should have been threatening to return their new iPhone instead 🙂

Mine works as well on 12.1 beta.

In all seriousness though. People need to remember that there are always going to be problems when companies upgrade software or hardware, particularly when software and hardware from one company are trying to interact with those of another company. The Arlo first generations have been out for quite a while now. Both Apple and Netgear/Arlo do their best when introducing new hardware and software to be backwards compatible but issues will always come up. This time there was an Arlo problem. Next time it could be a Ring or Blink product having an issue.

I agree, maybe Netgear/Arlo could have been better at communicating about the issue and potential fix. But what could they really say? They can’t tell people to download beta software. That could possibly create all new issues for people. But yes, being in the dark with no idea when it is going to fix sucks. I myself was simply being as patient as I could knowing st some point it would be resolved. And if it turned out my gen 1 cameras were not going to ever work then I planned to have a difficult conversation with Arlo because if the product is not End of Life and is still being sold they should be supporting it. I bought mine at Costco so I figured their return policy would protect me anyway. Thankfully none of that had to happen.

Glad to read others as well are having success with the Apple beta. Hope that becomes the solution in the end.

Z
Highlighted
Initiate
Initiate

I upgrade to the iPhone X and since the change, the videos in my libray are not playing.  I can see a still photo in the video but it does not cycle through the 10 second duration.  Can anyone provide me with recommendation that will correct this problem?

Highlighted
Aspirant
Aspirant

Have iphone XS with 12.1 installed and video is not working. Frozen frame.

Model: VMB3000 | Arlo Base Station
Highlighted
Aspirant
Aspirant
Are you sure it’s 12.1 not 12.0.1. I just updated to 12.1 and videos working again just fine. The latest non beta is 12.0.1.
Model: VMB3000 | Arlo Base Station
Highlighted
Initiate
Initiate

We are having the same issue with our new Iphone XS MAX.  It would look like it's replaying but the image is still.