Arlo|Smart Home Security|Wireless HD Security Cameras
× Arlo End of Life Policy Notice
To view Arlo’s new End of Life Policy, click here.

Discussion stats

First time poster here.


I've been using three Arlo Q Plus Security Cameras for the past 3 years without any major problems.

Today the cameras auto-updated to the latest firmware,, and I can no longer connect to them.


I've hard-reset them at least 10 times and I've tried connecting via Wifi and Ethernet cable, I've removed the cameras from my account and tried to add them again, but I always get stuck on the "No device detected page", both on the iOS app and on the website.


I have not changed a single thing in my network configuration between yesterday and today.


I am also able to ping the cameras.


Arlo, please advice what I should do next?

102 REPLIES 102


Thanks for your support, it really helped and without any "workaround", just strait on. The "new" firmware seems to be a roll back from july 2010. Will try to put camera in op-mode in premises to see if initial night-mode works at it should and eventually try to forget this glitch and get trust for Arlo again.




I tried to find the original poster with his solution to downgrade to firmware that bricked a lot of Arlo Q's. 


The solution can be found in this post "arlo q and q plus not syncing after firmware update 2020" from someone called Geoff.. Many many thanks for your solution...


His solution: create an open Wifi-network without a password, go through the normal process in which you add a new device, add your device to that open and free network and wait for a little bit so it can download and install the downgraded firmware, then proceed the process as normal.


In my case, i made an open account in my apple airport express


All my 3 Arlo Q's were able to downgrade from 1.10 to 1.9 and are now working again!


edit: i found the original poster with his solution:


geoffwbaOC, thank you very much.