Arlo|Smart Home Security|Wireless HD Security Cameras
× Urgent: Activate Two-Step Verification
Arlo requires all users to activate two-step verification to continue to access your recordings, devices, and account.
Please enable this feature now. Learn More.

Re: "Not Responding" message from Google Assistant; unable to stream through Google Assist

Reply
Geojeff
Tutor
Tutor
So where is the fix? Almost a year later and you have the same problem. Did Arlo ever find fix for camera not responding in google assistant? So unhappy. Would never recommend Arlo and warn everyone from buying them.
Geojeff
Tutor
Tutor
I could not agree more. Arlo and google are obviously not working on this problem. Posts go on for over a year with absolutely no fixes. Horrible they still say it works with google assistant on the packaging. False advertising!!!!!!
Geojeff
Tutor
Tutor
Then it should be removed from packaging now.
rs054
Aspirant
Aspirant
I just bought the Arlo ultra system. I was able to connect it to Google home, however, the video does not show on the app. " Not responding " is what it shows. Is there a fix to this? Looks like from previous posts that it has not resolved but I want to make sure.
Model: VMC5040 | Arlo Ultra Add-On Camera
Tim90210
Aspirant
Aspirant

The only thing helpful anybody can post at this point is to post your stuff for sale on eBay and buy something else if Home/Nest is that important.

 

If the mention of Home/Nest magically disappeared, then would you too? Sell your cameras maybe?

Adam112233
Tutor
Tutor
Two things are about all you need to know. One is that this issue about complete integration with Google assistant and Google home has been going on for nearly or more than a full year. Arlo apparently does not care enough to get this resolved or even offer any response that is satisfactory as to why it is happening. So this reflects very poorly on Arlo as a company. Secondly there have been posts to the effect that this is a Google problem and not an Arlo problem. Although in my opinion if there is a problem both companies need to take ownership. the Google nest products are what Google is focused on, so I don't think they are putting any priority on repairing integrations with competitors products. My best advice to you is to return your Arlo product if you still can and get something else.
Tim90210
Aspirant
Aspirant
Geojeff
Tutor
Tutor

You are correct.  Many people with these problems.  I am still unable to view any arlo camera in the Google Home/assistant  app.  I have done everything suggested multiple times and completely reset and started over twice.  Very disappointing for such an expensive product.  Due to this problem, and the extreme lag in seeing the video even in the Arlo App, I personally will not be buying any more Arlo products and would not recommend to anyone.  

KingAirport
Aspirant
Aspirant
This is ridiculous. Arlo knows the issue is there, has been for years with their serves, and no amount of rebooting, factory resetting, increasing internet speeds, delete and add cameras over and over again, NOTHING IS GOING TO FIX THIS ON OUR END. THIS IS AN ARLO ISSUE and they don't seem to care or know how to fix this. Incredible for a tech company to continue to have this issue and no real fix. I have an Arlo Pro and Arlo Pro 2, Nest Doorbell, and indoor Nest cam. Guess which cameras only have this issue with long buffering times in app AND with the Google Home Hub? Arlo, that's who. I would be surprised if Arlo fixes this issue by the year 2030. PS. I factory reset my Arlo devices just now, it was the only troubleshoot action I had yet to take, the issues persist. At least my Nest cameras work 100% of the time both in app and in the Google Home Hub. Nest is the winner here hands down. Get your (expletive) together Arlo!!
Tim90210
Aspirant
Aspirant
It's frustrating, it sucks, the devices are super unreliable. Arlo makes themselves an easy target and don't seem to have a path to repair the problems.

What I want to know is why it does work on many android TV devices but not the phones. I have a few odroid boards and I have seen it work on that port of the O/S
Davidcurl
Guide
Guide
Same problem here. Tried all the steps listed. Has anyone got a work around?
Catchbag
Star
Star
All, I suggest making this as public as possible is the only way to get a resolution...
https://m.facebook.com/story.php?story_fbid=446781829521845&id=257146888485341
Redpower187
Apprentice
Apprentice
@JamesC

Any progress on a fix for this issue?
Model: VMC5040 | Arlo Ultra Add-On Camera
Fundy1842
Aspirant
Aspirant

I know there are similar threads to this one out there, but I wanted to share my issue specifically, and hopefully get someone's attention to this issue.

 

I have an Arlo Pro 2 with 5 cameras and 2 Arlo Q cameras.  I have really liked my Pro 2 and Q cameras for the past year and a half I have had them.

 

Recently, I ended up with the Google Pixel 3 phone, and began to integrate my smart devices and apps to my Google Home app.  I found that I was unable to stream my cameras through the Google Home app, and began doing some digging.  I had been running my cameras through a Netgear wifi extender, as the base location was not best suited for where my wireless router was located.  I thought the reason I was unable to stream through the Google Home app was because technically, my Google Home was running on my primary wi-fi "Network" and my base station was running off the extender "Network-ext".  So I decided to invest in the Google Mesh wifi system- which has been awesome, btw.  It also allowed me to hard-wire my base station into one of the "pucks", and I thought for sure I would be able to stream my Arlo cameras to the Google Home app finally.  Well, turns out I still can't get this feature to work.  It does not work for my Pro 2 cameras or my Q cameras.  

 

I can get my Arlo cameras to stream to my chromecast on the TV (albeit rather slowly).  But it still will not stream at all through the Google Home app.  Is this a problem with everyone's Arlo/Google Home setup, or is it unique to my set-up somehow?

 

I appreciate any insight.  It is in the grand scheme a minor issue, since I still stream through my Arlo app, but for the amount of money I have invested in all of these products, I would expect to be able to stream through my Google Home app directly on my phone.

 

I appreciate any insight or help.

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera, VMC3040 | Arlo-Q HD with Audio
Mikeinvan
Initiate
Initiate
Same issue - pro and pro2 cameras timeout when trying to load video. Wonder if google maybe at fault (good way to sell more nest camera subscriptions). Either way it sucks hopefully arlo can fix. If youre reading this seeing same problem add a post and like maybe enough votes will get arlo dev attention. if anyone aware of other non-nest (non subscription anyway) cameras that work with google home let us know!
Model: VMB4000 | Arlo Pro/Pro2 Base Station, VMC4030 | Arlo Pro Wire-Free Camera , VMC4030P | Arlo Pro 2 Wire-Free Camera
Tim90210
Aspirant
Aspirant

IT WORKS NOW! I just changed to a Samsung S10+ (I really HATE this phone, will trade for the Note 10+) and it all works just fine in the app, HOWEVER, now I cannot add any new services to the app, I click the add "works with Google Home" prompt, and nothing happens.

 

The S10+ is a step down from my Note 9 in so many ways, and after 4 hours with it, I am not settling, I am going to get the Note 10+

gbrown
Aspirant
Aspirant

I managed to get the cameras showing up in Google Home app for me, albeit intermittently.  

 

  • Once you've connected Arlo to Google Home, make sure you speak/type 'Sync my Devices'
  • You should see the Cameras appear in the Home app.
  • Create a room for your cameras, i.e. External Cameras
  • Add the cameras to your home and to the new room.
  • A new button in the Google Home app should appear that says 'Cameras' on it, which will give you links to your select a Camera.
  • Now open the Arlo Web Portal, and view one of your cameras.  
  • Select the Camera in the Google Home app to view and see if the camera becomes visible.
  • Now when I choose a camera to view it will show within 5 -7 seconds, if it doesn't then I go back and try it again.

FYI: This is with Arlo Pro 2 cameras on an Ultra Base Station

 

I think the integration has trouble initializing the cameras which is why you get a not responding message, as there is probably a response timeout that Google Home is looking for.  That's what I've found so far.  Not great, but it's something.

 

G.

 

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
Catchbag
Star
Star

yes, every now and again I can get 1 of my 3 cameras display in Google Home. it could be any one of 3 and that can be after viewing in Arlo app, or not. I tried it after an Arlo App update recently and 2 of the 3 cameras displayed in Home, I thought "Hooray, were in". yeah, nah, haven't been able to do that again, and in actual fact status quo of nil displaying is the norm. So still we wait 🙂

Model: VMC5040 | Arlo Ultra Add-On Camera
gbrown
Aspirant
Aspirant

Indeed.  It's still very intermittent, but what I was sharing was the steps that make the camera appear for me every time.  As long as the cameras are in a room in the app (that seemed to help as well) and if the camera doesn't come up after 5-7s I hit back and do it again immediately then the camera shows.  It confirmed for me the idea that the issue is likely around the lag/timeout for Arlo starting the stream.  

gtrab
Tutor
Tutor
Hi, new user here. I though arlo was compatible with Google home, I have two home hubs, so I just bought 2 arlo pro 2 cameras, butt for the life of mine There's no way to stream them on a Google home hub display or Chromecast! It keeps telling me "sorry, it looks like the stream is currently unavailable from *camera name* Cameras work on Arlo app but not on any Google home product (home hub, home hub max, Chromecast) 😞 Now what? Any solution? I see this is an old problem...
Model: VMB4500 | Arlo Pro/Pro2 Base Station, VMC4030P | Arlo Pro 2 Wire-Free Camera
Geojeff
Tutor
Tutor

Out of nowhere, my cameras starting working on Nest Hub Max, Nest Hub and Chromecast.  No solutions posted worked for me, it simply started working one day.  All camera firmware and apps updated, logged in and out of Arlo, reset, blah blah blah.  The only thing I can think is either how I asked to see the camera "see below", or possibly uninstalling and reinstalling a different account (Hue, Wemo, etc.) or other unit connected to my system.  I had seen somewhere that the Nest smoke dectector doesn't install if you already have a Nest hub Max installed, so maybe it had something to do with a conflict with other product.  Either way, this shouldn't happen or be a problem for people. 

 

The only possibility is asking to stream the exact name of the camera as follows.  I have a camera called 'side door' one called 'front porch' and 'back porch'.  If I say, " hey Google, show side door camera", it works.  If I say "hey google, show side door cam", it doesn't.  I have two Pro cams and one Pro 2 camera.  

 

I have a Chromecast on my living room T.V.  It is labelled 'living room Chromecast'.  If I say "Hey Google, show side door camera on living room Chromecast" it works.  

 

I tried so many different 'solutions' that never worked, I honestly don't know if when I first tried to stream I used the word 'Camera' or said 'Cam'.  

 

I hope this helps, but seriously, with so many problems, with Arlo and Google Home.  I think it is a disservice to say it works with Google Home.  Especially with the high cost of the cameras.  It should work flawlessly.

Model: VMC3030 | Arlo Wire-Free Camera
BriscMoy
Star
Star

Still no solution - very frustrating that Arlo are still saying that it is supported. It may work, but the next time you try to stream it does not work.... 

Model: VMB4000 | Arlo Pro/Pro2 Base Station
bpullen
Tutor
Tutor

Things seem to be working again for me now, and I can stream from both of my Arlo Pro cameras using the Google Home app on my Pixel 4XL. Given what others are saying, I'm doubtful it will stay this way for long!

XenoGoddess
Aspirant
Aspirant

some interesting info:

 

I also bought a Google Home Hub and link with Arlo Pro2, seems all fine BUT!

I can only see the stream on Google Home Hub IF I logged in into Arlo App on my iPhone or Arlo Web Portal.

And I also have to play streaming video on Arlo App or Arlo Web Portal.

THEN I can command Google Home Hub to view live stream.

hmm..... I wouldnt call it problem solved because I dont thing anyone will have theor phone open Arlo App or Web Portal streaming video 24/7 in order to get Google Home Hub to work......

 

Oh, if I logged out / quit the app / close the window on the Arlo App or Web Portal, Google Home Hub stream video will stop working as well, feels like it logged out as well....

Oziosborne
Aspirant
Aspirant

This issue is still ongoing and after an hour on the phone with Arlo support their best answer was that I had to plug the google hub into the arlo base station with an ethernet cable (obviously no ethernet cable port on the google hub anyways). Sad to see that the problem has been going on for so long and on the two phone support calls I made they acted like this has never happened before. I bought the 6 camera arlo pro 2 pack with the understanding that it worked with google but looks like the option is going to be nest cameras since arlo doesn't seem to be working or responding on this issue.