Arlo|Smart Home Security|Wireless HD Security Cameras

Arlo Pro 2, HomeKit setup issues

Reply
Holford
Follower
Follower

Brand new Arlo Pro 2 & base-station cannot connect to / discover HomeKit, out of the box.

 

I've been through phone-support twice since receiving my Arlo Pro 2 cameras on Thursday night, but am hoping I can expedite the solution as I'm now waiting for a Tier 2 support person to call me back as none were available tonight...

 

How the issue manifests:

After setting-up both Arlo Pro 2 cameras & Hub (VMB4500r2) via the Arlo app on my iPhone, I went to setup the HomeKit integration via the Hub's settings. However, I perpetually see the 'Discovering your device. Please wait.' screen instead.

 

Troubleshooting steps taken:

  • Reboot Arlo Hub (via app & power-cycle)
  • Reboot Arlo Pro 2 cameras (via app & power-cycle)
  • Reboot home WiFi (via management app & power-cycle)
  • Soft-reset iPhone
  • Uninstall & re-install Arlo app
  • Use second iOS device (iPad Pro)
  • Restart Apple HomeKit Home Hubs (Apple TV, iPad Pro, and HomePod)
  • Confirm all Apple hardware is up-to-date with software
  • Confirm all Arlo hardware is up-to-date with software & firmware
  • Confirm all devices are on same WiFi network
  • Confirm all existing (25+) HomeKit devices are connected & responding
  • Place cameras, Hub, and iPhone within inches of each other
  • Leave iPhone on above 'Discovering your device...' screen for 30-45 minutes

 

Arlo support experience:

I've been on two different phone calls with Arlo support, which (to be honest) has not been fantastic. I've spent about 90mins on the phone on two different days, and spent about 50-60mins of that on hold. I've repeated all the steps numerous times, and the very first email follow-up I've received just tells me to follow the KB article on how to set-up HomeKit... 

 

I'm now waiting for a Tier 2 support engineer to call me back 'within a few days' as none were apparently available tonight.

 

I've done plenty of my own research both here, as well as on the /r/arlo subreddit, and it does appear this is a known issue with a number of Arlo Pro 2 kits, wherein the Hub needs a new Apple HomeKit Certificate issued remotely, with many saying they can have this resolved once this is confirmed within 20mins.

 

I'm hoping that someone (perhaps the fabled JamesC of this support forum) can help me in resolving this...

 

Many thanks for any help you wonderful people can give!

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
1 ACCEPTED SOLUTION

Accepted Solutions
JamesC
Community Manager
Community Manager

Holford,

 

I've sent a token reset request to your base station that should resolve the issue. Please reboot your base station (remove and reapply power) allow the base station to come back online and try setting up HomeKit again using these instructions: How do I connect my Arlo camera to Apple HomeKit?

 

JamesC

View solution in original post

405 REPLIES 405
JamesC
Community Manager
Community Manager

Holford,

 

I've sent a token reset request to your base station that should resolve the issue. Please reboot your base station (remove and reapply power) allow the base station to come back online and try setting up HomeKit again using these instructions: How do I connect my Arlo camera to Apple HomeKit?

 

JamesC

View solution in original post

Bryan_P
Tutor
Tutor

I've also had major issues setting up HomeKit. I am able to add my base station to HomeKit, but only as an uncertified accessory. I have been through phone and email support, and supposedly a new token was sent to my base station, but it didn't work (although the tech support individual had me completely reset my base station, as opposed to simply power-cycling it, as JamesC usually seems to instruct).

 

Arlo RMA'd my first base station and replaced it with another VMB4500, but in my attempt to set it up today, I am getting the same "uncertified accessory" message when I try to add it to HomeKit.

 

I like the Arlo app, but part of the reason I went with Arlo was the promise of HomeKit integration. Is there any way we can get this working properly?

Model: VMB4500 | Arlo Pro/Pro2 Base Station
JamesC
Community Manager
Community Manager

Bryan_P,

 

I've sent a token reset request to your base station that should resolve the issue. Please reboot your base station (remove and reapply power) allow the base station to come back online and try setting up HomeKit again using these instructions: How do I connect my Arlo camera to Apple HomeKit?

 

JamesC

Bryan_P
Tutor
Tutor

Thanks James. I power cycled the base station and tried again, but I'm still getting the "uncertified accessory" error message. This doesn't stop me from adding the cameras to HomeKit, but it doesn't seem ideal (and none of the other HomeKit accessories I have are uncertified).

BayParkGuidi
Aspirant
Aspirant

I just got the Arlo Ultra and I am having the same issue. I try to add the hub to homekit and it sits at Discovering your device. Please Wait. I tried rebooting the phone, the hub, etc... and it still doesn't work. I went and deleted the hub and re-associated it and re setup the cameras. Still get the same thing. Any ideas on how to fix it? I have the VMB5000r5 hub running 1.15.04_297_aa40f04 firmware. I checked and the arlo app has permissions to my home.

 

A little frustrating...

chayts
Initiate
Initiate

Hi JamesC,

 

I've been having the exact same issues as Holford for months now (an have gone through the same diagnostic process many times over). I had thought that I needed to wait for a base station firmware update to get Homekit working, but sounds like you have the ability to issue an Apple HomeKit Certificate remotely to resolve.

 

How can I request a token reset for my base station to enable Homekit?

Model: VMB4500 | Arlo Pro/Pro2 Base Station
JamesC
Community Manager
Community Manager

chayts,

 

I've sent a token reset request to your base station that should resolve the issue. Please reboot your base station (remove and reapply power) allow the base station to come back online and try setting up HomeKit again using these instructions: How do I connect my Arlo camera to Apple HomeKit?

 

JamesC

chayts
Initiate
Initiate

Thanks JamesC!!!!!

 

After you sent the token and a reboot adding Homekit worked flawlessly 🙂

Bryan_P
Tutor
Tutor

Hi James,

 

Could I please get a token reset? We've tried it before with my system and it didn't work, but I'd like to give it another shot.

 

Thanks,

Bryan

JamesC
Community Manager
Community Manager

Bryan_P,

 

I've sent a token reset request to your base station that should resolve the issue. Please reboot your base station (remove and reapply power) allow the base station to come back online and try setting up HomeKit again using these instructions: How do I connect my Arlo camera to Apple HomeKit?

 

JamesC

dylanthology
Aspirant
Aspirant
JamesC,

How do i get a reset token?
Sinds I moved to another house I cannot set up my HomeKit in arlo.
My hardware is VMB4000r3
JamesC
Community Manager
Community Manager

dylanthology,

 

I've sent a token reset request to your base station that should resolve the issue. Please reboot your base station (remove and reapply power) allow the base station to come back online and try setting up HomeKit again using these instructions: How do I connect my Arlo camera to Apple HomeKit?

 

JamesC

rcordeau
Aspirant
Aspirant

Can I get a reset token sent to my base station as well please?

JamesC
Community Manager
Community Manager

rcordeau,

 

I've sent a token reset request to your base station that should resolve the issue. Please reboot your base station (remove and reapply power) allow the base station to come back online and try setting up HomeKit again using these instructions: How do I connect my Arlo camera to Apple HomeKit?

 

JamesC

PCNerd87
Aspirant
Aspirant
Can I get a token reset as well?
Model: VMB4000 | Arlo Pro/Pro2 Base Station
rcordeau
Aspirant
Aspirant

Thanks James. Worked like a charm.

RyanAmado
Tutor
Tutor
Could I receive that token as well?
Model: VMB4000 | Arlo Pro/Pro2 Base Station
JamesC
Community Manager
Community Manager

PCNerd87, RyanAmado

 

I've sent a token reset request to your base station that should resolve the issue. Please reboot your base station (remove and reapply power) allow the base station to come back online and try setting up HomeKit again using these instructions: How do I connect my Arlo camera to Apple HomeKit?

 

JamesC

RyanAmado
Tutor
Tutor
Thank you!!! It finally works!!
Hype17
Aspirant
Aspirant

Can I get a token reset as well? Many thanks in advance!

TTeuer
Aspirant
Aspirant
I’d had my Arlo Pro 2 setup with HomeKit from day 1 of the firmware announcement and have experienced zero issues.

I noticed today that HomeKit was no longer able to connect to my Arlo camera and when I went into the Arlo app it said I need to setup HomeKit. I am unable to setup HomeKit like the OP originally had stated. Nothing on my network or HomeKit has changed, but it looks like the firmware was recently updated on the Arlo base station.

Would a token reset work like it seems like it has for others here?
Model: VMB4000 | Arlo Pro/Pro2 Base Station
JeremyA
Aspirant
Aspirant
Did this issue get resolved? I have exactly the same issue and I’ve used your list of things to cross off as checked but still no joy. What direction should I take?
Model: VMB4000 | Arlo Pro/Pro2 Base Station
RyanAmado
Tutor
Tutor
Get the token reset, after MONTHS of trying everything, less resetting the whole system, the token reset I got the other day fixed it flawlessly.
Peterlyd
Aspirant
Aspirant
Hi Can I too get a new token for my basestation as HomeKit says it is uncertified

/peter
Denmark
Model: VMB4000 | Arlo Pro/Pro2 Base Station