Arlo|Smart Home Security|Wireless HD Security Cameras

Re: GeoFencing not working.

ilioni Star

Exact same issue too with Andriod device. It is so unreliable! Keep on getting the below message and the device is a Samsung S8 Plus and tried reinstalling the app multiple times. Any  advice to make it work on the Andriod device is most appreciated. It works on my other device which is iPhone. 


Here's the notification:
Geofencing needs an internet connection. Open the Arlo app when your connection becomes available.

soyee7 Apprentice
I have the exact same issue with my S8.
ilioni Star



With regards to Netgear's response towards these geofencing issue on Andriod, their engineering team really need to get their act together. It shows how incompetent their (product engineering) Android developer team is. The Android development team in the Arlo Netgear really need to show that they can come up with the product that works or they are not doing their job right especially the person who is leading the team. This problem is easily reproducible and it is consistently not working and it's been reported by multiple people and I don't think i am the only person facing the problem. 


Netgear, how can you have a feature that is not working for so long for the Android based mobile? The only reason why I bought Arlo is because it has the geofencing capability. 


We are still seeing these messages below everyday on the Andriod device (Samsung S8 plus) - updated to the latest Android version recommended by Samsung using the autoupdate. 


"Geofencing needs an internet connection. Open the Arlo app when your connection becomes available."

Buts Initiate

I to am getting extremely frustrated about the geofencing sytem working sometimes but not most.

On the forum it states "problem solved"

I dont see a soultion anywhere and have tried all the suggested fixes many times.

I still get " system in home mode and visa versa, when clearly it is not.

What is the solution and when are we users ( there appear to be many with the same erratic issue) going to be told what the fix is?

The only true fix I see on this site is the guy that sent his system back and replaced it with a "Nest" system!

Model: VMC3030 | Arlo Wire-Free Camera
madkiwi Luminary

Pretty fed up myself. Wife and I both have Galaxy 7S phones, geofencing never works. Right now the system is in home mode, because we are both home. System shows we're both "In zone".


But 10 minutes ago I was out of zone. Although I have not moved.


My wife came home before me last night, system kept telling me movement was detected. But when I checked geofencing, it told me she was "In zone". So she was home, Arlo knew it, but it would not turn off the Armed condition?


Before anyone says to try all the standard BS troubleshooting- had this system since May. I know all the steps to take. I have tried them all in the last week. Uninstall Arlo app. Reboot Arlo. Reboot the phones. Made sure the Arlo app is not turned off by battery saver (Arlo is set up as "unmonitored" by Battery optimization, never sleep and allowed unrestricted data access) and yet it either doesn't work or I keep getting the "Arlo needs an internet connection" message.


This is as dumb as it gets. Why don't they use the home WIFI as an independent verifier? That's got to be pretty easy isn't it?



Model: VMC3030 | Arlo Wire-Free Camera
cr8v_nrg Aspirant
Have you tried removing special characters from your device (phone) names? That was what did the trick for me. My phone’s name was “Tom’s iPhone” but when I changed it to “Toms iPhone” geofencing started working. No problems since.
madkiwi Luminary

My phone was called SAMSUNG-SM-G930V (exciting, I know). Now called Marks S7.


Not improved yet.


Model: VMC3030 | Arlo Wire-Free Camera
cr8v_nrg Aspirant
On the iPhone, Location Services have to be On and set to Settings>Privacy>Location Services>Arlo>Always. Anything similar in your Android?
THamilton Aspirant

I'm have had the same problem with Geofencing for the last few weeks. Two cameras/Arlo base station, iPhone 6s and iPhone 5 carrying the mobile app. Arming doesn't seem to be too much of a problem, but when my wife and I come home it often doesn't recognise our presence and we wind up with a stream of motion detection messages.


@JamesC I have an issue with the "check the devices in geofencing setup" comment, I go to Mode, Arlo Base Station, but the Geofencing mode isn't selectable, so I can't check if our devices are being enabled.

Model: VMB3000 | Arlo Base Station
heisian Guide

I would very much like to see this addressed.

heisian Guide

Everyone, here are a bunch of other users having similar issues with Geofencing:



It seems pretty obvious that at this point NETGEAR has no desire to solve this issue that is being experienced by many, many users. Unless it is shown otherwise with confirmation that issues exist and have a plan to be fixed.

bigp0408 Aspirant

when i go to my devices iphone appears and right away disappears... cant activate it..thats tha only reason why im not using my iphone.. ive been using my s8+ no problem..but now cant get notification on my s8

JamesC Community Manager
Community Manager



It sounds like this could be due to special characters in the iPhone's name. By default the iPhone will be named something like "JamesC's iPhone". Some users have reported having issues with the special characters. Try renaming the iPhone to something like this: JamesCiPhone   Do you still see the same behavior?



denglish88 Initiate

Geo Fence does not work on my Samsung S7. It tracks me outside the radius and will not arm inself. I repeatedly get an error message that I do not have an internet connection when I do. This feature is compleetely useless. I bought it on Amazon and plan on returing with a 2 star review. It's too bad, the product works well other than that. Netgear had known about this problem and chooses to ignore its non iPhone's customers. A fatal mistake.

Model: VMC4030| Arlo Pro Wire-Free Camera
scottb08 Star

I had a similar problem with my Samsung Galaxy S7 Edge. I completely uninstalled the app and reinistalled it and it magically started working. Works pretty good now. Might be worth a try before returning it.

vanessalo Initiate

I was having the problem of 2 phones not working with the geofencing.  I did the live chat via the support page and they were able to help me with a very wierd solution.  I thought I would share although it may not be your problem.


My husband was adding me as a user with admin status but his phone could not "see" my phone in order to select it on his phone.  I also did not have the "arlo app" under the locations services in settings.  When i first installed the app, it never asked me if I wanted to allow locations services for the app either.


Turns out the Name of my phone (found under settings, general, about, name)  was "Vanessa's iphone".  The support guy had me remove the apostrophe from the name stating that arlo did not recognize the special characters.  As soon as I did that, my phone showed up on my husband's device list and the locations services question popped up.


Very finicky programming.  I asked if they know of this silly problem with the code, why don't they just fix it.   Apparently, its harder that it sounds.  


Anyway, thought maybe this might help someone else.  

Model: VMC4030| Arlo Pro Wire-Free Camera
JTDK Tutor

The geofencing option is not working similar to all other messages in this forum. We have two phones attached which not are detected unless we manually disconnect and connect the phones back into the geofencing option. If not fixed it will be delivered back to Power in Norway where it was bought within the 30 days return option we have.   

Model: VMC4030P| Arlo Pro 2 Wire-Free | Web Site/App
Joanlay Aspirant
I only have one phone set up for geofencing location identification and haven’t installed the Arlo app on any other devices but the location is listed as unavailable although I’ve allowed for location services for arlo in my iPhone settings.
crazyitalian Guide
This was very helpful - I was losing my mind with this exactly same fact pattern. Seems like a silly limitation.
Saluki00 Initiate

@JamesC - I think there seems to be a disconnect here between Netgear and its users.  I contacted Support regarding my challenges with GeoFencing and this was the conversation (below). What I am looking for, is an ETA on when this feature shoudl be working flawlessly? It seems this feature set has not worked for some time and many of your users are expressing thier frustration. The Arlo 2 system is an amazing system, but this feature set needs to be fixed soon.  


( 2m 39s ) Guiller C: As I understand, your Geo-fencing is not working properly, is that correct? 
( 3m 30s ) Guiller C: Thank you. I will be glad to clarify the reason for this problem to you today KBS. 
( 3m 54s ) Guiller C: There is actually a known issue with this feature. 
( 4m 45s ) Guiller C: The Geo-fencing mostly work flawlessly only if the Enabled Device is just one. Not when there are more . 
( 5m 57s ) Guiller C: The symptoms you are seeing is not actually a problem with your system or with the network devices. It is a problem with the cloud's integration with the GPS system. 
( 6m 9s ) Guiller C: The engineers are already working on this problem. 
( 7m 19s ) Guiller C: The feature actually worked fine before KBS. But something went wrong when the Arlo code was changed way back few months ago. So they are nw working on it. 

Jefffromtexas Star

Same issue.  Samsung Galaxy S7 and I get this message; "Geofencing needs an internet connection. Open the Arlo app when your connection becomes available".  Half the time when I open the Arlo app even  when I am not in GeoFencing mode Arlo thinks I don't have an internet connection. 


I was going to add to my system, but now I am thinking I may need to replace it. 

veener79 Luminary

I will say after the last couple of app updates my system has been good for the most part.  Know also having to set the App to be on noted on "Power Saving Excusions" in Android settings is a must.  

scottb08 Star

Good suggestion about setting the app to be excluded on Power Savings. I tried this myself but I keep getting the error that the app needs an Open Internet Connection, which I seem to do but still throws that error all the time. Seems like Netgear is not listening to their customers about these issues OR there is an underlying reason in Android OS that keeps them from implementing it the way they way. Either way, they should be open with their customer base about the issue.

Picturepainter Aspirant

Not just Android, I have an iPhone 6, and Geofencing continues to be an issue. Works some times, but very unreliable. 

brh Master

For anyone still following this thread, Make sure any phone names do not have any special characters in the name. For example: Use John Phome in the name rather than John's Phone.

This seems to solve a lot of Geofencing problems.