Arlo|Smart Home Security|Wireless HD Security Cameras

Geofencing broken with iOS 13. Need to open app and it figures out my location changed.

Reply
Highlighted
Star
Star

After updating to iOS 13, my geofencing no longer works. Shocking. Geofencing is the most unstable feature in this product. I find I need to open the app and then it figures out my locations has changed. Come on Arlo, does anyone test this stuff there?!?!

Model: VMB4000 | Arlo Pro/Pro2 Base Station

Accepted Solutions
Highlighted
Arlo Moderator
Arlo Moderator

A new version of the Arlo mobile app for iOS is now available resolving several issues with Geofencing, please make sure you have the latest version of the mobile app installed and take a look at the release notes here: Arlo iOS App - 2.12 - 13th December 2019

View solution in original post


All Replies
Highlighted
Initiate
Initiate

I have the same Problem after updating to ios 13

Highlighted
Arlo Moderator
Arlo Moderator

Hi markjericho and Jan80,

 

Make sure that you have Background App Refresh and you don't have Low Power Mode enabled in order for Geofencing to work. You can also read here to learn how to troubleshoot if your Geofencing isn't working properly: Why isn't the Geofencing mode working?

Highlighted
Star
Star

Thanks for the suggestions but I do have Background App Refresh on Low Power Mode off. I have also confirmed multiple times that Location Services is set to Always and have toggled off and on most of the related settings to see if that helps. Before the update, this was working just fine. After the update, it has been erratic. For example today when I left my house for work, it didn't arm but when I got to work 15 minutes later and walked into my office, and assume might have connected to wifi, it finally changed it's status. Other times I get a message that Arlo has lost internet connection. 

Highlighted
Arlo Moderator
Arlo Moderator

If you're still having problems with Geofencing and the article link didn't help, I would suggest to contact the Support Team to further investigate this issue. You will find several options for contacting support in the provided link.

 

Highlighted
Star
Star

I did that too! Lol. Still haven't received an update from them yet. Was posting on here to see if others were  having the problem. Today I got a new iPhone and I'm setting it up now. I'll see if this new phone works better or if it's just a software issue.

Highlighted
Star
Star

Did you try restarting the base station?

 

I was having the same issue and I think after I restarted the base station it is working now (I haven't actually left to verify with 100% certainty)

 

Previously if I switched modes off of geofencing and then back to it, my wife's phone was showing as location "unavailable". After the restart, it was properly updating without having to open the app on her phone.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Highlighted
Tutor
Tutor

mine is broken as well, after updating to iOS 13.1.

 

SO ANNOYING!

Highlighted
Star
Star

Nope, doesn’t look like restarting the base station fixed it. I turned on in/out of location reminders in the system Arlo settings and I’m not getting them. My wife’s phone also didn’t automatically update when she left this morning.

 

I’m having geofencing issues on a different app as well. I’m kind of wondering if Apple did something that caused this to stop working properly.

Highlighted
Tutor
Tutor
I’m having this same exact issue. I need to open the app every time I get close to home so that it knows I’m home. And it doesn’t arm sometimes for 20-40 minutes after I’ve left home. This is all since upgrading to iOS 13
Highlighted
Initiate
Initiate
I have absolutly the same issue since upgrading to ios 13!
Highlighted
Tutor
Tutor

i figured out how to fix mine. i went into geofencing mode and edited the device.. it had 1 iphones listed for some reason, and i selected the other one then it started to work again.

Highlighted
Tutor
Tutor

I had previously already done this....went in an re-checked my new device and unchecked my old device.  I'm still having the issue even after doing this.

Highlighted
Apprentice
Apprentice

Same, super unstable now with new app and iOS13.  Says away when the apps own map shows you inside circle!  Tried everything, spent hours.  Of the year I have had this system geofencing has been reliable about 50% of the time.  Stable, update, break....stable, update, breaks.  It is pathetic from a software QA standpoint, almost like no one tests it at all.

 

iOS13 is also no excuse, has had betas in the wild for 6 months!

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Highlighted
Tutor
Tutor

It almost seems like the Arlo app isn't able to run "in the background" to know where the current location is.  Even though location services is set to "Always" and Background app refresh is set to ON.  Currently it seems the only way for it to actively know where my location is, is to have the app open and the screen up and on my phone.  I keep checking every day for an app update in the app store in hopes they will fix this BUG!

 

p.s.  The issue persists in iOS 13.1, 13.1.1 and 13.1.2

Highlighted
Tutor
Tutor

yes, i have to re-open the app for the GEO to know where i am every time i leave. very annoying.

Highlighted
Guide
Guide
Same issue. Do the support team ever respond to these concerns? Highly disappointing since iOS13 has been in beta for some time. Arlo becomes unviable as a sensible security solution with these constant issues, time to look at something else.
Model: VMC3040 | Arlo-Q HD with Audio
Highlighted
Guide
Guide

Geofencing has been working fine, but since the upgrade to the new Arlo software it has been playing up.

it had the original phones listed along with the new phones which had the same phone name, but they have now cleared.

I am the main account for the system and it always works fine for me.

My wife and son have both been enabled and Geofence randomly detects whether in or out of zone, and then stops detecting whether in or out of zone, If you open the app it seems to detect whether they are in or out of zone and works for a few days then stops again.

Yesterday/today it now states 'Disabled' for all of us

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
Highlighted
Guide
Guide

I'm having same issue.

 

Had a chat session with "support" for 1hr 40 minutes, and it didn't resolve anything.

 

The last step was to reset the base station and add all the cameras again, which did not resolve the issue.

 

I don't even know how to reach support.  I guess there is an open case, but they don't respond to it, nor does support respond to other methods of contact.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Highlighted
Tutor
Tutor
Same here. Geofencing was working fantastically before the upgrade to iOS13 but now doesn’t work until I open the app. I often get an “Internet Connection is Lost” notification instead of a geofencing notification. Super frustrating, especially when I see that the error was detected by users several months ago during the iOS13 beta. Come on Arlo, get your act together!
Model: VMB4000 | Arlo Pro/Pro2 Base Station
Highlighted
Apprentice
Apprentice

The connection lost message is related as I see it too (no connections are ever lost though).  Was sitting on my couch yesterday and the system decided to go into away mode, despite me still being clearly in the large circle.

https://imgur.com/a/oqCeM3I

 

Now more broadly for Arlo.  Look at the number of responses here.  Might seem like not a lot but think about the uptake rate of iOS13 (always very fast) and realize you have 100s times as many people out there now whose SECURITY SYSTEMS currently don't work - many possibly unaware of that fact!  I know you have "separated" from your sugar daddy Netgear but Apple and Google do beta programs (aka Developer Previews for Apple) for a reason.... so you can purchase and load it on test bed phones months in advance and TEST.  They even allow developer feedback! (gasp) 

 

Again, you purport to sell SECURITY SYSTEMS, but they are woefully unreliable and as such are little more than novelty cameras currently.  The only real way to arm the basic system (short of manually every time) IS GEOFENCING.  You provide no traditional keypad.  Your product tag line currently is "The essential elements of true peace of mind".... no, far from it.  Do you actually WANT to be a security company?  All it will take is a robbery or home invasion where your system has failed so badly (like it currently is) and you will be looking at a lawsuit.  If there is loss of life or grievous bodily harm you will be done, all due to some lazy developers and lack of anything resembling a software quality system.

Highlighted
Arlo Moderator
Arlo Moderator

Hey steveomac,

 

If you're having problems with your Geofencing not working properly, try looking at this article for troubleshooting steps you can take to improve performance for Geofencing: Why isn't the Geofencing mode working?

 

If you're still having problems, contact the Support Team to further investigate this issue. You will find several options for contacting support in the provided link.

Highlighted
Aspirant
Aspirant

Same issue here geofencing stopped working 2-3 days ago all 4 devices/phones mix of iphones and android are "unavail"

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
Highlighted
Guide
Guide
Read the FAQs, called customer service, tried all the “delete-add-repeat” steps. Nothing works to fix the bugs with Geofencing and the new App. Whoever developed the new App needs to be fired! For me, after 5 years of using Arlo, sadly Thinking of switching to Ring.
Highlighted
Guide
Guide

Only had this product a few months.

Also have my doubts about the commitment to the customer base for this software and hardware.

i have managed to resolve a few issues manually, but starting to lose confidence and it has so many bugs.