Arlo|Smart Home Security|Wireless HD Security Cameras
× Urgent: Activate Two-Step Verification
Arlo requires all users to activate two-step verification by Oct 31st, 2020 to continue to access your recordings, devices, and account.
Please enable this feature now. Learn More.

Homekit - same account on two devices won't sync

Reply
Discussion stats
  • 11 Replies
  • 2849 Views
  • 16 Likes
  • 10 In Conversation
Highlighted
Initiate
Initiate

So I was able to successfully setup HomeKit with the new update, and it shows great on my iPhone Home app.  However, no one else in my household sees the devices in the Home app.  My iPad doesn't see the devices in the Home app, and when I open the Arlo app on my iPad it asks to 'set up Home Kit' but then hangs and starts asking if I want to delete temp home data.

 

Is this by design?  Is there a reason once it is added to HomeKit, only one device can see it?

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Highlighted
Aspirant
Aspirant

I struggled for most of yesterday and finally got the Arlo’s working in HomeKit (only to discover Arlo Smart is no longer working)

Couple tips - all iOS devices need to be running the updated app (in one instance I opened an old version of arlo on another device and needed to redo the whole setup from scratch)

Also the temp home thing seems to be connected to iOS 13 beta so if you don’t have all devices on the Beta it could be the problem.

I’ve had to redo my entire HomeKit and Arlo config from scratch and now want Arlo smart back. These problems are reminiscent of when Arlo smart was first introduced and we spent days trying to get it to work.

Highlighted
Initiate
Initiate

Set up Homekit on iPhone just fine. Cameras are showing in Homekit (thank you Arlo). Same Arlo & iCloud accounts on iPad is acting as if Homekit isn't set up (not synced) and wants to run the set up but just spins, not recognizing any devices. The Apple Home app on the iPad also shows no reference to Arlo. iPhone set up was done 36 hrs ago, both iPhone & iPad are running most recent ios. Arlo app is also most current.

 

What needs to be done to get same accounts synced to show Arlo in Home on two devices?

Model: VMB4000 | Arlo Pro/Pro2 Base Station, VMB4500 | Arlo Pro/Pro2 Base Station, VMC4030 | Arlo Pro Wire-Free Camera , VMC4030P | Arlo Pro 2 Wire-Free Camera
Highlighted
Tutor
Tutor

I have this problem too. Set it up on my iphone, cant see arlo in HomeKit on my iPad. Deleted it from iPhone and set up on my iPad, now I can't see it on my phone. My wife can't see it on her phone or iPad.

Highlighted
Initiate
Initiate

No problem setting up HomeKit for base station 1 with 4 attendant cameras on my iPhone.  But Arlo’s Homekit setup function would not recognize base station 2 and it’s 3 cameras.  So I tried setting up HomeKit for base 2 on my iPad.  Success! But set up would not recognize base station 1.  So iPhone has base station 1 and 4 cameras integrated with HomeKit but can’t see base 2, and iPad has base 2 and 3 cameras integrated but can’t see base 1.

 

My wife’s devices can’t see any of the Arlo cameras in HomeKit.  Even though it’s all one HomeKit account.

 

Will subsequent firmware updates resolve these issues?

Highlighted
Initiate
Initiate

I am having this exact same problem. Set up Arlo for HomeKit on my iPad, but no other device across my network (2 iPhone XS, another iPad Pro 11 and 2 x MacBook Pro's) don't see it within HomeKit. Eagerly awaiting to get this working properly across all devices.

Highlighted
Initiate
Initiate
Hello, exactly the same problem, only the device where I have done the setup is working , does not appear on other device .

I have set up on iPhone X, not working on IPad, mac, family devices ( iPhones, iPads and Macs )

How do we do the setup ?

Is there a work around ?

Highlighted
Arlo Moderator
Arlo Moderator

Make sure you invited other people to have access to your HomeKit accessories. Read here to learn how: Share control of your home.

 

If you're still having problems, please contact the Apple Support Team in the provided link.

Highlighted
Initiate
Initiate

 


@JessicaP wrote:

Make sure you invited other people to have access to your HomeKit accessories. Read here to learn how: Share control of your home.

 

If you're still having problems, please contact the Apple Support Team in the provided link.


They already have access to my home and can see/control everything else, even without the companion app installed.. The only things that don't show up is any of the Arlo gear. This looks more like a 'you' problem than a 'me' problem.

Highlighted
Star
Star

I would agree this is an Arlo set up issue, I have and iPhone and iPad, same Apple ID same configuration yet the homekit settings will not sync between devices, also my wife who has access to the "home" close to 20 Lutron devices, a few Hue lights, as well as iDevices plugs... the only devices that aren't syncing are the Arlo cameras. Any help would be appreciated. 

Highlighted
Initiate
Initiate

hello, just to clarify, with my personnal accout, i have 30+ Lutron switch, Eve light, Eve motion sensor, scene, and there is no issue to share anything between 4 people in my familly, on multiple device, from 4 iphones, 4 ipad, and 3 Mac... so sharing is up and running since a long time.

 

the issue is not to explain me how to share ( you can see i am a apple Fan so have done this a long time ago ), but why are the 4 camera not shared ? not on my personnal devices in my account , then why not in the familly group shared ...

 

my iphone was the device i set it up, running, all other devices ( 11 + ) are not able to see it...

 

and later we will have to discuss motion detection... not sure about it versus Eve motion... but let's fix the sharing..

 

any idea ? Arlo ? after all this time just to get the homekit running, ( thanks finally !!) let's push a little bit more and make the familly and same device sharing work... i wanted to add camera, was happy to see the homekit, but now again issue... please...

 

 

Highlighted
Initiate
Initiate

Are you running iOS 13 beta on the iPad?

im having the exact same issue, iPhone works, iPad gives that message constantly and iPad is on beta...