Arlo|Smart Home Security|Wireless HD Security Cameras

Geofencing. not working

StaceyH Aspirant
Having the same issue with the geofencing.
RChobby Virtuoso
Turned on Arlo geofencing mode,.....still broken. Wife’s iPhone does not disarm it. Turned on ifttt again which is a good solution until Netgear gets in gear.
simonpickard Aspirant

Hi James,


This is great to hear but they have been aware of the problem for over a year now (or should have been as it's been reported for that long).


It would be a great feature to get working correctly. It's been in Beta for long enough, needs to get sorted once and for all and released as a main feature.


Hopefully you can update us soon.






Jeem Apprentice
Imho geofencing has always been a hit or miss on iOS. I have my wife and I setup to trigger when we leave/return and at night scheduling takes over to arm/disarm.

GF has always required us to restart app/unassign devices and reassign/switch modes eg geo>disarm>geo ... just to get it stable.

But this last round of updates, beginning of March’18 has reduced this function to a stinking POS!!!

Slow to detect leaving/entering GF, sometime never detecting. Only detecting if WiFi is enabled, sometimes ok just on cell. Toggle modes, unassigned devices. You name it we’ve tried it


iOS 11.2.6 iPhone 6
Arlo March’18 release on app/cams/base
Model: VMC4030| Arlo Pro Wire-Free Camera
W__R Tutor
Same here. Geofencing stops working a week or so.

I’ve tried JamesC’s method of renaming the phone with no spaces or special characters but still wouldn’t work.

Please fix. This is starting to get annoying.
SallyC Apprentice

Here are the workaround that you may try to fix the issue on your geofencing.

1. Phone name should not contain any special characters under Geofencing's enabled devices.
iPhone=( Phone settings > General > about )
Android = Phone settings > About Device


Does anyone know if a dash (-) is considered a special character in this application? For example, Samsung-SM-G928V.



-S- Aspirant

+1.  iPhones show as In zone in the app (so based on the base station I would imagine) despite them receiving the notification that they have left the zone

Model: VMC3030 | Arlo Wire-Free Camera
DaHuhn Aspirant

Got the same issues.

Geofencing on iPhone 6 no longer working since last Arlo App update.

Only setting home/away when Arlo App is opened and mode is changed / opened.

In addition to that - the Arlo App Start page / device overview with the still image of the last sequence taken does no longer show the timestamp.

Before the last app update I saw something like "xy minutes ago, xy hours ago or xy days ago" on the lower left of the still images.



Fiatlux Aspirant
Removing all the devices, saving, and then adding them back in updated the in/out of zone status correctly, but only for that moment. Entering and exiting the zone after that still doesn’t cause that status to change.
johnbois Aspirant


Same issue with GF on my side. Tried removing devices, saving, powering cycle phones, re-enable devices, saving and power cycle with not change.


Maybe a simple status page or a communication sent out letting people know if issues like this are being addressed </sarcasim>.

Model: VMC4030| Arlo Pro Wire-Free Camera
GTunney Apprentice

Thought it was just my system playing up but the past week geo-fencing just has not worked at all.


Glad it looks a known issue. Seems linked to the app update a week or 2 ago.

Hannes85 Aspirant
Same here, problems started since last update. Fixed it by removing and adding users. Works for that moment but leaving and entering breaks it again. Entirely useless right now.

Problem is seen on both iPhone 6 with latest patches as well as IPhone 8 with latest patches.

Makes this a priority please, Netgear...
shelmarcel Tutor

+1 Geofencing using two iphones has worked really well & consistently for the past year or so--right up until about 2 weeks ago. Seems to be an update issue. Removing/adding back iphones and toggling Location Services remedies the issue for a very short period, sometimes. Need a fix on this

Model: VMC3040 | Arlo-Q HD with Audio
scottb08 Star

I can confirm that not only is the app almost completely useless now but the website isn't much better. Why is the website still using flash!? Come on guys, really?


I'm a software developer and I know what goes into creating a system like this and unit test it. From what I've seen there has been a some type of shake up in their development team and no one is following any type of modern testing standards. They need to roll back the recent changes until they thouroughly test the new system and make sure it works.


This is just unacceptable. They are losing their customer base. I used to recommend Arlo to everyone. Now I can't do it in good conscious.

Snn5 Apprentice
Maybe just a complete app overhaul. Like, one cannot adjust camera motion detection from Devices, rather has to be done from the Mode tab. Not intuitive.
scottb08 Star

Interesting... someone editing my post. I put "I smell a class action lawsuit brewing" at the end of my post and now it's missing. Netgear, you have a lot of loyal customers that want this system to work! Without any clear knowledge of what is happening and what the development roadmap is, their frustration is growing stronger. I suggest that you open up about that is happening over there.

Snn5 Apprentice
I noticed that too.
scottb08 Star

Complete app overhauls are fine, but they need to be feature compatible with the last app/website and of course need to be thouroughly tested! They are obviously not follow good software development practices.

snowboardjoe Aspirant

I'm having the same problem. Worked for months without any issues and then two weeks ago geofencing stopped. Removing/adding/saving phones would sometimes fix it for a day and then back to non-functional. App would always be confused with both of our iPhone X's on location. I give up fighting this.


System is almost useless now and I have no course of action on how to fix this. What changed to break this critical function?

Model: VMB3000 | Arlo Base Station
Jefffromtexas Star

[quote]Can you be more specific of what users/devices/etc?[/quote]


Seriously?  Are you with Netgear/Arlo?  Have you not read the thread?  The app is crap.  Geofencing doesn't work, and now we are being signed out after a few minute.  I cannot jut open the app and go to my cameras, I have to force close the app and reopen.  


I have a Samsung S7.  

edif30 Aspirant

No I'm not from Arlo/Netgear.  The question was to the Arlo rep.  When you click reply, it should show I replied to that last comment by them.  But doesn't look like it does.  

edif30 Aspirant

This quote to be exact...


"Engineering is currently aware of and investigating an issue with Geofencing that is affecting some users. I will provide an update as soon as I have more information.




^^^ When he says this I want to know... "what users/devices/etc"

joefan Guide

I have had the same problem for the last 2 weeks also.  The arlo app incorrectly indicates that I am "in zone" or "out of zone" when the opposite is true.  The only way to get it to correct itself is to go into the app, remove (Uncheck) both phones, exit and close the app, then open it again and add (check box) the two phones again.  At that point the app correctly indicates my location.  But my wifes phone remains "unavailable" until I go to her phone and do the same thing.

Ultimately, it does not matter, becuase when we leave the house arlo won't know that we've left unless we go through this whole thing all over again.  (Might as well just do a manual "arm" and "disarm".

Something must have changed with the app about two weeks ago, and I hope they fix it. 

Ikester Aspirant

Thanks, JoeFan Guide!


As you wrote, I am using manual arm-and-disarm technique until after this is resolved.




brookeb12 Tutor

Problem "fixed"! Check here for workaround help if you are still having issues with geofencing:

After literally months of writing on and following this thread, uninstalling and reinstalling the system, I decided to make the drastic move from my android to an iphone, hoping that would fix the issue. It did not. 

THEN I uninstalled, reset, and reinstalled the system under a totally new email address, hoping it would fix the issue. Again, it did not. 

So I did more googling and found a workaround. It's not perfect, but it works 99% of the time, and I want to share:

Download two apps to your smartphone: Life360 and IFTTT (If this, then that). Everyone in your home should join your family circle on Life360. Then go to IFTTT and set up "IF" 'last family member leaves Family - Home, "THEN" arm Arlo'. AND set up "IF" 'First person arrives at home "THEN" disarm Arlo'. I have also set up the IFTTT to work with my arlo on a schedule (so from midnight to 5am I want it set), and it works then too. 

Again, this is a workaround, but it works and have saved me from the frustration that my expensive Arlo system isn't working. It's not anything Arlo endorses, I'm sure, but hell, their system isn't functioning up to par. 

On a side note, the Life360 app is a little creepy, as it lets you track your family members. If this isn't your intent, as it wasn't mine, turn off all the alerts, like "John's cell battery is low", or "John is on the move approaching South Blvd". It's less creepy when you forget you can check in on your family. 🙂

Hope this helps a few people, and let me know if you have questions - I'll try to help!


Model: VMC4030| Arlo Pro Wire-Free Camera