Arlo|Smart Home Security|Wireless HD Security Cameras

Rich notifications not working after Android 13 update

Reply
Discussion stats
  • 27 Replies
  • 3101 Views
  • 0 Likes
  • 6 In Conversation
BEscruff
Aspirant
Aspirant
My rich notifications worked fine up until my phone updated to Android 13. A thumbnail preview appears at first but at about the time an animated preview used to appear, the thumbnail disappears and I only have a notification telling me there was motion detected.
1 ACCEPTED SOLUTION

Accepted Solutions
Paulieboy8223
Aspirant
Aspirant

This morning there was a security update pushed by Android and everything is working again. 

View solution in original post

27 REPLIES 27
StephenB
Guru Guru
Guru

@BEscruff wrote:
My rich notifications worked fine up until my phone updated to Android 13. A thumbnail preview appears at first but at about the time an animated preview used to appear, the thumbnail disappears and I only have a notification telling me there was motion detected.

Have you double-checked the subscription status for the cameras?  Just wondering if the timing of the Android update is coincidental.

BEscruff
Aspirant
Aspirant
My subscription is current. It's on auto pay. Didn't hurt to ask but I knew my notifications were still smart notifications because they were still telling me whether it was an "animal" or "person", etc. I did look after you asked to double check.
StephenB
Guru Guru
Guru

@BEscruff wrote:
My subscription is current. It's on auto pay. Didn't hurt to ask but I knew my notifications were still smart notifications because they were still telling me whether it was an "animal" or "person", etc. I did look after you asked to double check.

Ok.

 

I am thinking that the notifications are messed up, but that the motion events are still be saved in the library - is that correct?

 

There are a couple of other posts talking about issues with Android 13 recently - so it sounds like there are some bugs there that Arlo needs to fix.  I use an iPhone myself, so I can't help much with Android-specific issues.

BEscruff
Aspirant
Aspirant
That is correct.
I was thinking the same. Android 13 literally just came out so a few bugs would be expected.
jguerdat
Guru Guru
Guru

I've started checking this out to see what I see. Inconclusive so far. OP, would you provide a detailed accounting, including timing, so I can try duplicating this?

BEscruff
Aspirant
Aspirant
I figured out the problem. I tried to reinstall the app but that didn't fix it. A couple days later, I proceeded to download a video and needed to add the permission to access photos and videos to my device for that download to happen. My rich notifications have worked ever since.
BEscruff
Aspirant
Aspirant
Well, I spoke too soon. The notifications aren't working unless I've very recently logged into the app and therefore am officially "logged in". Almost every time I open the app back up now, I have to log back in which is extremely annoying. I used to only have to log back in if I'd switched from one network to another (i.e. wifi to Mobil 5G).
jguerdat
Guru Guru
Guru

Two different things, app crash and rich notifications. FWIW, I have the same app crash for the second opening of the app on Android 13. Arlo knows about it. You can quickly click on the square icon at the bottom of your screen, swipe Arlo away to force close it and then reopen.

 

As for notifications, I'm not seeing this much. Yes, I have seen it but since I really started to pay attention it isn't happening - I always see the rich notification. Doesn't help you much but it suggests a local issue rather than a specific Android 13-wide one. What phone are you using? I'm on a Pixel 6.

BEscruff
Aspirant
Aspirant
Pixel 5
BEscruff
Aspirant
Aspirant

I still haven't found a solution to this problem and it's really annoying since I really liked the "animation" to the notifications. The only camera I get the rich notifications from us the doorbell camera, the other 4 only give me an extremely small icon picture. My wife's phone gets the rich notifications but hasn't upgraded her phone to Android 13 yet.

jguerdat
Guru Guru
Guru

Not sure what the problem is but it seems local since I'm getting the rich notifications. That said, I only have PNs set up for my doorbells. I'll try setting them up on one or two others to see what happens.

BEscruff
Aspirant
Aspirant

Considering I've deleted and reinstalled the app and didn't have the problems before installing Android 13 though. I understand it may be local but what to do to fix the issue is still the question. Also, why would it matter what camera the notifications are coming from when it comes to my phone deciding whether it will display the rich notifications or not?

jguerdat
Guru Guru
Guru

After enabling PNs on a couple of cameras, I saw the same thing - just a small thumbnail. I then went into the Smart Notifications section and toggled the Animated Preview selection for a camera and tested again. This time it wasn't animated but I did get a large thumbnail with the subject (me) identified in a green box. Have you tried toggling that setting?

BEscruff
Aspirant
Aspirant

I just went into smart notifications and toggled off animated preview. I then got a large thumbnail which is an improvement but not the animated preview I receive from my doorbell camera. I then toggled animated preview back on and it went to absolutely no icon. I'm apparently stuck back at no animation in order to at least have a preview.

BEscruff
Aspirant
Aspirant

Ok. Now I'm really getting frustrated. I have cameras at two different locations in two different states so it's not like I can easily diagnose by walking in front of my own cameras.

 

My other location is being triggered after I toggled to not have animated previews. If I look at the notification immediately after it happens, I see a large icon with a green square around the subject that triggered it but very shortly after the icon disappears completely. I don't get a preview at all unless I catch the notification within three seconds!

Paulieboy8223
Aspirant
Aspirant

So I take it there is no fix to this and we are being ignored

BEscruff
Aspirant
Aspirant

That appears to be the case. I haven't heard from them about this problem at all. A notification with text telling me that there's been motion detected is almost worthless. I have to open the app 20 plus times a day now just to see if the notifications are anything to be concerned about. I'd rather take a quick glance at my phone while I'm punched in at my place of employment than push my limit with my employer on their cell phone policy.

 

My wife refuses to update to Android 13 because of this problem alone. Her notifications still work.

RMACFL
Aspirant
Aspirant

Mine started working again aprx a week ago.  Not sure what changed.  Dont recall seeing an update to the app. 

BEscruff
Aspirant
Aspirant

Which cameras do you have out of curiosity. I have Arlo's, Pro 2's, Pro 4's and a doorbell camera. The doorbell camera is the only one that gives animated notifications but not necessarily every time.

Paulieboy8223
Aspirant
Aspirant

I have the exact set up you have. I created a case with support and they say it is being looked at. I've sent logs and even a screen record video of the issues. Hopefully it will be figured out soon. 

BEscruff
Aspirant
Aspirant

Oh good, glad others are supplying them with info about the same problem. I'd created a case and sent screen shots too. Thanks for the info. 

RMACFL
Aspirant
Aspirant

I have the pro 4s along with a doorbell cam.  I'm running a pixel 6pro with android 13.

Paulieboy8223
Aspirant
Aspirant

This morning there was a security update pushed by Android and everything is working again. 

BEscruff
Aspirant
Aspirant

I'm having the same experience. My phone updated this morning and notifications have been working all day.