Arlo|Smart Home Security|Wireless HD Security Cameras

Reply
Discussion stats
  • 8 Replies
  • 1564 Views
  • 4 Likes
  • 3 In Conversation
Jefflin0411
Tutor
Tutor

Hi,
I activated my free subscription in October but I got charged for both November and December?? Can someone help me here?

8 REPLIES 8
JamesC
Community Manager
Community Manager

Jefflin0411,

 

Which free subscription are you referring to? With a ne Arlo installation, you will be able to take advantage of a 1 month free trial, but this is only for 1 month. You would be charged for the subscription after that 1 month trial ends.

 

JamesC

Jefflin0411
Tutor
Tutor

Hi James,

My arlo account is showing a 3 months trial till Jan. 2020. see my screen shot attached. This is quite confusing, I thought I had free subscription till Jan. 2020 and found out I've being charged for two months. Please take a look at the attached JPEG.

 

Jefflin0411
Tutor
Tutor

I'm also happy to speak on the phone about this...

JamesC
Community Manager
Community Manager

Jefflin0411,

 

To speak to a support agent, take a look at the options here: Arlo Support Team You will find several options for contacting support in the provided link.

 

The three month trial you get with Arlo Pro 3 is automatically applied when adding your Pro 3 cameras and would not require a credit card to be added during setup.

 

JamesC

 

Jefflin0411
Tutor
Tutor

Hi James,

Arlo's support is horrible. I can't get a hold of anyone for the past 4 days and now being charged again on the subscription fee. This is why I'm posting here at the community page. 

 

Can you direct me to a "real" agent to address this issue? This is quite frustrating and I never had this issue with Google Nest subscription.

 

thanks,

jeff

JamesC
Community Manager
Community Manager

Jefflin0411,

 

I've opened and escalated a case on this issue. An agent will reach out to you shortly.

 

JamesC

smacdonald
Initiate
Initiate

Hello,

 

I am also trying to activate my 3 month subscription. From what I've read, it's supposed to automatically activate when you setup the cameras, however, when I try to view the Library it still indicates that I need to activate a subscription.

 

Can someone please assist me with this?

JamesC
Community Manager
Community Manager

smacdonald,

 

I've opened a ticket with the details of the issue you're experiencing. An agent will reach out to you with an update as soon as possible.

 

JamesC