Arlo|Smart Home Security|Wireless HD Security Cameras
× Arlo End of Life Policy Notice
To view Arlo’s new End of Life Policy, click here.

Reply
sdmcgeown
Star
Star

I have seen numerous people posting similar issues but none of the solutions offered really address this problem. There are, at best, workarounds.

I am the main account holder for my Arlo secure account. I have a base station and three Arlo Pro 2 cameras.

All I want to do is share these with my wife's account so she can see the footage as well.

I used the Grant Access feature, selecting all the devices and base station, and it generated an invitation that was sent to my wife.

These are the three attempts we made:

1. She created an account on her App and followed the link. At the end of the process, no devices were visible on her dashboard.

2. We tried again, this time using a different email address. She used a Chrome browser this time on her Windows laptop and created a fresh new Arlo account from scratch. Again there were no devices on her dashboard (browser and app).

3. Finally, I tried myself - using my other email address as if I were a brand new user, going through the process from scratch on my Macbook's Safari browser. Again, I could see nothing appear on my dashboard.

In cases 2 and 3, I could see that the invite was accepted. In the first case (using the app on both my side and my wife's side), the invitation was marked as pending.

This shouldn't be difficult to do. We've tried the app, Windows and Macbook, so can probably rule out a specific platform with a problem.

What is the correct process to add another user? The current documented process does not work.

Thanks, Stephen

Best answers
  • JamesC
    Community Manager
    Community Manager

    For the grant access feature to allow visibility to the shared account, both users need to be on the same version of the Arlo mobile app and UI experience. We're currently rolling out app updates for iOS and Android users, but all users may not have version 4.0 available to them just yet. If you have a support ticket open, I encourage you to continue working on a resolution with the support team. Otherwise, please send me a private message and I will assist further.

    JamesC

149 REPLIES 149
firemystdl
Tutor
Tutor

@JamesC:

Please see this thread as well:

https://community.arlo.com/t5/Arlo-Secure/my-arlo-com-website-different-interfaces-for-different-peo...

We can't see shared cameras.

iOS version of app being used apparently is 4.0.2

Android version of app being used is 4.0.2

Both have different interfaces, and the iOS app on the iPhones cannot view the shared cameras.

 

njfoses
Apprentice
Apprentice

Have the "shared" person/login go to add a device in the app and choose security system. This will then enable them to upgrade to the new interface where they can see a shared location from someone already migrated to the new interface.

gsewing
Guide
Guide

I do not see the word DASHBOARD however. My app has definitely went through an update without me doing anything, reference I used to have a little bird icon now I have a HOUSE icon for the picture. I am the primary on the account my app works fine and I have full access to the system. My wife was able to accept the invite which shows it has been accepted on my side but she has no access to the system anymore. She did remove the old app from her phone then downloaded the new app. Still no access.

Sjherkes
Tutor
Tutor

I was having the same issue and struggling to get it working with inviting friends and family members.  My Arlo app did upgrade but, as stated in a previous post, I had to, addd device, Arlo security system (even though I don't have one) to switch the app to the new platform.

 

Caution, you have to have the firmware updated on all devices before doing this, you will lose any custom modes you may have setup, and you'll probably have to redo a bunch of setting.

 

I deleted and resent the invitation to a "friend" and it finally worked.

 

 

gsewing
Guide
Guide

The version showing on my app is 4.02.1_

gsewing
Guide
Guide

My version on my app says version 4.0.2.1. Secondly I followed the procedure you provided. At the end it aske me to start the upgrade. I did not click it whereas it appears to me an upgrade would be the paid subscription, which I don't need. This issue with not being able to invite other family members to view the cameras is very bad and negates the purpose of the system as a home security tool.  

Sjherkes
Tutor
Tutor

Just to clarify, my app version was 4.0.2.1 when I was having the issue adding a friend.  When I went through the add device>security system (even though I don't have a security system with arlo) it transitioned my account to the new arlo security interface, which allowed me to successfully add friends, but the app itself did not update to a new version.

gsewing
Guide
Guide

Do I have to be near my base in the wifi to go through the procedure of adding the new device or can I do it without being present at home? 

StephenB
Guru Guru
Guru

@gsewing wrote:

Do I have to be near my base in the wifi to go through the procedure of adding the new device or can I do it without being present at home? 


It needs to be done when you are connected to the local wifi - so you need to be at the home.

Daug
Tutor
Tutor

Thank you for the solution to the problem that the Arlo support staff couldn't help with.  I think I finally have the guest accounts working.

Fulano
Star
Star

I have the same problem.  I cannot share cameras. Both I and the shared account are on iPhones with iOS 16.2. We both have the same (new) ARLO app version on the phones. My friend has accepted the invite and this shows on my ARLO app. Friend has no access to anything and cannot see any cameras. We have deleted the app and redownloaded. We have cancelled ARLO account an.d started a new one with a new email address. ARLO tech confirms that my friend shows as accepted on their system.

There is one thing I did notice the other day. When I am signed into the ARLO app and then my friend signs in on her phone to the ARLO app, and we are both on the same wifi router, the ARLO app signs me out, saying I am on another device.

This is a programming error. It may be looking only at IPs , or something like that, and treating us both as one device, even though we are on two separate devices with two separate accounts.

Calloway
Guide
Guide

Hi James, can you assist? This response is not accurate as my boyfriend and I are having the same exact issues and are running the exact same versions of the app. We have noticed that for some reason though, his app has different options than mine, like 5 sections, one of which is "routines" but I only have 4 sections and none say routines. We are both on 4.0.2 (5309), Apple devices on the same OS version, we have used 2 different email addresses and while both of the invites show accepted, his app still looks like we are setting up a new home. We spent almost $1k on these cameras and they are seemingly useless - also just found out they don't work in colder temps so now that it's 20 degrees outside, we have no cameras for winter. Sad.

Daug
Tutor
Tutor

Screenshot_20221224-161940_Outlook.jpg

JeffS42
Star
Star

Hello,

 

I see no option in the app to add a "Security System" on a new account to trigger this migration. 

 

This is completely rediculous.  Can anyone assist?

Sjherkes
Tutor
Tutor

I am no expert in this, by any means, but did you have the Arlo app for a while?  If so your app version may have upgraded but your account may not have, for lack of a better word, migrated to the new interface.  This was the issue I was facing when trying to invite friends and they could not see any of my devices.  My app was the current version but the interface withing the app was not the current one until I attempted to add device, security system, and then it upgraded the interface.  I now have 5 options listed at the bottom of the app.  Dashboard, freed, emergency, devices, and routines.

 

If the main account holder doesn't list those 5 options in the app then I'd suggest the add security system process. Once that is done delete the invite and then re-invite that person.  That is what worked for me, although it may not work for you.

 

Also, my wife was having trouble seeing the devices when she clicked on the devices tab in the app, but they were listed somewhere else for her.  Turns out she had created another location called "home" and the devices I had shared were in a location called home as well.  There was an arrow next the the location name at the top of the app, indicating a drop down menu.  Once she clicked that and selected the other "home" location the devices were right there.

 

My cameras generally work in the cold temps, but my solar panels cannot charge them when the temp is too low.  I'm not saying you are not experiencing a temperature issue, as one of my cameras isn't working today, and it's 10F out, but my other 2 are working. 

 

Sorry if none of them a helps.

 

Calloway
Guide
Guide

Hey Jeff, select “add new device” first, then there will be an option for the security system. Go thru the setup until it confirms your app has been updated, then exit the setup. About a minute after this, my invitee could see the cameras on my system. 

Calloway
Guide
Guide

Thanks, @Sjherkes! The interface was definitely the problem. Everything’s working fine after the upgrade. Since their admins can clearly help, seems like Arlo is aware of the issue but doesn’t want to put it out there. The camera wasn’t working for a brief period and there was a notification that we should bring it inside due to the low temps, but it started working again about a half hour later. Luckily it’ll warm up a bit over the next few days but’s still outside & functioning properly now. 

Sjherkes
Tutor
Tutor

@Calloway seems like you're in the same arctic freeze I am currently in.  Glad it worked for you.

StephenB
Guru Guru
Guru

@JeffS42 wrote:

 

I see no option in the app to add a "Security System" on a new account to trigger this migration. 

 


It's an option in "Add Device".

Fulano
Star
Star

We have the same issue. There is no option for security system. Friends are accepted, all software is up to date. Nada. Tech support is totally useless. They send me the same email every three days, asking me to describe the problem and suggesting the same solutions we have already tried over and over again.

Calloway
Guide
Guide

@Fulano You have to select “add device” first (as if you’re adding a new camera), then there’s an option to select which device you want to add - security system is one of them. Choose that even if you aren’t adding a security system or don’t have one, it will walk you through upgrading your app interface. After it says your interface has been upgraded, exit out of the security system setup and re-try your friend invite. For me, my cameras automatically showed up on my boyfriend’s app about a minute after I upgraded my app. 

Fulano
Star
Star

Yes, yes, we did that. And no. Security System is NOT an option. That is the problem. Very buggy software at ARLO. They don't seem to know how to fix it or even go into their database and manually change a setting to push that down to us.

Calloway
Guide
Guide

@Fulano Oh no! I’m sorry, that’s definitely annoying. Have you tried to add from the website? I wonder if that makes a difference. If that doesn’t work, I hope it gets resolved for you soon. 

jguerdat
Guru Guru
Guru

@Fulano wrote:

Yes, yes, we did that. And no. Security System is NOT an option. That is the problem. Very buggy software at ARLO. They don't seem to know how to fix it or even go into their database and manually change a setting to push that down to us.


The security system won't be available to install using the 3.x versions of the app. Reinstall the app to get that option.

Fulano
Star
Star

everybody has the latest version. We just bought the camera's 3 weeks ago. We have deleted and reinstalled the new software several times. This never worked form day 1.