Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Geofencing not disarming when I arrive home after iOS app update 2.7.9

Reply
AncientGeek Hero
Hero

@Linusl wrote:
Tested some more. It bugs out if you use timeslots to 100%. Leave 1 minute somewere during the day free in the schedule and modes will work.

Example (compare to my first post/comment)

Home mode set to schedule and then
00:00-07:00 set to active
07:02-22:00 set to active Home (custom settings)
22:01-23:59 set to active

I have one minute not added in the schedule between 7:00 and 7:02. If you change that to 7:01 then mode is set to inactive instead. A mode not even being in the schedule at all.

Seen posts back in 2018 regarding this aswell. Community members recommended using 100% of the time, that is actually what is causing the problem.

So keep 1 min ”free” somewere in the schedule during the day and modes will work and you might actually spot a burglar using this expensive system.

I had a problem that could be related.  I found that using the same mode in two different time slots during the day did not work.  Perhaps if I had left a minute between them, (midnight and 11:58 pm) it would have worked.  However, I just duplicated the rule with a different name and I was able to get it to work with the same effective mode during two “midnight adjacent“ time slots as long  as they were different rules by name.

Greck Guide
Guide

Okay so I had previously reported that it looked like geofencing working using 2 iPhones and someone had commented that it would not work when I left first and my wife returned first. Well sad to say that they were right it does not work. 

 

I left first walking out of Zone. My wife followed a distance behind. My phone notified me that I was out of Zone. When she out out of Zone her phone was notified that she was out of Zone. I checked the system on my phone and both showed out of Zone and the system armed itself. I sent her back first. She went in Zone got notified and system status on my phone updated that she was now in Zoi ne. System stayed Armed. I walked back home and my phone was notified that I was back in zone. Checking system status both phones were back in zone, but system stayed Armed. I had to manually change it to Disarmed and then back to geofencing. 

 

Geofencing is still broken for multiple devices. Back to using it with just one phone for now. 

Rusty6 Guide
Guide

Same... still not fixed.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Dannybear Mentor
Mentor
Geofencing still not working for me using a single iPhone device. Works for a day then get the same issue.
This is down to the base and camera firmware in my opinion.
Boomer_1 Apprentice
Apprentice

Jessica, THEY ARE NOT WORKING. NOTHING HAS CHANGED FOR MANY OF US. It is still not arming or disarming our systems when we enter and exit - EVEN THOUGH THE Phones show the correct status either in-zone or out-of-zone.

Model: VMC4030 | Arlo Pro Wire-Free Camera
Boomer_1 Apprentice
Apprentice

I performed the same test. I have always had my wife added as an authorized user and geofencing has worked pretty solid for the past year or so, with the exeption of the occassiona phone blip. Once they did these May updates it does not arm and disarm on entry and exit EVEN though the phones report their status accurately. So I deleted my wife as an authorized user nad ran for 4 days. Worked fine every time. So rather than add her back in I deleted her app and reinstalled it and then readministered her connection. As soon as she is administered as an authorized user, it borke again. Why they can't trouble shoot this and fix it is beyond me. Except maybe it is becasue they have Drones or moderators.

Model: VMC4030 | Arlo Pro Wire-Free Camera
Bobright Tutor
Tutor

Geo used to work properly but no longer using 2 iphones. Tried all the suggestions but none work. I have to manually Arm and Disarm the sytem. Geo cannot be relied upon to work correctly! Seems like a common issue with a lot of other people. Help!

 

Model: VMC3030 | Arlo Wire-Free Camera
Ryan0751 Aspirant
Aspirant

I have Geofencing set up for myself and my partner.  The cameras are all set up under my account, and are shared with his.

 

In the Geofencing settings, it appears everything is fine.  It will show both our phones either "In Zone" or "Out of Zone".  However, I don't always see it change modes when we both leave home.

 

 

Model: VMB4500 | Arlo Pro/Pro2 Base Station
wooddler Aspirant
Aspirant
I second that. Had Arlo geofencing working fine based on location of my Pixel 2 and my wifes iPhone X for years and all of the sudden it is buggy and I keep on having to arm/disarm manually. Very poor.
Nephs03 Aspirant
Aspirant

This seems to be a known issue (IE: https://community.arlo.com/t5/Arlo-Pro/Geofencing-not-disarming-when-I-arrive-home-after-iOS-app-upd...) and I'm still amazed that Arlo have yet to respond to say "yes, we have a problem and are investigating". 

One workaround that seems to work is to log in to the Arlo app using the primary account on both devices.

Whilst not perfect, it at least has the system function as expected.

n30 Guide
Guide

Same here - after numerous troubleshooting sessions with support, I've managed to get geofencing working again on my phone, but not on my wife's whom I have granted administrator access to. She gets the zone in/out notifications, but it is not actually changing home or away modes. My phone works fine on it's own, but I think the base station sometimes gets confused when we arrive in the zone together and doesn't properly disarm, which has grown hugely irritating this past month. It hasn't worked for just her phone at all.

 

The May 21 firmware update is when this all started and it has not yet been fixed. I'm considering returning my Arlo puchase to Costco. It worked for over a year, but I'm waiting one more firmware update to see if they can fix it before returning. Arlo truly refuses to recognize the firmware is an issue.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Steve-M Star
Star

@n30 wrote:

I'm considering returning my Arlo puchase to Costco. It worked for over a year, but I'm waiting one more firmware update to see if they can fix it before returning. Arlo truly refuses to recognize the firmware is an issue.


Returning to Costco is an option for me too.  I can put the $1200 to better use.

 

Linusl Apprentice
Apprentice
Today arming when we leave the house started working (havent for many weeks) but disarming cameras when coming home that have worked now stopped working. We get the push ”home mode” and we can see phones ”in zone” but they do not change to home mode, still away mode and recording.

Maybe tomorrow it will be the other way around again 😉
Highlighted
RSC1 Guide
Guide
There was a firmware change today for the smart hub. When both devices left together it did not arm, but...when both devices returned, it disarmed and has not been doing that.
Dannybear Mentor
Mentor
Today I left home and manually armed my system and it armed correctly.
When I got back home I manually disarmed my system and it disarmed correctly.
This is how well my geofencing is working for me.
Monkey_501 Guide
Guide
@Dannybear. You said
Today I left home and manually armed my system and it armed correctly.
When I got back home I manually disarmed my system and it disarmed correctly.
This is how well my geofencing is working for me.

And I laughed and I laughed. Thank you!!
mstrong25 Aspirant
Aspirant
Geofencing is still not fixed. My wife and I both deleted and reinstalled the app on both of our iPhones and then re-enabled geofencing. Whether either of us are home together or separately it still arms the system once one of us leaves. Very frustrating because since I purchased Arlo geofencing worked without issue. Now it’s just become more of a nuisance and just drains my camera batteries more often.
Model: VMB4000 | Arlo Pro/Pro2 Base Station
zmk Aspirant
Aspirant

bear with me for info on the issue, and a resolution.

I've done a fair bit of digging into this, and despite customer support not having much information for me, they at least put me onto the right path.

 

As many people may be aware, geofencing for a single user does work reasonable effectively. Although the system is a bit slow to update (sometimes you'll receive alerts when you get home, as the geofencing takes a few minutes to realize you're home) it does do the trick, for a single user.

 

For multi-user setups, this is entirely not functional and will not work as intended. The primary user is fine, to some extent, but if both users arrive or leave at the same time, the system doesn't arm or disarm as it should. Similarly if the secondary user is last to leave, or first to come home, it doesn't arm or disarm.

 

The solution(s):
Arlo supports IFTTT. You can register at IFTTT and create an account/install "Life360" - It is a family tracking app which can more accurately (and quickly) guage if anyone has come home, or if everyone has left.

The concept of IFTTT (IF this, then that) is:
If
- this: (The last person has left home)
Then
- that: Arm Arlo

 

or

 

If
- this: (First person has arrived home)
Then
- that: Disarm Arlo

 

This works extremely well, and I've been using it for a few days now.

 

Unfortunately, Arlo doesn't allow you to set the mode to a custom mode, or schedule when returning home, only arm and disarm. Although there is little to no technical reason for them to do so, I believe they just "can't be bothered"

 

What you can do if you know how, is the following:
Use IFTTT to trigger a web hook which arms or disarms the system, you'll need to know how to create a web hook (ie. an API) and you can use the Arlo API to arm, disarm or set a custom mode.

I don't know why everyone in this forum isn't straight up recommending life360, I know it sucks having another app, more battery life drained, and more privacy issues with a secondary app, but at least it is functional.

RSC1 Guide
Guide
Maybe I’m too patient. My hub’s firmware updated yesterday, I believe. Our devices came home together yesterday afternoon, and it disarmed the system. It hadn’t done that before.

I might try IFTTT, but I’ll wait a bit for a cleaner solution. I’m actually more interested in getting activity zones going. Something tells me that attempts to fix them are what broke geofencing, but that’s a wild guess.
dazednconfuzd Aspirant
Aspirant

Geofencing still not working.....  😞

Model: VMB4000 | Arlo Pro/Pro2 Base Station
n30 Guide
Guide

I considered trying IFTTT,  but between needing two separate apps/accounts for multiple devices and not having the ability for custom modes, I put such a solution on the back burner. The simple fact is geofencing shouldn't be so difficult. I have a separate app for my thermostat that works flawlessly for multiple devices going in and out of the radius. It's visually antiquated. It also doesn't drain battery in the background like Arlo tends to, and yet still manages to detect where two devices are.

 

Thanks fo the info on web hooks though, I may look into that.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
n30 Guide
Guide

There have been two firmware updates since they broke geofencing in late May for my VMB4000 base station. The release notes for neither say anything about geofencing. I can confirm the latest doesn't fix the second (granted access) device issue, despite doing all the troubleshooting steps after the update. It's like the app knows you went in/out the zone but the profile isn't changing.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
ForzaMotorsport Initiate
Initiate

I had posted in this thread on June 10th what I did to get my geofencing to start working again after one of Arlo's updates. Since then I have seen a few posts about what account the devices are logged into, I believe my wife's device is signed into the same account as my device is, I only did this when we first set up the system about a year ago and I haven't opened the arlo app on her device since then.

 

Well yesterday my wife left the geofencing zone while I was still in the zone and it went to away mode. I had to disarm, go into enabled devices, uncheck my device, save, then go back into geofencing settings and check my device, save again, and then put it back on geofencing mode to get it to work again and show in home mode.

Aaltox Aspirant
Aspirant

Same here. Have ver 2.7.10.

At least one of two registered phones are insida geofence but cameras still keep recording/alerting. 

Extremely annoying!!

 

 

sward6368 Apprentice
Apprentice

I am cautiously optimistic.  

I have 2 users phones (mine and my wifes) set for geofencing devices each as seperate logins to the app, both apps set to always allow location services on iOS.  The apps rarely stay open on the phone.

I use geofencing combined with schedules - so at night even if we are both in zone will change to Armed

 

Since some time Saturday, geofencing seems to be working.  When both our devices are out of zone, moved to armed, returned to home mode when both return.

My wifes device has been out of zone for 24 hours (and shows correctly as out of zone in the Arlo geofencing settings).  Each time I leave and enter the zone, the status correctly changes to home or away mode, and when I check the actual mode it has updated correctly as well.

 

Staying cautiously optimistic as have not been able to test all variations of which one of our devices goes in and our of zone in various order - but working better than the last 4 weeks