Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Base Station doesn't power on after 2 years of purchase

Reply
Discussion stats
  • 5 Replies
  • 299 Views
  • 1 Like
  • 4 In Conversation
gwen584
Initiate
Initiate

I am not expecting arlo product to be defective in just 2 years. Can you help me to seek for a replacement or repair for my base station

Model: VMB4500 | Arlo Pro/Pro2 Base Station
5 REPLIES 5
StephenB
Guru Guru
Guru

@gwen584 wrote:

I am not expecting arlo product to be defective in just 2 years. Can you help me to seek for a replacement or repair for my base station


You'll need to contact support to request that - there is a link at the top right of the forum page.

 

One possibility is that it is the power adapter.  You might check to see if you have one that is compatible, and see if that resolves it. 

gwen584
Initiate
Initiate

I submitted a support case but they replied twice and they close the case without solution or answer to the problem.

How can I submit a complain to this product?

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Fedupwarlo2020
Star
Star
Arlo cameras are a POS and their equipment is faulty and defective. And based on all the complaints on this forum I smell a lawsuit coming their way. Everyone keep track of your complaints, screen shots or pics of your error messages. I am so done with them. You can go to the play store where you downloaded the app and give a review. I did twice with one star. Also call your Better Business Bureau, the Federal Trade Commission and file complaint there. Wish you the best of luck.
jguerdat
Guru Guru
Guru

An out of warranty device can't be replaced via the normal mechanisms, just like with a car or any other device. Once out of warranty, you have to determine the cost of repairs/fixing. 

 

In this case, you have to determine if it's the power supply or base that's the problem. What are the LEDs showing when connecting power? Have you checked the voltage from the power supply with a voltmeter? A universal power supply that can provide the proper voltage, power and polarity as indicated on the Arlo supply can be used if the power supply is faulty. If the base is determined to be bad, you'll have to buy a new one to get the system working.

Fedupwarlo2020
Star
Star
Well my cameras appear to be running and hopefully after this they will continue to work. I also realized that this post is in the Arlo Pro 2 category and my Cameras are Arlo Pro but whatever. Yesterday I had reached my limit, I got a generic message from the playstore instructing me to report to Arlo support which had already been done. But I hopped on the FB page and addressed the CEO & CFO in a long post. And I guess around the same time I had received an email which really showed that the left hand does not know what the right hand is doing. I was addressed by a different name, not mines then this very extensive long email with steps for troubleshooting which clearly showed my complaints were not looked at very well. The problems I was experiencing I listed and explained how frustrated I was because I was having to get up on a ladder, take down all my cameras, remove them from the base & resync. I also mentioned that I had blamed my internet company, had them come out to which it was not the problem on their end. Basically this email was telling me thing to try when I already explained what I had been doing, clearing out the cache in the app, force stopping the app, log out and restart my phone but I guess that was just another general email they send to all. Oh and by the way I do know that if you use more than one device it will kick you out, in which I only use my phone but apparently that was their explanation as to why I was getting kicked out and receiving the "Device Limit Reached" message. But needless to say I am hoping this is resolved but I do see that a few say it has not. I hope this thread does not get closed because it needs to stay open in case. As I stated my cameras appear to be finally working. Thank you Shane, Arlo Support, and I hope this is the end.