Arlo|Smart Home Security|Wireless HD Security Cameras
× Arlo End of Life Policy Notice
To view Arlo’s new End of Life Policy, click here.

Android app update Nov 21 broke app!


I just did the latest November 21 update for the Arlo Android app. After I did the update, the app popped up with a notification that said it needed new permissions and would need to push out notifications to my phone. I thought that was fine because that's the way it's always been, but I've never seen this notification come from the app. The next thing that popped up was that it was asking for permission to make phone calls, which I denied because I don't want Arlo to make phone calls for me. I only have the basic. I was told  that with the Premium plan, the app can call 911. Nevertheless, the only permissions I've ever given Arlo is for notifications, and it worked just fine before.


After a bit of troubleshooting, it's very clear that denying the Arlo app the ability to make phone calls breaks the app. I can get into the Mode screen, but then the app does not allow me to do anything further. That means I can't arm or disarm cameras. I can't set up zones; I can't do scheduling; I can't do anything that I would need to do through the Mode screen. This is true for both Arlo Q and Pro 2 cameras on my app.


I did call customer support, and he took notes, gave me case #, and said someone would get back to me. So if you are having the same problems please call them and let them know....

456 REPLIES 456

I just finished a chat with Arlo support and they acknowledged that the phone permissions/mode setting issue is a bug that they still have to address.  Until they do, they suggested using another platform for updates (PC version works) or reverting the Android app to the last October version (which works for me on my Samsung S9).  



Had the same issue.

It appears that Arlo authentication cant handle a disconnect and reconnect immediately. If I had to guess probably a caching issue.

Wait 24 hours and try again.

Solved the issue for me 

Not applicable

A couple of days ago, I turned off notifications for Arlo on my LG Android and it is now allowing me to Arm and Disarm the cameras.  It wasn't working before and caused me to use the website to change it.  They must have fixed something.  However I still occasionally get the error message that shuts down the Arlo app.  It never shows the reason and most of the time does it when I don't even have the app active.

Community Manager
Community Manager

Many of the app crash issues being discussed here should now be resolved with the release of the 2.6.4 version of the Android mobile app.


Please make sure you have the latest version downloaded and installed: Arlo Android App - 2.6.4 - 27th November 2018


We're continuing to investigate reports of other issues.



UPDATE:  I'm not sure what happened, but, he just uninstalled the app and reinstalled.  As soon as he reinstalled he was told to "Update".  He clicked the "Update" button as indicated and everything is good now? He was never offered the "Update" option before, it would just say "Arlo has stopped".  I see that the update was dated 11/27/2018.


I wish I knew how to help others in this situation, but, I'm certainly happy his Arlo app is now working properly.

Guru Guru

I would have rebooted the base before waiting for 24 hours.



Happened to me once while away from the house. Restarted the base thru the app and I was back in business.