Arlo|Smart Home Security|Wireless HD Security Cameras|NETGEAR

Android app update Nov 21 broke app!

I just did the latest November 21 update for the Arlo Android app. After I did the update, the app popped up with a notification that said it needed new permissions and would need to push out notifications to my phone. I thought that was fine because that's the way it's always been, but I've never seen this notification come from the app. The next thing that popped up was that it was asking for permission to make phone calls, which I denied because I don't want Arlo to make phone calls for me. I only have the basic. I was told  that with the Premium plan, the app can call 911. Nevertheless, the only permissions I've ever given Arlo is for notifications, and it worked just fine before.


After a bit of troubleshooting, it's very clear that denying the Arlo app the ability to make phone calls breaks the app. I can get into the Mode screen, but then the app does not allow me to do anything further. That means I can't arm or disarm cameras. I can't set up zones; I can't do scheduling; I can't do anything that I would need to do through the Mode screen. This is true for both Arlo Q and Pro 2 cameras on my app.


I did call customer support, and he took notes, gave me case #, and said someone would get back to me. So if you are having the same problems please call them and let them know....

Message 1 of 457

Accepted Solutions
Community Manager

Re: Android app update Nov 21 broke app!

Many of the app crash issues being discussed here should now be resolved with the release of the 2.6.4 version of the Android mobile app.


Please make sure you have the latest version downloaded and installed: Arlo Android App - 2.6.4 - 27th November 2018


We're continuing to investigate reports of other issues.


Message 454 of 457

All Replies

Android latest update today broke Arlo!!

Had an automatic update go through today on my Android Moto e5. Now Arlo cannot launch!!
Uninstalled, reinstalled, restarted, all the tricks and no go. This is horrible for a home security system to be inaccessible. Please tell me the team is working on a fix?
I also see in the Google play store that this update broke it completely for plenty of others.
Message 2 of 457

Re: Android latest update today broke Arlo!!

Android & iOS...seems like the entire mobile platorm "update" crashed today.

Message 3 of 457

Re: Android app update Nov 21 broke app!

Awesome.... the Arlo app notifications on the phone are no longer working either.... the Arlo app is allowed all forms of notifications, but it's not working at all. No sound, no vibration, and no notification of any form when a camera is triggered. I actually have to go into the Arlo app library to see what the cameras have captured....

Message 4 of 457

Re: Android latest update today broke Arlo!!

Update broke my Arlo system. Called support and they claimed they new nothing of it. When I go to stream a camera it locks up the app and then the iPhone XS Max. Arlo worked great before the upgrade.
Message 5 of 457

Unable to navigate to the mode display on Android release 2.6.3

Android release 2.6.3_23000 installed on 11/20/2018, now I can no longer navigate to the mode display to select either armed or disarmed.

Model: vmb3000 | arlo base station
Message 6 of 457

Re: Android latest update today broke Arlo!!

Well the devs just have to read this and all those play store reviews, I'm sure they will be aware of it shortly... I was hoping to see an update this morning. I know it's a holiday in the US but this is unacceptable to lose control to monitor my home security system for this long
Message 7 of 457

Arlo app crashes when I try and bring it up....

I got a new Samsung Galaxy J7 Crown yesterday that runs on Android 8.0.0 ....I installed the Arlo app yesterday around 4pm... Worked fine... No problems at all...I woke up this morning and every time I try and launch it it says "Arlo keeps stopping"....I looked at the app info on my phone and it says that it did an update last night around 10pm..... I've uninstalled and reinstalled... No luck.....
Message 8 of 457

Andoid app problems with new uppdate


Have used the Android app for some time without any problems to my Samsung S9 but after the update today 21 nov the app craching all the time. Have noticed that as soon as I make a call or receive a call the app crash..

Any suggestions more then delete and download again..or will there come an update soon. Dispite that the app crash and have to be restarted all the time all other functions is working.

Message 9 of 457

Re: Android latest update today broke Arlo!!

I had intermittant crashes for a while now.  After I updated my Samsung J3 this am app crashes continuously.  Tries to open then crashes with the system message that it has crashed.  Did all the standard troubleshooting, even holding my mouth different.  No change.  Sent a report through the app.  Guess I'll have to wait and see.  Great this happened on a big holiday weekend.  People leaving home without mobile security updates.  Website still working though.

Model: VMB3000 | Arlo Base Station
Message 10 of 457

Re: Arlo app crashes when I try and bring it up....


Just posted the same problem and have nothing to do with your phone. Problem started with the new uppdate.

Arlo App worked fine until the update today. Now mine crashes all the time..


Message 11 of 457

Re: Arlo app crashes when I try and bring it up....

Thank you Martin for your reply....sorry that its not working for you either, but glad I'm not the only one..... of course I saw your post after I did a full factory reset of my phone LOL..... but that fixed another unrelated issue I was having... so at least that worked out well.... thanks again....I hope arlo fixed this issue.....
Message 12 of 457

Re: Android latest update today broke Arlo!!

It works fine on multiple devices here with Android 8.0 and 9. However, I have an old Nexus 6 with Lineage 15.1 (Android 8.1) that the app crashes on when trying to open. I had assumed it was an issue with a custom ROM but it appears that may not be true. 


What OS versions are all of you using?  The Google Play Store indicates that Android 5+ is needed.

Message 13 of 457

Re: Android latest update today broke Arlo!!

Android 8 here, long term Arlo user here since launch.. worked great until yesterday when the update rolled out and completely broke everything.
Still works on an old iPad but nothing on both of my newer Android devices
Message 14 of 457

Re: Android latest update today broke Arlo!!

I'm having the exact same issue on my Samsung S7.... Worked yesterday before the update.... Won't even launch... Says "Arlo stopped working"..... I've tried everything....
Message 15 of 457

Arlo Pro

My latest update (11/20/2018) is causing the mode screen to freeze. I can see the system is armed but I can't get to the disarm mode. I am using a Samsung Galaxy S8 to access my Arlo app. Is anyone else experiencing this issue?
Message 16 of 457

Re: Arlo Pro doesn't even come up for me... Just crashes every time... Says "Arlo stopped working"..... Ever since the update last night... What I've noticed from most of the complaints is that it's mainly effecting newer Samsungs.....I just bought a Samsung Galaxy S7 Crown that's running 8.0.0
Message 17 of 457

Re: Android app update Nov 21 broke app!

After the update Arlo app crashes all the time for me as well. Each time when you make or receive a call the app crashes. If app not running you will not get any alerts or alarms...Really bad and support does not act. So disappointed. Believe it has to do with the new demand to access the phone. Have to swift over to email notifications since app does not work.
Message 18 of 457

Android app crashes on launch (2.6.3_23000)

Since the update for the Android app to version 2.6.3_23000, the app will no longer launch without immediately crashing. Clearing data and/or reinstalling allows you to get to the login page, but will start crashing again the moment you login.


Many other users are also experiencing this issue as evidenced from the sudden influx of negative reviews detailing as such (including custom notification sounds no longer working).


Netgear's quality control for this update has been abysmal. For such a crucial app that people rely on to keep their homes secure, updates which make it completely unusable should never get to release. Please fix this ASAP!


For the time being, I have managed to rollback to 2.6.2_22800 via APKMirror (which works fine), and have disabled auto updates for Arlo via Google Play Store, but this is not ideal and I certainly shouldn't need to do this.


Also, can you stop locking your threads in the Firmware Release Notes forum? This post could have been made as a reply to , but instead we have to post in random subforums for various Arlo products.

Message 19 of 457

Re: Android app update Nov 21 broke app!

I agree that it is broken.  I do not do notifications so denied the request to give Arlo permissions for the phone.  Now I have lost the ability to see any mode for all of my bases, both camera and lights.  This is exceptionally poor design.  I would hope that Arlo rolls back this version until they get it right.  I am beginning to think that the Arlo designers and architects do not use their own products.  The last few releases have not been improvements and instead have appeared to be change for changes sake, at least from a user standpoint.  As a retired developer, don't they have any beta testing with actual users and customers before releasing a new version on their full customer base?  

Message 20 of 457

arlo android app keeps crashing at startup

As of this morning the Android app does not work on my phone - It was working fine yesterday, and I use it everyday, so I suspect an update broke it.  It is version 2.6.3_2300.


The app crashes right at startup, screen goes white, then black with the "Arlo has stopped working" message.  Every retry get the same result.  I tried restarting my phone, uninstalling / reinstalling the app then restarting the phone, restarting the base station and restarting the phone - same results.  I checked the permissions of the app and gave it all permissions available - again, same thing.


My phone is an LG Q6.  The webpage works fine: I still get push notifications on my phone if motion is detected, but I can't activate/deactivate/monitor my cameras using my phone anymore (making my entire system pretty much useless now).  


Anyone else has a similar issue?



Model: VMB3000 | Arlo Base Station
Message 21 of 457

Re: Android app update Nov 21 broke app!

Having the same problem. When I try to open arlo i get the message "Arlo has stopped"

Model: VMC4030 | Arlo Pro Wire-Free Camera
Message 22 of 457

Re: arlo android app keeps crashing at startup

Exactly the same issue here. Immediate crash of Android App 2.6.3 upon startup. Tried uninstalling, restarting phone, reinstalling. Immediate app crash after I enter login/PW information. Stop app. Start it again -- immediate crash ("Arlo has stopped"). Same every time.


Running Android App 2.6.3 (11/21 release), Android 8.0.0., Galaxy J3V


I'd sure like to install the previous version, which was running fine for me. Any suggestions on where/how to get it?

Message 23 of 457

Re: Android app crashes on launch (2.6.3_23000)

Thank you, I had some issues as well at start since today. 

App keeps on craching at start. I did roll back to 22800 from your website...(hope it safe tho..)

Now I can access my Cameras.

Thank a ton Mate ! +1


P.S. You need to keep the older APK available for users , just in case stuff like that happens... :-/


Using 2.6.2_22800 right now.. not going to update.... (Android OREO 8.1/Unlocked)

Message 24 of 457

Re: Android app crashes on launch (2.6.3_23000)

It's only happening to some devices. It works fine o 2 devices for me but not on another. I've reported it. This is a holiday weekend so no idea what kind of response we'll get.

Message 25 of 457