Arlo|Smart Home Security|Wireless HD Security Cameras

"Firmware has been updated" showing on my Arlo iOS app. Not seeing it on web client.

Reply
Discussion stats
Best answers
  • JessicaP
    Arlo Employee Retired This widget could not be displayed.
    ">
    Arlo Employee Retired

    Our development team is still looking into this issue. We'll be sure to provide any new information or update when we hear back from them. We appreciate everyone's patience regarding this issue.

  • JessicaP
    Arlo Employee Retired This widget could not be displayed.
    ">
    Arlo Employee Retired

    The development team is investigating this issue. We will provide an update as soon as we have more information to share with the community.

srandall25
Apprentice
Apprentice

6 months later and 'The development team is investigating this issue.' ? Still?

ant
Prodigy
Prodigy

Ditto. 😞

EngineerDye
Initiate
Initiate

I believe I found what is causing the issue but it seems to be a firmware length issue. If you open the iOS app the and click on the setting symbol of camera 1, Click device info. You are now seeing the firmware, hardware and serial number. Next minimize the app and then re-activate (return to home and the swipe up to reopen the app on iphone XS). You will see the firmware filename expand out and then shrink back in like the filename is 3 digits too long to have to update everytime we open the app. I figure I would try to support given it taking so long. Maybe you could push out another firmware update with a slightly shorter filename. 

Model: VMC4030 | Arlo Pro Wire-Free Camera
srandall25
Apprentice
Apprentice

I actually don't see how this is related. 

CALoski
Initiate
Initiate
How many months of waiting patiently do YOU think is reasonable??!! All we get is “still looking into this issue”—please look harder and deeper. Now I know why my neighbors switched to Ring.
EngineerDye
Initiate
Initiate

My reply was meant for the development team. It doesn't do us as users any good given the issue is on iOS devices (must be app related like previous replies imply) and they must need a little support. I believe maybe two weeks was a good time limit to address this issue as it can't be a very big issue to fix. I say that because it all started when we updated our cameras to the new firmware. 

Model: VMC4030 | Arlo Pro Wire-Free Camera
gattaca
Star
Star

I posted what worked for me on stopping these annoying messages earlier.  But I'm unsure that worked for other people that tried it - YMMV.   Maybe still worth a shot b/c I've been good since then and they have not returned - knocking on wood.  I'm 100% sure it was introduced by the firmware updating but it is also tied to the app... probably a corner case that's darn hard to reproduce. 

 

Msg 24 -> https://community.arlo.com/t5/Arlo/quot-Firmware-has-been-updated-quot-showing-on-my-Arlo-iOS-app/m-...

Stay safe, stay alive.  Peace.

srandall25
Apprentice
Apprentice
Your solution doesn’t involve anything that would write back to the file or app. It’s just a sequence for checking the firmware version number. I tried it and when I close the app altogether after doing your sequence, and reopen the app, the same thing happens.
ant
Prodigy
Prodigy

Is it me or does gattaca's link doesn't click? 😞

mspic_humph
Star
Star

I’m not sure if this is an iOS issue. I don’t have this problem on my ipad6. It’s  only on my iphone11. 

Model: VMB4000 | Arlo Pro/Pro2 Base Station
gattaca
Star
Star

Sorry.  IDK... referring to links in this forum board behaves oddly.  I'll try again below.  If not just goto page 1 of this thread and see message # 24.

 

https://community.arlo.com/t5/Arlo/quot-Firmware-has-been-updated-quot-showing-on-my-Arlo-iOS-app/m-... 

 

IDK if this will work for everyone.  I'm reporting what worked for my cams/setup/iPhone after that FW update and those messages.  These messages no longer appear on my iPhone when checking the cams and everything appears normal.   It's not the first time I've had trouble after Arlo's firmware updates. I had to do a similar procedure a few years ago to recover then too. That time I think all of the cams motion sensors stopped recording vids.  

Yeah it was a big PITA.... but that process fixed it then too.

I agree, Arlo Engineering needs to fix this PRONTO.  It appeared after that FW update.  Good luck - YMMV.    Stay safe, stay alive. Peace.

revangel
Star
Star

At last it seems was fixed in yesterday’s new iOS app’s version!

JessicaP
Arlo Employee Retired

This issue should now be fixed on the the latest version of the Arlo iOS app, which is 3.5.12. Please make sure to update to the latest version through the iOS App Store.

 

If you're still experiencing this issue, please let us know.

 

EDIT/UPDATE (Jan 11 2022): Some users are mentioning that they're not seeing version 3.5.12 on their iOS device. You may need to update your Arlo iOS app manually, which you can refer to here: How to manually update apps on your Apple device

George-F
Tutor
Tutor
There is no update available and I am on 3.5.10 so it isn’t fixed
giostefani
Tutor
Tutor
Well, I was able to upgrade on my iPhone to 3.5.12 and it resolved my issue.
Model: VMC4040P | Arlo Pro 3 Wire-Free Camera
mspic_humph
Star
Star
Both my ipad6 and iPhone11 are on 3.5.10. However, I am not having this issue on my ipad6. I find no upgrade to 3.5.12 in the App Store. Am I looking at the wrong source for the update? Also, the Arlo account is in my husband’s name. My ipad6 is setup in my husband’s profile. Again, no issue there. My iPhone is set up in my profile where I am added as a guest. Problem on iPhone.
Model: VMB4000 | Arlo Pro/Pro2 Base Station
giostefani
Tutor
Tutor

I’ve attached a screenshot of my current installed apps awaiting updates on my iPad Pro. You can see that 3.5.12 is awaiting an upgrade. Try clicking on your profile (or husbands) from the Apple Store (upper right of screen). Once that opens, hold your finger on the screen and slide down which will refresh your apps.  You should see the update then. Same process from your iPhone.  Now, there might be an issue because you're a "Family Member" (e.g. Guest) on your Husband’s account. 

mspic_humph
Star
Star

Got it! It needed the refresh to find the awaiting updates. Thanks. Now fingers crossed the update corrects the issue. 

Model: VMB4000 | Arlo Pro/Pro2 Base Station
mspic_humph
Star
Star
Voila! It’s gone. Yay! Thanks
Model: VMB4000 | Arlo Pro/Pro2 Base Station
George-F
Tutor
Tutor
My husband just checked his Arlo app, because his is primary, and there is no update for 3.5.12 nor is there one on mine!!!
giostefani
Tutor
Tutor

It has nothing to do with who is "Primary" on the Arlo app or not.  This is an Apple app store update issue.  What version of iOS are you running?  Model of iPhone?  Do you have app updates turned off?

George-F
Tutor
Tutor
I am on IPhone 13 Pro Max And updates automatically run there are no updates for 3.5.12
StephenB
Guru Guru
Guru

@George-F wrote:
My husband just checked his Arlo app, because his is primary, and there is no update for 3.5.12 nor is there one on mine!!!

If you are running iOS you can open the app store, and search the app (as if you were doing a new install).  You should then see an option to update it.

 

Otherwise, wait until the iPhone gets to it on its own.

dcfox1
Master
Master

@George-F  Try uninstalling the App then download it again from the store and the latest will install. I needed to do this a few times in the past when it didn't show up in updates.