Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Arlo Schrdule not working

Discussion stats
DjIntrigue Tutor
Are you going to leave out the part that Arlo also said that it's something on their end and they are working on an update? If your going to help people about this, then also let them know that everything is just a band-aid fix thats just temporary and still may not work until Arlo fixes the issue.
nappleton Guide
One Google Pixel XL running Android P and one iPhone X running iOS 12.
nappleton Guide
Any updates on this issue?
Jakelly Initiate

Just purchased a set of three cams with a base (Arlo Pro) from Costco.  THIS is the exact problem I am having!  So frustrating.  Is it time to return and leave a bad review or is Arlo doing something about it?

The schedule works fine, but I don't want to leave my house unmonitored when I leave during the day.  Leaving it on is fine, but then I have literally dozens of alerts as my kids come home from school or I pull out my garbage cans.  


I NEED the geofencing plus schedule to work!  


I have tried a ton of stuff, including the following:

  • Multiple resets of the base and the cams.
  • Remvoing the app and data from my phone. 
  • Reducing the number of phones that are geofencing down to just one.
  • Changing which phone is geofencing.
  • Setting it up from the app and/or the PC
  • Factory resetting and trying the whole thing again.

I literally told my Mom to buy this system too.  Are we both returning it?  How can this "feature" be unusable for so many people for so long.  Any help?

OurHattonHome Star

Jakelly, with the last update it appears that Geofencing is finally working. There are a few things you need to keep in mind when you are using this feature. For instance you need to make sure that Arlo is allowed to see the GPS and the biggest thing is that Arlo needs to be active in the device, which is the same as running in the background, while you have the app set to Geofencing. The reason for this is Arlo needs to see the status of the GPS and it will not see anything if the app is not running. I always check Arlo when I leave to make sure the required switch occurs. If it hasn't then if you set the Mode to armed if leaving and disarmed if returning then back to Geofencing that should get it to set correctly. This can be a pain at times, but necessary if you want the system to work the way you want. Hope this helps.  

Verymad Guide
My app stops running after a period of time and therefore geofencing doesn't work.
Bostro Star
Still same issues. Im getting notofications when I remove zone and Arlo App when I go to geofencing correctly see phones being in or out zone... but id does nit change its behaviour 😕 Any ideas how to solve it?
Matchpoint Apprentice

OurHattonHome, what's the point of Geofencing, if you have to keep on adjusting it when you're in the zone and away. Might as well remove it and just set it manually everytime. It used to work ok before, it detects when you're away or in the zone and changes the mode according to your setting but it hasn't work right in the last 3 months. I just set mine to scheduled and that is kind of ok because I know approximately when there's gonna be someone at the house and I just use it to do manual live view to check.

Model: VMC4030 | Arlo Pro Wire-Free Camera
OurHattonHome Star

Matchpoint, You are correct. Having to manipulate Geofencing at anytime after it is selected is not ideal. I was only trying to answer the question as to why it would not be working and what to do to get it to work. I've always had an issue with Geofencing working if the app was not running the in background. If you only have had an issue with it for a few months count yourself lucky. I just wish it was working correctly so once set I would not have to fool with it ever. But it has been over 6 months since the issue was reported with nothing has been done about it. Just wish they would fix it so I can use it. And I have to stand corrected. Geofencing is NOT working correctly anymore. I tested it the other night when it showed as being armed as set in the app but nothing was being picked up and the lights on the camera would not come on as they are supposed to when armed. I wish they would just get rid of Geofencing since they are unable to make it work right.

ArloAlex17 Aspirant

New Arlo user and this is happening here too...on a Geofenced schedule and everything is disarming (all six cameras) at 12 midnight when it should be armed. 

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
Scalo008 Aspirant
Hi I have my Arlo Security set to Geo-fencing .

Iin away mode it is set to armed
In home mode it is set to schedule

When home the schedule doesn’t seem to always work and the system states it is disarmed albeit according to the schedule it should be armed.

Can anyone help, thanks
Model: VMS3230|Arlo Smart Home
Mstams Aspirant
Similar issue here. Cameras should be armed based on schedule but are disarmed. This was working up until a day or two ago. Glad I checked. I really hate this system and wish I went with another product.
Model: VMC4030 | Arlo Pro Wire-Free Camera
Guru jguerdat Guru

Use a browser when checking/setting modes, rules and schedule. It works 100% of the time while the apps have display problems making you think one thing while another is actually true.

Bostro Star


1. Browser is blocking me with Geofencing setup as it is only available in the Mobile App.

2. I do not care what realy web browser or app is showing as a status when in the moment when Im at home with both phones in the zone I do get all notifications when those should be off, just recording. Based on cameras behaviour, recording and notifications I see does it switch to the right mode or not.


But I will try this later today over next few days, maybe some updates in soft took place.



totempty Aspirant
Using latest firmware on cameras and Arlo Pro 2 base. Using latest Android phone app. I have set mode to be Geofencing, and the app seems to detect location of the two (Android) phones as it shows that we are "in zone". When we are Home or 'in zone', it is set to be in "Schedule" mode. the "Schedule" mode is set to go "Armed" from 10pm - 11:59pm and 12:00am - 6:00am. every day, It is currently 1am, however, it seems to not be in Armed mode (when it should) as I went outside and got in front of the cameras but there was no pushed notification or recording that happened. When looking under the "Mode" tab in the Android app, the row for the Arlo Pro 2 base just shows the icon for the geofencing, should it show the status/mode that it should be in? Any idea of what's happening and how to fix it? Thanks
nappleton Guide
Has anyone seen a meaningful response from Arlo on this?

ShayneS from has responded to my post with some initial follow up questions, but nothing since then (early Nov).

It's been a couple of months since my original post, pretty frustrating!
Bostro Star
After few tests and making the Geofencing working back for this is what may help you.
I have geofencing mode whichbis switchibg between Armed and my Custom mode. I setngeofencing range to medium (i reccomend to try large). Small radius is not allowing the system to switch fast and Im at home and software still works in the previous mode causing strange behaviour. Give the system more time so go to medium or large radius for geofencing and you will switch modes before entering the house doors. I also have mode switch notifications so I know when the mode switch takes place. Is shifts to Armed Mode when Im leaving house in the same place very quickly. But for sure I see that switching from Armed to Custom takes longer. Very often when Im opening garage doors, but sometime (maybe depends on the LTE coverage) it will switch few houses ealier. Also when I did switch to Geofencing Mode Im not playing with changing the modes manually at all. My wife second phone is added and all works well with both phones. Good luck.

BTW: why nobody is responding from Arlo, ... I hope they all worked on the software updates, which I believe took place few days ago. I for sure know it fixed my Arlo Door issues with camera not turning on automaticly when I answear door bell call. 🙂

SteveRy Aspirant

Everything was working fine until a few months ago, but now it's not recording/activating in certain circumstances.


Normallly, it's set to geofencing with a schedule for overnight.

During the day when we're at work, geofencing sets it to armed and it successfuly records

On a night, when we're at home, geofencing set it to disarmed except for when there's a schedule.

The schedule is set so that between 11pm and 6am it should be armed.  However - it never records (even though I know it should have done).  The schedule definitely sets the system to armed, but it just doesn't actually record anything.

If I manually set it to armed overnight, it successfuly records.


Why isn't the armed via schedule working?


Model: VMB3000 | Arlo Base Station, VMC4030 | Arlo Pro Wire-Free Camera
SteveRy Aspirant

Apologies if it's bad form to answer my own question!


Having looked further through the forums this morning and doing some more testing it seems like this is the same problem that others have.  i.e. geofencing in "home mode" is not forcing the schedule to go to armed even though both geofencing and schedule modes work independently.  Lots of other people seem to have that same problem, and it used to work until some random update last year.


Any update from Arlo/Netgear as to when they're going to fix it?

tmaddoux Aspirant

Hardware H7
Firmware 1.3.314

Samsung Galaxy S8 phone

App ver. 2.7.1_23406


The geofencing function seems to be inconsistent in its operation.

Sometimes it appropriately switches modes and sometimes it doesn't.

So does the app need to be running in order for the geofencing to work??


Model: VMC3030 | Arlo Wire-Free Camera
Ward_home Initiate

I have encounted an issue with the system when using Geofencing with a schedule allocated to the home mode, the system currently is not arming based on the schedule leaving the system inactive overnight.


The system was working absolutely fine and following the required settings until I disabled several cameras and set the mode to disarmed due to some requirements at home. Once the settings were reactivated the system has not followed the schedule when in home mode, the geofencing works seems to work correctly.


I have tried rebooting the base unit, disarmed and rearmed the system, reallocated the modes and nothing seems to switch it over, has anyone experienced similar issues and can advise how to correct?


Base Station - FW (Hardware VMB3010r2)

Cameras - FW 1.3.314 (H7)

Model: VMS3330|Arlo Smart Home
ShayneS Arlo Moderator
Arlo Moderator

Hi @Ward_home


Have you tried to set the mode through the web portal then reboot the base station and test again? 

Kslynch Aspirant
I’m having the same problem, it is supposed to be armed overnight according to my schedule (and I’m in geofencing mode set to follow a schedule at night), but instead it is entirely disarmed. I’ve tried rebooting, completely rescheduling everything, it still isn’t working.
jdshep44 Aspirant
I am using geofencing with a schedule when I am at home. I currently have a schedule set from 21:00-23:59 and then 00:00-05:00. My issue is the system is working from 9pm to midnight but not from midnight to 5am. Any ideas?
Kslynch Aspirant
So after further investigation, mine is also working up until midnight but then the midnight to 0659 is says disarmed despite being set to be alarmed by the geofence scheduled home mode. No clue why, will hope we get some response.