Arlo|Smart Home Security|Wireless HD Security Cameras
× Arlo End of Life Policy Notice
To view Arlo’s new End of Life Policy, click here.

Geofencing is DNF STILL!

Discussion stats

So they think they fixed all the problems caused by the base firmware update by updating the cameras (instead of fixing what they broke, they layered a patch on something else).


But the geofencing is still broken. I have 2 houses, both with Arlo base stations. My phone and my wife's phone are set up for geofencing at both locations. Geofencing has not worked since May 22nd.


I am currently sitting at home. The vacation home is currently set to geofencing, but is not armed. I armed it manually, then set it back to geofencing. I get a notification that the system there is now in away mode. But when I look at Devices the cameras are disarmed, when I look at mode main screen it shows Disarmed. When I look at the geofencing setup it acknowledges that both devices are not in zone.


So I look at Home, both devices are in zone, but the current mode is Disarmed (geofencing mode should be front door camera armed, rear door disarmed). Manually set it to armed, then Geofencing. Get the notification that it is in Home mode. Go to the Mode main page and it is showing Disarmed, and of course under devices all cameras are disarmed.


I am running the Android app version from 7/30/18 (in my opinion the last one that was bug-free) but my wife is running the 5/23/19 version. Surely one would work correctly.


It's really quite funny, if you think about ti.

Geofencing is not working for me as it has been for the last couple years. This started a couple months ago and my environment is not unique. 1 system, 4 cameras and 3 iPhones for geofencing. This system has been so buggy since the very beginning. How can this be called a security camera system when it can’t be relied upon consistently. They do a firmware update to fix something and end up breaking something else. As I’ve said before, very disappointed I chose this system and would not recommend it to anyone.

Please reply to this thread when the issue is fixed.  I really depend on my geofencing so having it work properly is very important.  I notice that geofencing has issues very often which is very disappointing.  


When asked by friends to rate Arlo's products, this is by far my biggest complaint.


I totally agree with you. Geofencing malfunctions frequently.  You would think that techical support would be on top of this by now but they are not.  Very disappointing.  


Base Station

Hardware: VMB4000r3



Cameras (x2)

Hardware: H4



2 Devices set up for Geofencing.

Device 1 (Account Holder): Huawei P30 Pro - app version 2.7.11_25630

Device 2 (Granted Access): iPhone XS


Same issues as described in the initial message in this thread.  Both devices have left the zone but Arlo has not changed to its "Out of Zone" settings.


In Zone: Scheduled; Disarmed between 5am and 11pm. Armed between 11pm and 5am.

Out of Zone: Armed


When you open the Geofencing settings and look at Enabled Devices, both ticked devices show as "Out of Zone" but the base station is reporting itself as Disarmed.  If you change the mode manually to Disarmed and back to Geofencing, the status will automatically update to Away as it should have when the second device left the zone.


I would like to be included on this survey so that I can get this resolved.  This feature is the reason behind me purchasing an Arlo system.





I have had the same problem for months and have the same "unique" situation as most others, although it is likely the most common environment I can imagine for an Arlo setup:  2 iPhones set up with geofencing for one base station and 4 Arlo cameras.


The app shows when each phone is in or out of zone correctly, but the mode does not update!!  The only way I can get it to update is if I manually update it, or toggle another mode then go back to geofencing mode.


This app definitely has some bugs! Squash them please!! I see this exact same problem posted on all Arlo communities.

I totally agree with you. I have 2 base stations and 7 cameras. 2 iPhones 1 primary account and a grant access account. What I have noticed is that if the grant access account is the last person to leave, or the first person to enter the Home zone, Arlo fails to arm or disarm, however it does work when the primary account is the last to leave / first to enter the Home zone. If we both leave together / return together then it may or may not work correctly depending on which phone gets registered first. Would be interesting to see if this matches your experience. The problem seems to exist across the entire geofencing product range and is certainly overdue for a fix.
And don’t forget it’s still beta, absurd. It’s been beta for almost 4 years now. Mine won’t even update even if you change modes. Only if you are logged into an account will it update when changing modes. If you share a base station and have two accounts the other basestation no longer reacts to geofencing something it used to do for several years. There’s only one explanation for all this lock of responsiveness, I fear this company is in trouble and soon we will all get some bad news. I truly hope I am wrong.
Arlo Employee Retired

This week we deployed an update on our cloud server to improve geofencing reliability when multiple users are enabled. With this update, when one mobile device exits the geofencing zone, the Arlo Base Station or Arlo SmartHub now detects and accurately sets the geofencing state based on the location of the additional/second mobile device on your Arlo Account. 


We previously mentioned we would be sharing a survey in order to collect more detailed information around the use of our geofencing feature. The information gathered in this survey will help our team to enhance and optimize the geofencing feature for a wider variety of unique user environments. We would sincerely appreciate it if you would participate in the survey by clicking on the link below:


Arlo Geofencing Survey


We are grateful your continued patience as our team works to optimize this feature for all users and your feedback is always welcome. Our team will continue to provides updates in the Arlo Community when we have additional information to share. 


Thank you,


Arlo Team


Note: We will provide updated information here as it becomes available. Marking solved to float the latest information to the top of the thread.


Obviously very early days yet, but I observed that my system disarmed itself yesterday when the first member of my family arrived home, and both armed and disarmed itself this morning when a different family member was last out of the house and then returned home a short while later.  


It would be interesting to hear whether other people can see an improvement?


Finally, thanks for the link to the survey as I'm sure there will be quite a few of us interested in completing that.


Mine seems to be working now!!  Hooray!

Seems to be working again hopeful that it is fixed now for good. Finally!!

I have never been able to get Geofencing to work.

I watched in hope as all the emails from the forums rolled in over the last Geofencing debacle. And reports seem to show the problem has been fixed.

Now I should point out my wife and I are both on Android. I am the administrator of the account using a Samsung S9+ android 9.0, running app versio 2.7.12_25660.

My wife has been "granted access" and is an "enabled mobile device". She is using an Oppo A75 on Android 7.0.


Our base station is a VMB4000r3 running Firmware


Names of enabled Mobile devices are SteveHouston     and     RainHouston.     No spaces, characters or numbers.



Home mode is "Schedule"

Away mode is "Custom"


We have rebooted base stations, re have removed the apps from phones. Cleared caches, restarted and reinstalled.


There are times when we are both shown as unavaialable when we are clearly in the zone. Then we reboot everything and we are shown in zone. 

Eureka, we cheer, its working. But no...Next day it never shows us leaveing home.(although Geofencing is selected).


Both phones use accurate Location on "high accuracy." Both phones have granted location access to Arlo. Both phones have zero battery saving functions activated. Both phones have Wifi, Mobile data, Blue tooth and Location On. Both phones even utilise location sharing in Google maps.


But still geofencing does not work.

I can tell you that...

I have 2 older devices (not selected) as shown in above jpeg  that I can not remove from the list of enabled mobile devices.


We can not type in our full street address. Only our road name is found.


But when I push the "compass" icon, the app finds me to a high degree of accuracy. Yet doing this makes no difference to my "unavailable" or "

In" or "out of zone" staus.

I even tried this whilst in Hong Kong, (we live in New Zealand) and it still showed me "In Zone".



We never log out, unless we need to, ie turn off phone. We do use "Do not disturb" but are generaly at home when this mode is used.


If I do force a log out. (3 dots top right/Log out. "Are you sure you want to log out?'  then click OK) I then log back in using my fingerprint. A message then appears Fingerprint for "Arlo" unlock Arlo is displayed. I then use my fingerprint to acces Arlo.


As I said, I never log out unless I have to. So why does the Arlo app ask me to use my fingerprint to unlock Arlo when accesing the app. After not being used for a while. This is exactly same process as logging in.


Is Arlo logging me out after not being use for a while? Therefore stopping geofencing from functioning.



On the positive side, whilst in China. We managed to capture on camera someone breaking into our and neighbours car. Arlo notified us someone was in our drive. I was able to call our Neighbour in NZ, who passed on screenshot to police. Who within 45minutes arrested a young man and charged him with unlawfull tampering and theft from 7 vehicles in our neighbourhood


So, we love Arlo 98%, just need geofencing to fuction.


Please....What am I doing wrong, what have I missed??