Arlo|Smart Home Security|Wireless HD Security Cameras

Defective arlo base station power adapter

Reply
Discussion stats
  • 5 Replies
  • 2793 Views
  • 1 Like
  • 5 In Conversation
Keem
Follower
Follower
I received a faulty power adapter. After receiving my arlo, i plugged in the base station and tested all the cameras. All was good till i smelled something burning. To my surprise, the smell came from the power adapter. I quickly turned off the power and when i touched the adapter, there was sticky, clear liquid oozing out from the adapter seal. I am clueless. What happened? Did the insides get melted? 😕
5 REPLIES 5
TomMac
Guru Guru
Guru

Keem wrote:
I received a faulty power adapter. After receiving my arlo, i plugged in the base station and tested all the cameras. All was good till i smelled something burning. To my surprise, the smell came from the power adapter. I quickly turned off the power and when i touched the adapter, there was sticky, clear liquid oozing out from the adapter seal. I am clueless. What happened? Did the insides get melted? 😕

Prob... it may have been a leaky capacitor or insulation from the wire, etc... It really shouldn't even get warm

 

Def, contact Netgear for a new one

--------------------------------------
Morse is faster than texting!
--------------------------------------
jguerdat
Guru Guru
Guru

Since it seems to be a new system, return the whole thing for a replacement system.

JamesC
Community Manager
Community Manager

Keem,

 

I will reach out to you in a private message to further investigate this issue.

 

JamesC

dalert
Initiate
Initiate

Hi James

 

Would it be possible to contact myself as well as I have a similar issue with a burning smell (minus the stickiness). My base station has no lights on, have tried different powerpoints and ports in modem but will not power on so seems to be the power adaptor.

 

Thanks heaps!

 

 

jguerdat
Guru Guru
Guru

The answer will always be the same - create a trouble ticket. Use the Support link at the top here and then Contact Support on the right. You'll need an RMA and that's the only way to get it.