Arlo|Smart Home Security|Wireless HD Security Cameras
× Arlo End of Life Policy Notice
To view Arlo’s new End of Life Policy, click here.

Reply
Discussion stats
  • 8 Replies
  • 956 Views
  • 3 Likes
  • 5 In Conversation
Joe_Wi
Follower
Follower

I cannot login to the arlo site. This started a few days ago. I get the following error in my browsers:

"Secure Connection Failed

An error occurred during a connection to arlo.netgear.com. Cannot communicate securely with peer: no common encryption algorithm(s).

Error code: SSL_ERROR_NO_CYPHER_OVERLAP"

 

Anyone been able to fix this?

TIA

1 ACCEPTED SOLUTION

Accepted Solutions
StephenB
Guru Guru
Guru

@Joe_Wi wrote:

I cannot login to the arlo site. This started a few days ago. I get the following error in my browsers:

"Secure Connection Failed

An error occurred during a connection to arlo.netgear.com. Cannot communicate securely with peer: no common encryption algorithm(s).

Error code: SSL_ERROR_NO_CYPHER_OVERLAP"

 


Use my.arlo.com.

 

arlo.netgear.com is left over from the period when Netgear owned Arlo.  That ended in 2018.

View solution in original post

8 REPLIES 8
StephenB
Guru Guru
Guru

@Joe_Wi wrote:

I cannot login to the arlo site. This started a few days ago. I get the following error in my browsers:

"Secure Connection Failed

An error occurred during a connection to arlo.netgear.com. Cannot communicate securely with peer: no common encryption algorithm(s).

Error code: SSL_ERROR_NO_CYPHER_OVERLAP"

 


Use my.arlo.com.

 

arlo.netgear.com is left over from the period when Netgear owned Arlo.  That ended in 2018.

greenweenie
Star
Star

The request still "times out" using arlo.com - tried 3 different browsers

dsfenton
Guide
Guide

Same problem.  Android phone app works but website doesn't.

greenweenie
Star
Star

Seems like it's been fixed - I can now login after 3 days
https://my.arlo.com/#/login

siren
Aspirant
Aspirant

I have tried my.arlo.com and keep getting "The request timed out."  no matter what web browser I use.  

StephenB
Guru Guru
Guru

@siren wrote:

I have tried my.arlo.com and keep getting "The request timed out."  no matter what web browser I use.  


Is this during the 2 factor authentication?  Or are you not getting that far?

siren
Aspirant
Aspirant

I'm not getting that far.  I don't know if there has been an update server side recently because I USE to be able to login, request a code for 2FA.

StephenB
Guru Guru
Guru

@siren wrote:

I'm not getting that far.  I don't know if there has been an update server side recently because I USE to be able to login, request a code for 2FA.


FWIW, I can log in - just confirmed that using Chrome.

 

Did you try the usual step of clearing the browser cache?  And/or opening an incognito window, and see if you can log in from that?