Arlo|Smart Home Security|Wireless HD Security Cameras
× Arlo End of Life Policy Notice
To view Arlo’s new End of Life Policy, click here.

Arlo Camera Stuck In Update Firmware Loop

Reply
Discussion stats
  • 8 Replies
  • 2957 Views
  • 0 Likes
  • 5 In Conversation
Toastmanpete
Tutor
Tutor

my arlo camera is stuck on update firmware. i click the update and it says do not remove batteries. then later it comes back to update firmware.

 

i have tried connecting to my arlo pro base station and updating there, same issue. reconnecting to basic system, forget device then re-add but same issue. new batteries, same issue. it will not update or move move past this update camera page.

 

anything else i can try? much appreciated

8 REPLIES 8
ShayneS
Arlo Moderator
Arlo Moderator

Hi Toastmanpete,

 

Have you tried to open and close the battery door & retry the firmware update? Are the camera batteries charged?

DallasBob
Aspirant
Aspirant
I have the same problem with one of three brand new cameras. The first one is stuck in a firmware update. It installed and then showed a firmware update requirement. . I tried resyncing, removing batteries, resyncing, removing the device and reinstalling all to no avail. The other two cameras installed and updated fine. Any help on resolving? Thanks
ShayneS
Arlo Moderator
Arlo Moderator

Hi DallasBob,

 

Just to double check, you did try and remove & reinstall the trouble camera from the Base Station, Correct?

 

There are few steps we can try, bare with me if you have done them already. Can you remove and re sync the camera > reboot the base station by the power button > test again to see if the firmware update applies.

 

 

Toastmanpete
Tutor
Tutor

yes batteries are new and fully charged. open the battery door during update and you get update failed and some nice flashing red lights. then try again and same thing. just loops back to update.

Toastmanpete
Tutor
Tutor

played around with it again last night. the camera will not resync to the new arlo pro base station but removes and resyncs to the old base station fine.i was hoping if i sync to the pro bast station that would then update. i guess not. tried turning everything off then on. removing device, then re adding. reset the bast staion to factory then re added camera and same thing. stuck. not sure what else i can try.

jguerdat
Guru Guru
Guru

Did you remove the camera from the old base before trying to add it to the new one?

Toastmanpete
Tutor
Tutor

i did indeed remove from old station before trying new. i am out of idea's now. thanks 

JamesC
Community Manager
Community Manager

Toastmanpete,

 

Given the troubleshooting you've already performed please contact the Arlo Support Team to further investigate this issue. You will find several options for contacting support in the provided link.

 

JamesC