Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Arlo's new Android App won't download pictures

Reply
Discussion stats
  • 18 Replies
  • 4356 Views
  • 2 Likes
  • 11 In Conversation
BGHill
Tutor
Tutor

After recently installing the new Arlo branded Arlo App on my Android (Pixel 2) device, I am no longer able to download photos to my phone from my Arlo account library. When viewing the live image I have taken a snapshot, then when the snapshot shows up in my library I select to download it.  A message shows up on the screen saying "downloaded", but I am not able to find the photo anywhere on my device. I have searched all the expected locations (downloads) and have searched all folders on my device, but I can not find the photo. I tried this download several times without any succcess.

 

I was using the previous Netgear branded Arlo App on my Pixel 2 before and I was able to download pictures and find them with no problem. I am not sure now if the download is just not working in the new App, or if it is storing the file somewhere on my device that I can not see. Anyone else experiencing this problem with the new Android Arlo App?

1 ACCEPTED SOLUTION

Accepted Solutions
JamesC
Community Manager
Community Manager

This should be resolved with the latest update released for for Arlo mobile app. Please make sure you have the latest version of the Arlo mobile app installed and let us know if you continue experiencing this behavior.

 

JamesC

View solution in original post

18 REPLIES 18
StephenB
Guru Guru
Guru

Is this only happening with snapshots?  How about downloaded videos from the library?

BGHill
Tutor
Tutor
Yes. I have the same issue downloading video from my library using the new Android Arlo App. I just tested it now and used file manager on my device to try and find it.
StephenB
Guru Guru
Guru

@BGHill wrote:
Yes. I have the same issue downloading video from my library using the new Android Arlo App. I just tested it now and used file manager on my device to try and find it.

FWIW, I just downloaded a video on my Galaxy S7, and that was saved in downloads.  The app version is 2.8.1.

 

It did ask for permission when I did the download (it was the first download I've done with the new app).

BGHill
Tutor
Tutor

Interesting that it works for you. Thanks for testing.

 

I checked my Arlo App permissions and it does have permissions to storage (in addition to location services).

My App version is also 2.8.1.

 

When you do the download, do you see a message on the screen "Downloading" followed by any message indicating download was successful? Mine just briefly displays "Downloading" then the message goes away.

 

Any suggestions as to what I should try ? Maybe I should uninstall and reinstall the App?

 

 

BGHill
Tutor
Tutor
Just tested this on my wife's pixel 3 (android v9) and it worked fine. Snapshots downloaded into the downloads folder.

I uninstalled the app on my Pixel 2 (android v10) then reinstalled it and the snapshot downloads still do not work.
The difference between our devices may be that I am on Android v10.

I will contact the app developer to advise them of my issue.
BGHill
Tutor
Tutor

So far not much help with Arlo support.

 

The contact email listed in the Play Store App page bounces back to me indicating that the address only accepts email from people in the organisation or on the approved senders list (and my email is not on the approved list).

 

I did manage to get part way through a support Chat before getting cut off (it took me too long to respond to one of the changes I was asked to do).

 

I have been able to confirm the following:

  • I am unable to download snapshots or recorded video from any of my cameras (it is not isolated to images from just one camera
  • I have cleared my cache for the Arlo App and cookies from my phone and then restarted the phone, but I am still not able to get downloads to work.
  • Snapshot and Video downloads using Arlo App v2.9 and Android 10 do not work 
  • Downloads using Arlo App 2.8 on Android 9 do work
LandJS
Mentor
Mentor

ver 2.9 is out now, perhaps that has fixed it

BGHill
Tutor
Tutor
I have updated to v2.9, but the problem persists.

I now have a case open with Arlo support. We tried uninstalling and reinstalling v2.9, as well as clearing the cache and cookies, but neither of these fixed the problem with snapshot and video downloads not working.

Most recently I provided Arlo support with a screen recording of the steps I performed resulting in the failed download.

Once again, it appears that this issue only exists when running the Arlo App (v2.8 or v2.9) on Android 10.

Hopefully I hear back from Arlo support soon and an update to the App will follow.
BikerCA
Tutor
Tutor
Same issues on my Pixel 2 XL.
usernametaken
Aspirant
Aspirant

I have the same problem and am on Android v.10. I did notice when browsing the files on my phone that the file has been downloaded but is .BIN instead of .MP4 and also includes "Downloading" in the file name. It seems like the download process is getting interrupted (similar to like on a Windows desktop if you see a file being downloaded it has a temporary name while in progress and then is renamed once the download has completed).  

TheTreeHouse
Aspirant
Aspirant

I have a Google Pixel 2XL.  I don't know how long I haven't been able to view downloaded videos, probably around the time the app switch happened but I wasn't paying that much attention.  What I noticed is that the file name says "downloading" the file extension is a MP4, but the "type" is "BIN".  I couldn't figure out how to do anything with it on my phone, but emailing it to myself allowed me to download the video from my email client and the video played just fine.  I don't know what is happening, it is annoying.  But I think I have found a work around.  

jguerdat
Guru Guru
Guru

Just tried this myself and see the same issue. @JamesC ?

arkar
Initiate
Initiate

Same problem here on Android 10.

jguerdat
Guru Guru
Guru

Don't forget to contact support about this - use the link at the bottom here.

Andrew6132
Aspirant
Aspirant
Same issues pixel xl 2. can't open any downloads
Derrica
Aspirant
Aspirant
I have the same issue on my Samsung S10.
JamesC
Community Manager
Community Manager

This should be resolved with the latest update released for for Arlo mobile app. Please make sure you have the latest version of the Arlo mobile app installed and let us know if you continue experiencing this behavior.

 

JamesC

arkar
Initiate
Initiate
Problem solved. Thanks.
Discussion stats
  • 18 Replies
  • 4357 Views
  • 2 Likes
  • 11 In Conversation