Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Arlo Ultra - unwanted sound capture turns on when changing to/from low light mode when AC powere

Reply
Discussion stats
  • 5 Replies
  • 410 Views
  • 1 Like
  • 4 In Conversation
SpiralD
Aspirant
Aspirant

I noticed that after I connected my Arlo Ultra to a permanent power source (AC adapter), captured videos would contain sound even though my device settings indicated that sound was off.

 

Upon turning on and off the microphone in the app, sound capture stopped until the system went into low light mode. The first videos recorded in night mode had sound captured, until I toggled the microphone setting in the app again which stopped capture for videos after that.

 

In the morning, the first videos after low light mode turned off had sound. I once again toggled the microphone setting to turn sound capture off.

 

The unit only started behaving this way once I connected it to a full time power source.

 

I'm a software engineer, and IMHO this pattern appears to be some sort of logic bug triggered by the change to and from low-light mode- like the requested "microphone off" setting is forgotten internally until it is reapplied.

 

This is a major annoyance, but to make matters worse, if this bug causes the private conversations of individuals to be recorded without their consent, it would break the law in California and other 2 party consent states.

 

Can we get a fix for this ASAP?

 

Arlo Ultra: H7 firmware 1.070.50.2_205_0c7c8e1

Model: VMB5000 | Arlo Ultra SmartHub, VMC5040 | Arlo Ultra Wire-Free Camera
jguerdat
Guru Guru
Guru

You should be deactivating audio detection in your modes and rules, not in the camera settings.

StephenB
Guru Guru
Guru

@jguerdat wrote:

You should be deactivating audio detection in your modes and rules, not in the camera settings.


It should work either way, and probably he wants to do both, in order to prevent audio capture when live streaming.

 

Where I live, audio capture is legal for my home cameras.  But not for cameras deployed in a building that is open to the public.  It's really important that the system NOT capture audio when it's been configured NOT to do that.  If the system can't do that reliably, people will either need to return it, or try to disconnect the wires going to the microphone.

SpiralD
Aspirant
Aspirant

The system is always in the "Armed" mode. Audio detection is off for both cameras.

 

To be more specific, the problem isn't the camera triggering off of sound. It does not appear to do so. The problem is that the microphone turns on and the camera starts capturing sound in the recordings when the ambient light causes the camera to switch into or out of "low light" behavior, regardless of the current setting of "microphone off".

 

Does this clarify my issue @jguerdat ?

SpiralD
Aspirant
Aspirant

This is likely a bug as far as I can tell. The simplest way to reproduce it:

 

With the camera plugged into a power source (IMPORTANT), go to the device settings for the camera and turn the microphone off. I also turn the speaker off. 

 

View the live video from the camera in the app. There should be no sound captured.

 

Put your hand over the camera while viewing the live video. The low-light behavior will be triggered. Listen as the sound clicks on and you can hear the sounds from the camera environment through the phone.

 

Go back into the camera device settings in the app and observe that the microphone is still set to off. Toggle the microphone switch from on to off. Go back to the live camera view and observe that the sounds is no longer captured.

 

This can be verified by tech in a couple of minutes. Please patch.

JamesC
Community Manager
Community Manager

SpiralD,

 

Thank you for the detailed information. I've escalated this to the development team for further investigation.

 

JamesC

Discussion stats
  • 5 Replies
  • 411 Views
  • 1 Like
  • 4 In Conversation