Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Arlo Go

Reply
Discussion stats
  • 10 Replies
  • 803 Views
  • 1 Like
  • 2 In Conversation
stoneshabad
Aspirant
Aspirant

I haven’t used my Arlo in a few years. The last time I set it up it was unresponsive.

I just noticed I have a charge from Arlo of $9.99 every month.

When I log into myarlo app or log in on a browser I have no subscription.

Without a subscription I can’t get support.

I still have a monthly charge though. I cannot get around this and the current credit card has been changed.

Please Arlo, help me either access my subscription or cancel it.

Model: VMB3500 | Arlo Base Station
1 ACCEPTED SOLUTION

Accepted Solutions
stoneshabad
Aspirant
Aspirant
Thank you! I was able to find a chat support and as soon as it was made a case# my problem was confirmed and was resolved. I appreciate your help, I felt I was going around in circles seeing the same pages over and over.

View solution in original post

10 REPLIES 10
StephenB
Guru Guru
Guru

@stoneshabad wrote:

I just noticed I have a charge from Arlo of $9.99 every month.


That's for LTE service, not for Arlo Smart.

 

I suggest contacting support, using the link in the top right of the forum page.

 

 

stoneshabad
Aspirant
Aspirant
Thanks,

I just realized my product was Arlo Wireless. The first Gen Arlo camera.

I don’t see a link for support on my phone. I’ll look on my pc.

This is very confusing as neither of my Arlo accounts have any subscription. That’s one reason I can’t use Support. If the charge is LTE what would that be for?
StephenB
Guru Guru
Guru

@stoneshabad wrote:

I just realized my product was Arlo Wireless. The first Gen Arlo camera.

Then it's not a charge for LTE, you must have paid for Arlo Smart.

 

Subscriptions can be managed in the app, but it might be easier to use https://my.arlo.com

stoneshabad
Aspirant
Aspirant
Hi everyone,

I used to have two Arlo base stations and 6 cameras. I had several months where they were great and provided streaming views of my property. One recording was used in a trial as evidence of a crime.

They gradually stopped working, batteries failed frequently or the cameras were disabled by sunlight causing the “red” effect. Cameras couldn’t connect to the base stations. I gave up.

I do not remember what happened to the cameras or base stations. My wife may have donated them. I had reset the base stations when I gave up on using them.

Now I see I’m getting a $9.99 monthly charge from Arlo. If I access my accounts (one for each base station) I have no devices listed and no subscription service. I have no payment option to check. I can’t find anything related to this charge.

I can’t access support because it requires you have a subscription which I don’t. The Arlo phone number on the bill has a rotating message regardless of choice. It just repeats asking the same two questions with no answer.

I’d really like to stop being charged for a service I don’t have but so far I’ve been stumped trying to get help.

My credit card bill lists it as Arlo under a broader category of Netgear. Netgear says they are not associated with Arlo. It took them 15 minutes to get back to a support request.

All in all very confusing.
stoneshabad
Aspirant
Aspirant
I have no subscriptions on my accounts. I have no payment method to access.

I made a new post in the correct area since this post was under Arlo Go.
stoneshabad
Aspirant
Aspirant
Screenshot of myarlo.com
stoneshabad
Aspirant
Aspirant
From the app
StephenB
Guru Guru
Guru

@stoneshabad wrote:

I can’t access support because it requires you have a subscription which I don’t. The Arlo phone number on the bill has a rotating message regardless of choice. It just repeats asking the same two questions with no answer.


You actually should be able to get support w/o a subscription.  Perhaps @JamesC can assist.

 

You could also dispute the charge with your credit card company.

stoneshabad
Aspirant
Aspirant
Thank you! I was able to find a chat support and as soon as it was made a case# my problem was confirmed and was resolved. I appreciate your help, I felt I was going around in circles seeing the same pages over and over.

View solution in original post

StephenB
Guru Guru
Guru

I'm glad you were able to get it dealt with.