Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Arlo Smart Hub Port Forwarding not Working

Reply
Discussion stats
  • 6 Replies
  • 507 Views
  • 0 Likes
  • 3 In Conversation
NathanZ05
Aspirant
Aspirant

So today we got our smart hub in and I've set it all up, the LAN storage is working but the port forwarding isn't working. I have my knowledge on technology and have port forwarded multiple times without trouble so I know what I'm doing.

 

So back on topic I did all of the port forwarding but in the Arlo app it still shows "Getting status" with the red and black ! mark.

A photo of the port forwarding that I've done is linked below, I got the the right port number and the right ip address that the smart hub is on, I also gave the base station a static Ip address so that's out of the story. 

 

I restarted the hub and don't want to factory restart sense its a lengthy process re-linking all the cameras, smart hub, etc. I looked online and couldn't find what I was looking for so that's why I'm asking this question, Thank you for your response 

 

 

 

Model: VMB4540 | Arlo Pro 3 SmartHub
6 REPLIES 6
StephenB
Guru Guru
Guru

@NathanZ05 wrote:

 

A photo of the port forwarding that I've done is linked below,

 


Not sure, but maybe try forwarding both UDP and TCP (instead of just TCP).

NathanZ05
Aspirant
Aspirant
I already have, it was in both to begin with but this same problem.
StephenB
Guru Guru
Guru

Just to clarify your network setup - Do you have an ipv4 WAN address, an ipv6 WAN address or both?

 

Also, you might want to verify that the port is actually open using https://www.yougetsignal.com/tools/open-ports/ or a similar website. FWIW, some ISPs are using carrier grade NAT (cgn) for ipv4, and they might not support port forwarding.  

 

 

NathanZ05
Aspirant
Aspirant

I have both and the port is open

findcoop
Aspirant
Aspirant

Hello,

 

I've been wrestling with this, and finally got it resolved. Your average home Wifi router may not be able to work for you, given what I have learned and ultimately configured.

 

With Smart port forwarding enabled, I can only access videos on 5G, and not on Wifi.

- This is because my phone on the internal Wifi (192.168.x.x) sends traffic to Arlo Hub via my Internet IP address. My router doesn't know how to handle that, and so it just drops. Your home Wifi may still process this like a port forwarding configuration.

With Smart port forwarding disabled, I can only access videos on Wifi, and not 5G

- Traffic here goes from my phone 192.168.x.x to the Arlo Hub directly 192.168.x.x

 

The solution for me ended up being network address translation. I have smart port forwarding enabled

- First I grab traffic from my phone (192.168.x.x) to my Internet IP (24.x.x.x) on the configured Smart Port Forwarding port (e.g. 19000), and NAT it to the destination address of my Arlo (192.168.x.x). I found that Arlo would not respond to the TCP SYN, and so I experimented with source NAT to change my address from a private to a public, and this ultimately worked. So I also required a source NAT from 192.168.x.x to 100.64.x.x (Public but non-routable, reserved range).

 

Firewall rules

1- From Internet to My-Internet-IP on SPF port (e.g. 19000) DNAT to Arlo Hub

2- From Smart-Phone-Wifi to My-Internet-IP on SPF port (e.g. 19000) DNAT to Arlo Hub, SNAT to 100.64.x.x

3-From Arlo Hub to 100.64.x.x from SPF port (e.g. 19000), DNAT to Smart Phone

 

Once I did this, I could access the Hub on both Wifi and on 5G.

Model: VMB4540 | Arlo Pro 3 SmartHub
findcoop
Aspirant
Aspirant

Also, forgot to mention that Arlo Hub seems to ignore traffic from private IP addresses (192.168.x.x) when Smart Port Forwarding is enabled, that's why I needed to source NAT myself to 100.64.x.x.