Arlo|Smart Home Security|Wireless HD Security Cameras
× Urgent: Activate Two-Step Verification
Arlo requires all users to activate two-step verification by Oct 31st, 2020 to continue to access your recordings, devices, and account.
Please enable this feature now. Learn More.

Problem plug cover

Reply
Discussion stats
  • 8 Replies
  • 1678 Views
  • 0 Likes
  • 7 In Conversation
Highlighted
Follower
Follower
I just got my new lights. Finished setup and there working fine. Haven’t even mounted them yet. I noticed the plug covers will not stay closed. I’ve tried several times making sure there pushed in securely. Minutes later there popped open again. This seems to me that outside in the weather will be an issue if they don’t stay closed in my house for longer then 5 minutes how long will they last outside. Maybe I should just return them, they weren’t cheap. I’d assume the water will destroy them
Highlighted
Guru Guru
Guru

A swap at the store would be the fastest fix. 

Highlighted
Community Manager
Community Manager

Splatterific,

 

I will reach out to you in a private message to gather more information on this topic.

 

JamesC

Highlighted
Aspirant
Aspirant

I have the same problem as previously reported here on the site by another customer. I purchased three Arlo Pro 2 wireless cameras yesterday and installed.  In all three camera's  the USB cover continuously pops out. Will not stay closed. What do I do? Do I return the cameras? Thanks 

Model: VMC4030 | Arlo Pro Wire-Free Camera
Highlighted
Guru Guru
Guru

Maybe try using a bent paper clip to guide the USB cover back into the opening?

Highlighted
Aspirant
Aspirant

I will give it a try. Thank you

Highlighted
Aspirant
Aspirant

Hello - I have this same problem with one of my Arlo Pro 2 cameras. The rubber plug pops out no matter how I try to push it into the hole for the power cable.  It does not appear to be misshapen, and there is nothing that I can see which would be preventing it from fitting, yet it pops out about 1-2 seconds after pushing it in.  

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
Highlighted
Aspirant
Aspirant

I have the Pro 2 and wanted to share a similar experience after taking down my Pro 2 for charging.  When taking the cover off, I must have pulled on the cover which gave it some more slack.  The extra slack would force the cover to pop off and not stay on.  After pushing the cover to reduce the slack, I was then able to close the cover (and have it stay closed).

 

The attached picture shows what I encountered (sorry for the blurriness).

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
Highlighted
Guru Guru
Guru

@Rob1208 wrote:

I have the Pro 2 and wanted to share a similar experience after taking down my Pro 2 for charging.  When taking the cover off, I must have pulled on the cover which gave it some more slack.  The extra slack would force the cover to pop off and not stay on.  After pushing the cover to reduce the slack, I was then able to close the cover (and have it stay closed).

 

The attached picture shows what I encountered (sorry for the blurriness).


I agree the rubber plug is a weakness in the design (which was addressed in the newer cameras, which use a magnetic coupling that doesn't need a plug).

 

It works ok if you are careful with it.  Some have applied some silicon grease around it, in order to prevent water from leaking in around the edges.  

Discussion stats
  • 8 Replies
  • 1679 Views
  • 0 Likes
  • 7 In Conversation