Arlo|Smart Home Security|Wireless HD Security Cameras

"Device of this type cannot be shared" message displayed

Discussion stats
  • 11 Replies
  • 8 In Conversation
guillermoavalos Aspirant

So, I have my Arlo Pro setup shared with a couple of family members. I'm trying to add a new one, and after completing the full name and email address and selecting which devices I want to share, the app displays this message on top highlighted in orange: "Device of this type cannot be shared". It doesn't matter whether I select a single camera or all of them + the base station, nothing works.


The web app doesn't work either. There's no message being displayed and no other errorrs seem to ocurr, but the invitation never gets sent. 


UPDATE: Seems it's been fixed now. Tried a few more times and the invitation got sent. 

Model: VMB3000|Arlo Smart Home Security

I am having this same issue.  I am getting an error message in an orange box at the top of my screen that states, "Device of this type cannot be shared".  I have tried multiple times and am getting the same error message.  I have been able to share the cameras on this account previously.  


Has anyone found the root cause or a solution to the problem?

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
JessicaP Arlo Moderator
Arlo Moderator



Are you experiencing this issue when trying through the Arlo app on your phone and/or web client on the computer?

Jcclark78 Guide
Seems to be the manual alarm on mine
guillermoavalos Aspirant

Yes, it is the manual alarm. For some strange reason I cannot share it, just the cameras, which is weird beacuse I was able to share it for all my other users.

Guru jguerdat Guru

Did you also set the access rights for that person?

guillermoavalos Aspirant

I just tried it again. The orange alert with the same error popped up, but going back and opening the user setting again shows the base station in the shared devices list. Must be a bug.

Rick777 Aspirant

Im having the same problem...what can I do ?

JessicaP Arlo Moderator
Arlo Moderator

Hey @Rick777,


What device are you experiencing this issue on?

VTRD Aspirant

I cannot add a person on the (Grant Access) in the setting on the Android app or website. I filled out everything (Add Friend) and I tried different email but still showed me (device of this type cannot be shared) in orange, I reset the system and still nothing. Please, help.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
JessicaP Arlo Moderator
Arlo Moderator



Could you show a screenshot that shows this error on the Arlo app on your phone and the web client on your computer?

cliffba Initiate

I got this same message.  It turns out that when I added an additional camera and tried to grant access to a friend, the camera, along with the base station was checked.  The base station had to be unchecked, because it cannot be shared.  Problem resolved.

Model: VMB3000 | Arlo Base Station