Arlo|Smart Home Security|Wireless HD Security Cameras

Re: New user interface unusable

Reply
Yazmine Guide
Guide
key items are missing from the opening page under devices on Android app. Status for all cameras at a glance is no more availible. There are other so called enhancement that are not enhancement and poorly done. Please undo...undo......undo...
Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
Yazmine Guide
Guide
I don't like the latest update undo please......key items are missing from the opening page under devices on Android app. Status for all cameras at a glance is no more availible. There are other so called enhancement that are not enhancement and poorly done. Please undo
Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
Stephanoochi Initiate
Initiate
Is anyone else unable to view videos on some of their cameras now that they've just updated the not very user-friendly app?
Retired_Member
Not applicable

From the App store Arlo:

”We’ve also refined the design of our app to put the important information front and center.”

 

Netgear, You removed important information like battery icon, motion icon and wifi and for what reason? To make it less user friendly? Everything should be at a glance and not tapping this and that just to get battery percentage! GET YOUR ACT TOGETHER NETGEAR I AM LOSING MY PATIENCE!

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
PLSChows Initiate
Initiate

One of the new enhancements to the App version 2.6.0 requires one to click the settings button to see the battery percentage left. It used to show on the Devices tab. Easy to scroll and know at a glance which batteries might be low. Now it requires clicking on every device to see. VERY annoying when you have multiple cameras. Please put this back on the devices tab so it's easy to know how many batteries might need changing soon. This only applies to the app since the web still shows it.

megarecticman Initiate
Initiate

This is a perfect example when to fire the UI and UX designers. Also somewhere, someone is probably proud of this desicion who led the team of ui/ux - he should be fired as well!. Arlo/Netgear: please send me the API specs so I can write my own.

 

JasGard Initiate
Initiate

I, too, agree this current layout is awful.  Please change it back to the previous one.

 

Also, to change the Motion/Audio sensitivity of a camera you have to:

Hit "Mode"  -  Get into edit mode in "Armed"  -  Choose which camera  - then "Motion is detected".

 

Why not have Sensitivity in the "Settings" for each camera, under "Video/Audio Settings"?

Model: VMC4030 | Arlo Pro Wire-Free Camera
Highlighted
RalphPondOwner Initiate
Initiate

Actually the situation with this new user interface on the ipad is worse than I described. Each camera simply shows a static image which does not refresh, and there is no count of incidents or any way to access the various videos. This occurs on all my iOS devices. The Mac computer interface works fine. What's up? Anyone from Arlo reading these posts? HELP!

pc2k17 Hero
Hero

@JasGard

Sensitivity was always that way, at least in the android app. It's that way because you may want different sensitivity settings for one single camera depending on the situation. If it's windy outside I turn the sensitivity down on my outside camera. If it not windy sensitvity is 100%. If you set it in the camera you couldn't have different settings for different situations, this is why it's the the mode/rule.

 

When I read the what's new section for the arlo app update and it said "we've also refined the design of the app" I knew that meant GUI changes and it wasn't going to be pretty......... and my hunch was right. I'm still enjoyin the old app currently.

 

My guess as to why the icons are now hidden in the 3 dots menu is........ those icons load from the server each time we opened the app or went to the devices page. All that loading put stress on the arlo servers and they are now experiencing overload problems due to all the new users. Hiding them in the menu means they don't load automatically right away taking stress off the servers. I'm just guessing here but I see no other reason to remove the icons from the main screen. IMHO arlo needs to update infrastructure not cripple an app.

skibum0607 Initiate
Initiate

Agreed.... This update is horrible.  I have no idea how anyone can think this is an improvement.

BGhome Initiate
Initiate

This new interface is terrible. I have a home 1000 miles away with 10 cameras that are now useless. Should have left it alone. While the cameras show they are live, they are not. One of the cameras has a clock in it’s view. No more battery indicator on camera screen. Fix it or go back to previous version 

Upsman87 Guide
Guide
Just spent 30 minutes chatting with Amazon tech support (I was investigating my return options) and she suggested checking for firmware updates on my Base Station via the app.... firmware was all up to date....I also checked all my cameras via the app...also all up to date. She then suggested deleting and reinstalling the app, which I did, and it seems to have reduced the alert times and live view lag I was experiencing before. Down from 1 minute plus to around 3-5 seconds. Worth a try! Still hate the new UI though....
Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
Prowl Star
Star

"My guess as to why the icons are now hidden in the 3 dots menu is........ those icons load from the server each time we opened the app or went to the devices page. All that loading put stress on the arlo servers and they are now experiencing overload problems due to all the new users. Hiding them in the menu means they don't load automatically right away taking stress off the servers"

 

Nope. The icons will just be overlays in the APP done locally.  The server will only be sending raw video. 

They could of course just add the icons below the video...

pc2k17 Hero
Hero

Yes true, the icon graphics themselves are probably locally stored on the device, but the information the icons show, battery status, signal strength, motion guy, usb, sound, all comes from the cloud (server). Status information is not stored or transmitted locally on the Arlo system. All information displayed in the app comes from your account in the cloud (server). App GUI, icons, menus, etc, is local, information is cloud. You can tell this by opening the arlo app, and when you do you always have to wait for the devices, screenshots, and status icons to load even though the app is already fully loaded. Those things come from the server. In my android app those status icons where always the last thing to display, even after modes and cameras were already displayed. Like I said, I'm just guessing, but there has to be a reason why they'd make such an obvious mistake as "hiding" the icons. There's some information we are missing as to why....

Prowl Star
Star

That's just bytes of information that would equate to less than 1/10th of a single frame of video.
 

The delay is purely down to the order the "programmer" has chosen to load the Video / State.  

If you click the pointless three dots ( then the device settings - rolls eyes - make it a gear icon and go direct at least !!! ) the battery info appears immediately... sure it miught be pinging the server account.

 

Point is these guys have made a bit of a mess of the App.

 

Prowl Star
Star

Basically to fix this for me at least...

Show the battery percentage on the front page.   Also the other indicators that show what each camera is doing. 

Reduce the amount of click it takes to get to settings.  
    Make the 3 Dots a gear icon and go directly to it.   The Basestation has a direct gear icon! *

    Make the UI more obvious  for closing the settings - not the back buton top left when the Settings SLIDE UP.  

    Point of note - Home page - Press the Basestation gear icon and the settings slide immediatedly on from Right and then    

    the Arrow top right takes you back - Actually intuative and works.  


In that Don't bury settings under multiple menus - EXCEPT for Remove device! That should be under a seperate menu... not something that looks like the damn Close button!   

Make the UI more obvious  for closing the settings - not the back buton top left when the Settings SLIDE UP. 

I actually like the scrolling on the home page on Mobile... but looks Awful on Tablet - you could get 6 cameras on screen at once. 

Fix the 3D Touch on iPhone to do what they should ( Geofencing / shedule / disarm etc  ) - Currently does nothting but open the app to where you were - not even the right bit of the app. 

Fix the Apple TV App so that works! 

jimci1234 Tutor
Tutor

The app 2.6.0 is a step backwards from a user perpective.  Prior to this update a user could select a device directly in the library instead of having to set a filter to limit the recording library to that device. Please bring back the camera list under library.

AncientGeek Hero
Hero

That's just bytes of information that would equate to less than 1/10th of a single frame of video.”

 

I agree this is a tiny amount of information.  I suspect everything you’d ever want to know about the camera status is around 100 bytes.  A full system status would likely be single digit kilobytes at the most including packet overhead.  A very small amount of data by today’s standards.  At 300 BAUD every byte mattered, but not at typical speeds in use today and it wouldn’t be noticble next to the images.  They likely waste more bytes that this with the white space in their email notifications.

AlbertoM Initiate
Initiate

Hello,

I like the idea of clean up; but I do not know if this can be set by user what do you wan to remove.

I miss the battery percentage on the main view screen.

Regards,

Alberto

bhtinc2000 Initiate
Initiate

Yes ..... Dont show battery life

.............Dont have ease of access to history recordings from front screen any more

 

............ and the history ............. CAN NOT PLAY BACK ......

 

stop changing ..... you just got the battery drain fixed !!!!

Model: VMC4030 | Arlo Pro Wire-Free Camera , VMC4030P | Arlo Pro 2 Wire-Free Camera
Dash13 Aspirant
Aspirant

Also can't adjust the brightness anymore.

Frappguy Initiate
Initiate
Latest update of the app also isn’t allowing live access to any of my cameras. Worked all last week as I setup the Arlo Lights; now nothing but a spinning wheel. Ugh!
bhtinc2000 Initiate
Initiate

Chome ... or Internet Explorer or my samson phone .... can not veiw history ....

 

i just found out the FireFox does work............

 

When it works for all again ....... stop changing for a while ../... let it just work ... like it did a year ago

Model: VMC4030 | Arlo Pro Wire-Free Camera , VMC4030P | Arlo Pro 2 Wire-Free Camera
Jezs Initiate
Initiate
You have removed the battery and indicator symbol off the front dashboard - why? This is irrational and an obstacle to security. I now have to click on each camera to view battery life. Hopeless. When will you sort it?
Model: VMC4030 | Arlo Pro Wire-Free Camera
gilbo2 Luminary
Luminary

Just to add my voice that I DO NOT see this an an enhancement, there is so much useful functionality now missing from the UI.

 

Major, major step backward, thank goodness at least the Web browser version is still the same!