Arlo|Smart Home Security|Wireless HD Security Cameras

Re: app not compatible on Samsung Galaxy S5 AND Google Chrome

Reply
Discussion stats
  • 6 Replies
  • 1803 Views
  • 0 Likes
  • 2 In Conversation
S-Davenport
Aspirant
Aspirant

I have tried everything that I could find and I still get Device Not Compatible. Please help.

6 REPLIES 6
jguerdat
Guru Guru
Guru

What OS is the S5 running? I think I remember 4.4.1 being the lowest version supported (might be wrong on the exact version).

S-Davenport
Aspirant
Aspirant

I'm not sure what OS is... I'm definitely TECH challenged LOL

jguerdat
Guru Guru
Guru

OS = operating system. Android x.xxx and found in the phone settings, About this Phone or similar. Check for possible updates while poking around.

S-Davenport
Aspirant
Aspirant

OS 4.4.2 says I am up to date on the latest version. But I also can't download the app on the computer.

jguerdat
Guru Guru
Guru

The computer doesn't use an app - it's just a web site at https://arlo.netgear.com. I believe this is spelled out in the documentation that came with the system.

 

I stand corrected - the latest app requires at least Android 5.0. While there are things that can be done to make your phone compatible (rooting and using a custom ROM), it would be easiest to use a different device or use a computer browser.

S-Davenport
Aspirant
Aspirant
Thank you.