Arlo|Smart Home Security|Wireless HD Security Cameras
× Urgent: Activate Two-Step Verification
Arlo requires all users to activate two-step verification to continue to access your recordings, devices, and account.
Please enable this feature now. Learn More.

Re: Email notifications

Reply
Discussion stats
JessicaP
Arlo Moderator
Arlo Moderator

Hi everyone,

 

The Arlo development team is currently investigating this issue. We will provide an update as soon as we have more information to share with the community.

TechJohn
Guide
Guide

I am having the exact same issue. Previews have stoped on my Android phone (Samsung Note 9 using Samsung Email app) as well as my Win 10 PC running Outlook 2016. This has been very frustrating as I now need to click thru each alert to see what is going versus looking at the preview picture. I would appreciate a fix.

TechJohn
Guide
Guide

Sorry for the post. Looks like there is another thread on this topic.

 

https://community.arlo.com/t5/Arlo-Pro/What-happened-to-the-preview-picture-in-the-emails/m-p/170066...

GR2011
Apprentice
Apprentice

I get the image preview on my Galaxy S10+ (Pie) using the Outlook App (3.0.70, build 321) for Android. The preview will not work if I use bluemail, Samsung mail app, Truemail.

treebuilder
Apprentice
Apprentice

I'm having the same problem, but there's not even a link to the video.  Just all the surrounding text and branding and such, but no video and no link.  Very frustrating.  Started in the past week or two.

treebuilder
Apprentice
Apprentice

Same issue.

 

Can't see it on my phone using Nine, can't see it in my mail program using Roundcube.

 

 

treebuilder
Apprentice
Apprentice

I've had the same problem with a lack of the video or link showing in my email notifications sinnce May 23.

Soka
Aspirant
Aspirant
Been having problem as well..Arlo team said to get my emails through Outlook. Downloaded the app and set up my email. I turn my arlo to set motion on...was able to see the preview pic in email from galaxy s8+ when email notification came through.
treebuilder
Apprentice
Apprentice

Then I need to start investigating alternate security camera solutions, as I am not going to completely change how I interact with my email just because some developers in the Bay Area can't figure out conformant, cross-platform HTML.

Soka
Aspirant
Aspirant
Been using Outlook and so far it's been horrible. I don't like the layout of the email setup and it is way slower then Samsung email as far as getting my emails...Gonna switch back to Samsung setup....Arlo team, please fix the situation...I too will be looking for alternative to my security setup if this does not get resloved.
JessicaP
Arlo Moderator
Arlo Moderator

Hey @miketech and @treebuilder,

 

What email client are you using? And could you provide a screenshot where you don't see a video or link from your email?

treebuilder
Apprentice
Apprentice

Roundcube (web-based), Nine (mobile), Gmail (mobile), Thunderbird (desktop).

 

Your HTML is screwed up.  The link is present in the HTML source.  It's not displaying in most web based, desktop, or mobile MUAs.

 

Screenshot attached from Roundcube.

 

 

frankpgh
Guide
Guide

This is just piss poor product development.

 

There is a post at the end of the first page that Arlo development is looking into this.

 

How about some beta testing?  You have a lot of dedicated customers here and it really surprises me that this issue came up AFTER you pushed to production.  It's obvious that your QA is lacking in an attempt to keep up with competition.  

 

How many Android app pushes/updates have you sent in the last 3 weeks?  Embarrasing.

 

FWIW - I have 2 different laptops both running Office 365 (16) and one gets the preview image and the other does not.  One is managed my by corp IT (which works) and the other is not.

 

Between this issue and spending $300 on some lights that turn on and off whenever they want, I feel I should have invested in better options.  Shame on you, Arlo!

 

sspeak
Guide
Guide

What I don't get is why they had to make a change at all?

ranran
Apprentice
Apprentice

Add me to the list.. no longer getting the preview pictures.  I REALLY REALLY liked getting those preview pictures to give me an idea of whether I needed to investigate further or not.... and now, no picture.

 

It used to work in Outlook just fine.  Arlo, PLEASE fix this ASAP - I want those preview pictures back!

 

Thanks.

Model: VMC4030 | Arlo Pro Wire-Free Camera
Rueg
Apprentice
Apprentice

Any update JessicaP?

Fastmike
Guide
Guide

What have they done now??? This morning, only the Arlo Pro 2 system is still alive.

In the other houses, the Arlo Pro systems had no capture for yesterday and no camera detected!

When I reboot the base stations, only the first camera is detected on each!

What is the next step Netgear??? Travel to each location at my cost to try to fix the mess you again created?

I am not sure on the way you are organized, but you for sure need to review your testing procedures before putting any update in production for such 'critical' security products!

Nancy_L
Star
Star

Same problem with previews not working for Outlook 2010 on Windows 10.  Preview works on email to my iPhone IOS version 11.4.1 & my iPad IOS version 9.3.5.

Model: VMB3000 | Arlo Base Station
CWuestefeld
Guide
Guide

The problem isn't that their HTML isn't compliant or well-formed - it's fine. The problem is that they've changed the architecture. It used to contain an <img> tag that directly loaded the jpeg image into the body of the message. They've removed that. It now appears to be be relying on javascript that runs in the message, just as inside your browser, to download the image.

This isn't entirely stupid. The new javascript stuff also provides the video player controls, and I assume that this was designed to give a better experience when playing the video in the email.

The problem is that it's a security risk to allow javascript to run in emails at all. This is the kind of thing that hackers do to compromise your system through spam. And from this exercise we can see which email readers are doing a better job of protecting you from this kind of danger: if you can see the still photo, then you're using a risky email program. So DO NOT switch email readers if Arlo support is telling you that's the workaround.

The other problem is that Arlo's developers (a) weren't aware that this kind of thing can be a problem, and (b) didn't test their email change sufficiently to see the defect that it causes.

And compounding this is the fact that it's not a change they can undo - they can't just roll back to the older email code. From the fact that the URLs for the videos differ, we can infer that this change was part of a broader architectural change in how they're storing those video. They can't go back to the old, good email code because it looks for the videos in a place they're no longer being stored.

 

SP1123
Tutor
Tutor

Since I got my Arlo cameras, I've always received email notifications that have a photo included in the email message.  This helps me quickly peek at the photo and figure out if it's something I need to investigate further or if it's probably something like plants blowing in the wind next to the front porch.  About a week ago, I started getting email notifications that no longer include a photo and instead, they have a link to hop on the web site to see the video.  It means that it takes me longer to check out each notification and it's not as quick as it used to be.  Is this a setting that can be changed, or was this a service-wide change in how the notifications work?  Thanks everyone

The_Wraith
Apprentice
Apprentice

It's probably a "feature" they push to the customer without the customer asking or desiring such a "feature".  You can count on Arlo continually kicking your expectations of their product in the shin.


Regards,
The Wraith
Bagabond
Tutor
Tutor

Hi SP1123,

 

You piqued my interest with your observation. 

 

I have checked my recent arlo event emails and they too do not appear to have an image attachment when viewed in my PC's mail client.  However, when I log into the email service provider's webmail interface, the images are actually there embedded in the email.

 

Could it be that the lack of image is just the way your mail client is currently responding to the Arlo email format?

 

Cheers

 

treebuilder
Apprentice
Apprentice

Well, as of today, it's gone from, "I'm not getting the image in my arlo alert emails" to, "I'm not getting my arlo alert emails anymore."

 

This isn't an improvement.

duffer303
Aspirant
Aspirant

Any update on the missing images in the emails?  It is having a big impact on how we use the system at home and at our business.  This is a key sell point on this system!!

SP1123
Tutor
Tutor

Hello Bagabond, thank you so much for your comment.  I checked webmail and the image was also visible in my webmail - it just isn't coming into my Outlook on my home computer, or into the email program on my smartphone anymore.  I use Comcast as my internet service so I called them thinking it was a Comcast issue, but the agents that I IM'd with and talked to were not successful in helping me resolve the issue and one of them suggested that it was an Outlook problem.  I didn't think this made sense because the problem is happening with the email program on my smartphone as well, but I thought I'd ask you and the other users out there (1) what internet provider you are using and (2) what email programs are you using?  If we can identify some commonalities hopefully this will help resolve the issue! 

I also noticed on the Google Play Arlo app page that several people are indicating that they have experienced problems since the last upgrade:  https://play.google.com/store/apps/details?id=com.netgear.android&hl=en&showAllReviews=true