Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Arlo Pro battery not charging

Reply
Discussion stats
Highlighted
Aspirant
Aspirant
I'm using the one that came with my Alro Pro.
Highlighted
Tutor
Tutor
Arlo support is at best a joke if somehow you're in a laughing mood after spending how many hundreds of dollars on equipment that doesnt work at best
Model: VMC4030| Arlo Pro Wire-Free Camera
Highlighted
Community Manager
Community Manager

Chadster,

 

Try unplugging the power adapter, remove the battery, reinsert the battery and then reinsert the power adapter. Still seeing the same behavior?

 

JamesC

Highlighted
Aspirant
Aspirant
Exactly same situation here. Can’t understand why I have to pay for the shipping. Not my fault! Not only to spend the time to package and drop it off , also pay the cost? Totally disappointed.
Highlighted
Tutor
Tutor
I had to have the send me a second camera because the first replacement was defective. Poor quality. I had to pay 2x to ship back defective cameras plus the time and effort to convince Netgear that they needed replacement. That is bad business! This one finally seems to work, but in the beginning so did the last replacement until it needed its 2nd charge - just wouldn’t take it. I would return the whole system and go with Nest, but I didn’t want to throw away all that money. If you are able to return the system - do so immediately.
Model: VMC4030| Arlo Pro Wire-Free Camera
Highlighted
Tutor
Tutor
James,

Many of the cameras are simply defective - which no amount of plugging or unplugging will fix. Defective equipment is ok, but not when you have to pay to return a defective product. That is just poor policy.
Model: VMC4030| Arlo Pro Wire-Free Camera
Highlighted
Tutor
Tutor
Here is my recommendation. Do not buy this system and, assuming you did because you are on the forum, return it if you can. If you are stuck like me then you need to stay on top of support to get a replacement. Poor product, poor support.
Model: VMC4030| Arlo Pro Wire-Free Camera
Highlighted
Aspirant
Aspirant
Thanks for your input. Will try to return the whole system to costco. Hopefully costco could do a better job to protect customers’ rights.
Highlighted
Prodigy
Prodigy

I bought mine from Costco.. I been returning my defective Arlo's thru them without any problem. It's a bit of a hassle but money not wasted and don't have to put out more for shipping and also guaranteed you'll have a new replacement than a refurbished.. Costco is the only place I would purchase Arlo due to this kinda' issue and more to come with the upcoming updates to deal with.. This is the only insurance for me that make sense without dealing support from Arlo. I get a 90-Day return policy and rolling it.. Some of you prolly' get the one's I've returned and now Arlo is selling it refurbished.. Goodluck to all.. 

Highlighted
Aspirant
Aspirant
Just returned mine to costco this afternoon. Had to do the return and rebuy. My arlo has been almost six months but Costco still take it (the CS person was not very happy though). Tested the new cameras, looks good now. Set them to best image and record longer timeto get to drain the battery faster. Used to set them to best battery life and took six months to find out one is defective. Another lesson learned.
Highlighted
Aspirant
Aspirant

@USAF1954 wrote:

I had the same problem.  What I ended up doing was folding a small piece of index card and putting it between the battery and the clip.  It seemed to tighten it up and battery shows 100 % charged now and camera works without plugging in.  Hope this helps.


Thank you very much for this tip. My battery wouldn't charge in the camera--it kept showing 1% after hours of charging with the Netgear supplied charging cable & wall wart. Putting a folded piece of paper between the back of the battery and the door did the trick and the battery charged as it should. You saved me from buying a new battery!

Highlighted
Aspirant
Aspirant
Having the same problem

My case number is 30210604

Cameras are 6 months old. I received the cameras are tired message so have been charging using the supplied arlo plug and cable.

I own three cameras and Two cameras do not charge properly. in my app the icon flashes between a percentage number and 0%. This results in my getting a push alert on my mobile and an email.

Fine the first time. Not so funny after 100 times. What do I do? I literally cannot secure my home because of an annoying manufacturing defect.

Not impressed
Model: VMC4030| Arlo Pro Wire-Free Camera
Highlighted
Community Manager
Community Manager

PavanGC,

 

If you're able to charge one of the cameras you may need to contact support to further isolate the issue. You might try putting the battery from the camera that will not charge into the camera that you say is charging without issues to further isolate.

 

JamesC

Highlighted
Aspirant
Aspirant
I had to buy another battery at best buy, and a double charging station on amazon. I only have one camera but, i always have a charged battery
Model: VMC4030| Arlo Pro Wire-Free Camera
Highlighted
Aspirant
Aspirant

Did you try putting some folded paper or card stock behind the battery to create a tighter fit against the contacts? That worked for me.

Highlighted
Star
Star

To jguerdat:

Not so easy outside of the US,, Australia more constrained and suppliers holding less parts.

Also no where to go for tech support as suppliers just SELL.

i have 2 chargers and cords and none will charge/show icon.

I have tried all proposed “solutions”

 

help

Model: VMC3030 | Arlo Wire-Free Camera
Highlighted
Master Master
Master

@AppleArlo wrote:

To jguerdat:

Not so easy outside of the US,, Australia more constrained and suppliers holding less parts.

Also no where to go for tech support as suppliers just SELL.

i have 2 chargers and cords and none will charge/show icon.

I have tried all proposed “solutions”

 

help


Who did you buy from? The likes of Harvey Norman have been incredibly easy to deal with and have just swapped out faulty cameras once they've been confirmed to be faulty

Highlighted
Star
Star
Yes. Aware of that method of taking up the slack and tried it.. withhout success. Tried 2. chargers and 3 mini plug cords.
Highlighted
Aspirant
Aspirant

Same issue.   I've had it.    Won't charge and have done everything this site tells me to do.    

 

Model: VMC4030| Arlo Pro Wire-Free Camera
Highlighted
Community Manager
Community Manager

Fountain_N,

 

Are you using the charging cable and power adapter that came with your Arlo Pro Kit?

 

JamesC

Highlighted
Aspirant
Aspirant

Same issue as everyone above.  Obviously an Arlo defect if so many people are having the same EXACT problem. 

 

Yes I am using the supplied Arlo charging cable.

Yes I have tried removing the battery, reseating it and trying to charge it again.

I have four cameras and one charging cable.  Only one of the cameras will charge the batteries.

 

Model: VMC4030 | Arlo Pro Wire-Free Camera
Highlighted
Aspirant
Aspirant

I am trying to determine if the battery issue was resolved with the June firmware update. I would like to purchase but it is expensive and not useful to me if the issue is not resolved as of august 2018. I appreciate any help anyone can give me on this issue. Sincere thanks.

Model: VMC4030 | Arlo Pro Wire-Free Camera
Highlighted
Initiate
Initiate
My problem seem to be from the inside of the Arlo getting wet from being outside. Although it's supposed to weather proof. RMA the defective unit and bought a silicone cover.
That camera also stop detecting motion.
Model: VMC4030 | Arlo Pro Wire-Free Camera
Highlighted
Aspirant
Aspirant

Thanks very much for your reply.  I am going to order the unit again.  It may have bugs but id vastly superior to the alternatives in ease of use. I just use them inside.

i appreciate your help.

Highlighted
Aspirant
Aspirant

Just worked  for me.  Deleted non charging phone from base and resynced.  Now working not sure why.  Maybe I let the phone drain too long.