Arlo|Smart Home Security|Wireless HD Security Cameras|NETGEAR
Discussion stats
  • 3 replies
  • 1 kudo
  • 3 in conversation
Top Contributors
Caught on Arlo Video Contest
Share Video

Share Your Video!
Caught something cool on Arlo? Share it with the Arlo Community.

Post a video

Arlo Pro add on camera issues, no solid blue light on full charge, yellow light when battery full

I thought I would post this explanation as to why Arlo Pro doesn't charge or show the solid blue light when fully charged to help other users with the frustration that could be avoided (and get Netgear to resolve the root cause).   I purchased Arlo Pro with 4 camera's yesterday and was so impressed I purchased the 5th add on camera today.  However, unlike the first 4 camera's the fifth was a nightmare.  In fact, so bad I returned it to JB-Hi Fi where I purchased it and to their credit they immediately gave a replacement.   However, I believe there is actualy a Netgear software fault that causes this issue. It is very simple to do the steps to recreate the problem which is why so many people are getting it.  If you actually get this symptom you don't appear to be able to recover from it unless you get a new camera.


First the symptoms.  I sync'd the 5th camera but it never gave the blue flashing light during this process like the other cameras (how it is supposed to behave). All I got was a flashing yellow light on the camera (every 10 secs or so) which is supposedly flat battery.  I plugged the camera into the charger and tried to sync again.  After a few (3?) sync attempts the app (Iphone) recognised the device (but no flashing blue light on the camera to confirm)   I got an image from the camera, checked the battery status via settings which confirmed 100% battery and charging.  I unplugged the charger and the image dropped out immediately.  Restarted the app and camera was recognised but the yellow (amber) led kept flashing indicating low battery. I checked the battery via settings and it reported 100% (still flashing yellow)  I plugged the camera back to the charger (with a power monitor) and no current was being drawn.   No solid blue light on the front of camera to indicate full charge.  Checked the settings to ensure the battery full indicator set on.  Left the battery on charge (still drawing no current though) for 3 hrs since it is supposed to be fully charged from flat in about 2 hrs.  Still no solid blue light.   Still flashing yellow light on the camera indicating low battery.


Read all the support and tried all the suggested work arounds (i.e. deleting devices, swapping batteries, etc).  Nothing worked.   Seemed like the only suggested work around that actually worked was to get a new camera (not new battery).   So I returned the product and was replaced with a new one.


Repeated the syncing procedure with the new 5th camera and hey presto, worked perfectly. Plugged into a charger and got the solid blue indicator straight away as expected.  Looking back though I realise I did one thing differently that must have caused the original symptoms.  When I sync'd the 5th camera on the first attempt I simply held down the Sync button on the base station till the light flashed, then the Sync button on the camera.  (Did not add device through the app).  On the second attempt I was logged into Arlo through the app, then I added device through the app and followed the steps as the app prompted.  Everything worked as advertised.  Camera prompted to update firmare which also worked fine.


So it appears by trying to sync a camera initially when not logged into the Arlo base with the app (or presumably through the web) or not adding device from the app first somehow stuffs up the camera software so all these weird errors occur which don't appear to be recoverable from and frustrates many people..including me.  It is so easy to do it incorrectly.


Hope that helps any future users who purchase add on camera's...Netgear should also change the base station software to not allow camera's to sync when you are not logged onto the system.

Model: VMC4030| Arlo Pro Wire-Free Camera
Message 1 of 4

Re: Arlo Pro add on camera issues, no solid blue light on full charge, yellow light when battery ful

Good info and good catch. As a desktop engineer part of my job is re-packaging software so it works in our corporate environment. So many times I see similar situations like you explain where if you do one step out of order, or differently than the devs expected, that things can go wrong. After I re-packaged software I have to test dozens of scenarios, to hopefully account for anything the end user might do during install or while using the software. My feeling is many times the QC testing isn't thorough enough in many cases. Sometimes, devs / testers get "tunnel vision" and don't account for the many different scenarios that could arise from installing software and/or hardware. It could be here that netgear never tested syncing a camera if your logged out of the app, so they never caught this potential issue. Hopefully, if this is an issue, someone from netgear will address it an expand there test scenarios in the future.
Message 2 of 4
Community Manager

Re: Arlo Pro add on camera issues, no solid blue light on full charge, yellow light when battery ...

I've done some testing with this and you do not need to be logged in to the app to successfully sync a camera. Simply initiating the sync process by pressing the sync buttons on the camera and base station will allow the process to complete without issue. I believe in the scenario mentioned, you had a defective camera that was causing the issue.



Message 3 of 4

Re: Arlo Pro add on camera issues, no solid blue light on full charge, yellow light when battery ...

Hi James,

Actually, there is a problem and it is certainly to do with the way you sync cameras.  Now, you might be right that the sync works without being logged into the app but I managed to inadvertantly recreate the issue on two separate cameras on a separate system.    I showed my neighbour my system and he was also impressed so he went and got one. (4 camera's)  I mentioned the issue I had and to follow the instruction exactly and all should be well.  A few hours later I get a text saying he couldn't sync two cameras and could I come and take a look.   Exactly like my problem 5th add, he had two camera's blinking yellow (suggesting flat battery), the app shoing the batteries were full and no blue light during the sync process etc etc.  Arg, I told him I could find no way out of it and better to take it back to the store as the camera's must be dud. I asked how he synced and he said he followed the instructions exactly, was logged into the app.  Now, he said that after he added the first camera the app prompted for "Finish" or "Add another Device".  He chose neither option but just synced pushing the physical buttons. The second camera synced properly but the following two did not.  


Now, to have 3 camera's fail out of 9 within 50m of each other it a little bit hard to believe so I suggested we do a full factory restore of the base station and try again.  Did that, still the same issue.  Just before he took it back to the shop I thought I would take the battery out and leave it out for a minute or so.  I also pushed and held the open battery button for a good 5 secs (No idea if that does anything).  We did this on the two camera's that were having issues.  When putting the battery back, the one that I had held the button down for 5 secs now started behaving as a good camera, and, to our surprise we synced it (Using add device on the app) and all was fine.  The camera that we didn't hold the button down still was flashing yellow so we took the battery out again (for 1 min), held the button down for 5 secs...and it worked!


So Arlo, you definitely have some glitch in the sync process whatever it is and it certainly isn't obvious how to recover from it but it appears what we did at least allows you to recover from it instead of returning cameras.

Message 4 of 4