Arlo|Smart Home Security|Wireless HD Security Cameras

Arlo Pro 3 Video Delay/Lag

Reply
Discussion stats
morrawr
Tutor
Tutor
Latency... You said 2k will have some latency if you are a separate network. I've proven that even on the same network, streaming 4k the latency is almost the same as streaming "locally" on a 2g network.

The primary issue here is the latency between actual viewing and live viewing experiences. If you view on a local or remote connection, the latency is practically the same. It seems that at every aspect of viewing, the camera will always send the feed to the cloud first.
tony_2018
Apprentice
Apprentice

 

I can see you're adding way more than what I said even though I already clarified what I mean about networks.  My answer is still the same.

 

Can only stream 2k on local network, will have some latency issues.  

turkeysub426
Aspirant
Aspirant

Unfortunately, I have to say that all these issues sound way too similar/common to be "user error".  It seems to me like a general problem with the Arlo Pro3 system.  Problem is that I feel like I'm too deep in now to do anything about it - 4 cameras, 1 video doorbell, extra mounts, solar panels, etc.  Boxes are all long gone.  I'll have to give support a call when I get the chance to see if there is anything I can do.  Ugh!

J_JJ
Aspirant
Aspirant

Oh hey to be clear I was just trying to watch my live feed with cameras staged indoors without 2k finding that using my iPhone (Arlo app) over the same wireless network that the Arlo hub is connected shows constant feed delay of around 10-20 seconds.

 

But it sounds like this live 'feed' is always sent out to their external network first and does not stream across the internal network.

 

Thanks,

Model: VMB4540 | Arlo Pro 3 SmartHub
daxon
Star
Star

So, mine is still not useful when I receive a notification, although at least now all 4 cameras, doorbell and 2 base stations work.

 

If you have the iphone homekit app, you can see live streaming with only a second or so lag. However, it doesn't work for the doorbell at all. So that's useless.

 

And, if you get a notification for say, your side gate, from Arlo, by the time you open your Arlo app or the Homekit app and connect to the right camera, it's 15 seconds later because the app has to load and connect while the video is still being uploaded to the cloud.

 

While you wait, the new recording is unavailable, the person that walks through your gate is gone, and the live feed is still circling or hanging until the video is done.

 

If more than one camera is recording at the same time, it's glitchy.

 

I have two base stations and it still handles the bandwidth poorly.

 

It's just not written well. I can stream on 3 HD tvs simultaneously and have xbox game running with no problems, but one little camera recording is slow as molasses.

 

And the classifications of animal/vehicle/person... for a day now, one camera is just sure that any flying bug is a person. And a moving leaf is a vehicle.

 

Next time, hard wired cameras, local network, backup, and second backup to the cloud. This is stupid.

tony_2018
Apprentice
Apprentice
Most companies are stop making adjustments and updating their algorithm. I've seen false/miss alerts on ring, I've read about eufy as well, and yes I get the wrong alerts on Arlo. They'll work on it.

Its good you got the delay down, I just test live view and was messing the spot light and was only getting 2-4 sec delay. Guess having a power adapter on constantly helps.

Now if only I can get access to my local storage.....
daxon
Star
Star

Well, the 2-4 second delay only works if nothing is recording. And not on the doorbell. So it's not really a solution.

 

Because, when I get a notification that someone is moving around my house, it still takes too long to actually get anything to load until the recordings from the movement are done uploading to the cloud. If they are walking from the front gate to the back yard, that's 3 recordings, 3 cameras, and up to 45 seconds before I can get any of the live feeds OR recordings to work.

 

By then it's too late.

 

So this is still not working for it's intended purpose - live feed.

 

But if I just want to watch an empty yard with no movement at some other point, sure, works great.

turkeysub426
Aspirant
Aspirant

Yeah, same here on the next time being hard wired, etc.  I tried to go the "easy" route and now I'm regretting it.  Stupid, stupid...  I just thought the technology was here and had to be robust enough to handle the wireless signal and be able to stream well with the high bandwidth that I have...

Wibbey
Initiate
Initiate
If we can all work from home having video conferences with several other people across the internet with zero lag why can we not expect zero latency within our own networks? It's a bloody a camera no different from your webcam. I encountered the same 15-20 second delay lag. I can literally live stream to my TV located at the back of my house and watch myself walking through my own front door! Two way communication is not even approaching usable.
Model: VMB4540 | Arlo Pro 3 SmartHub
Stan-
Aspirant
Aspirant

I am also having this lag issue using the Arlo app and I was trying to find a way to resolve this. The lag in the Arlo App is horrible, when I move, the video feed picks up the movement ~10 seconds later.

Today, I have  connected my cameras to Apple Homekit. No lag viewing my videos through there and my video feed are being played in real time.

This is so disappointing from Arlo's part, especially for the price that these cameras cost, the app integration is so bad.

mrpetrov
Star
Star
Hi there - when you say you connected your cameras to Apple HomeKit (and that eliminated the lag) - which cameras are you referring to? The Arlo cameras...?
Stan-
Aspirant
Aspirant

Yes, I have the arlo pro 2 cameras.

Linusl
Luminary
Luminary

I have about 5-20sec delay when I want to stream. Sometimes no feed at all and I have to close the app and reopen and try again. I do have the Arlo 3 cameras set to 2K stream. I have the cameras about 3-10 (9-30 feet) meters from the basestation connected directly to my Amplifi router.

larch
Initiate
Initiate

Having taken delivery of the Arlo Pro 3 two camera system, I am also getting 2 to 10 second delay on the video.

This renders it useless as a security system.

This forum tells me this is a firmware problem that Arlo is denying.

 

I shall return this expensive system unless someone can post something with a cast-iron solution.

Model: VMB4540 | Arlo Pro 3 SmartHub
Markv1
Tutor
Tutor

I have the Arlo Pro 3 cameras and I always have a 1-2 second delay. That includes the video doorbell.

JamesC
Community Manager
Community Manager

The delay you are experiencing is normal behavior. A slight delay is expected as the camera must communicate with the Arlo cloud when live streaming.

 

JamesC

View solution in original post

Discussion stats