Arlo|Smart Home Security|Wireless HD Security Cameras
× Urgent: Activate Two-Step Verification
Arlo requires all users to activate two-step verification by Nov 30th, 2020 to continue to access your recordings, devices, and account.
Please enable this feature now. Learn More.

Re: VMB4000 Dead and a long support disaster - Help Please?

Reply
Discussion stats
  • 3 Replies
  • 291 Views
  • 0 Likes
  • 2 In Conversation
Highlighted
Aspirant
Aspirant

Okeycokey - firmware update of the setup killed the base station. Ive spent the best part of a month trying to get somewhere and done everything asked by the painfully slow support.

 

Finally got anoffer of a replacement unit even though its out of warranty and despite giving support the shipping address and telephone number 4 times i just kept getting a response of 'Hi, we will need your address and telephone number to proceed...'

 

Eventually got a live chat - more waiting to actually get the option let alone a chat - and i am told they don't have the shipping address and telephone number! For the 5th time i give it to them and im told an RMA email will arrive in the next few days and to follow the instructions.

 

Email arrives and after 2 days of trying 2 PC's, 2 Credit cards, 3 browsers and a lot of screaming i've lost the will to live.  I submit the address and contact details 2 more times (!) and then the credit card details to be told it has been accepted and i just have to close the window and click 'submit'. I do as instructed and the pop up for the address and cc details returns and im in a infinite loop.

 

For the love of whatever master you serve - what do i have to do to get this somewhat expensive setup actually working!

 

Any ideas?

 

Cheers

Nat

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Highlighted
Arlo Moderator
Arlo Moderator

Hi @blzeebub

 

It looks like your RMA has shipped. I have provided the link & RMA number below for you.

 

RMA Status

 

RMA#: 7082594

Highlighted
Aspirant
Aspirant

Hi,

 

Yes, the RMA has finally shipped but not until after a few more days of waiting and chasing. Finally i had to be called by your support staff to rectify the failure to complete the RMA.

 

Now i have 13 outstanding charges on my credit card to resolve from the multiple failures of your online RMA process. I suspect this may well be another battle.

 

Regards,

One less-than-impressed customer.

Arlo Moderator
Arlo Moderator

@blzeebub

 

I would suggest contacting customer support & provide the screenshots of the multiple charges.

Discussion stats
  • 3 Replies
  • 292 Views
  • 0 Likes
  • 2 In Conversation