Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Geofencing Not Working After 2.7.6 Update

Reply
Discussion stats
  • 45 Replies
  • 3019 Views
  • 16 Likes
  • 13 In Conversation
M19add Initiate
Initiate

Hi, I’ve been using my Arlo pro 2 system for a while now with geofencing arming and disarming the system as I come and go. But more recently the system doesn’t recognise that I’ve left home. So the alarm stays disarmed. My gps system is working fine on other apps like Hue - my lights come on when I arrive home. Both my Arlo app and my iOS are fully up to date.

Thanks.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
AncientGeek Hero
Hero

@M19add wrote:
Hi, I’ve been using my Arlo pro 2 system for a while now with geofencing arming and disarming the system as I come and go. But more recently the system doesn’t recognise that I’ve left home. So the alarm stays disarmed. My gps system is working fine on other apps like Hue - my lights come on when I arrive home. Both my Arlo app and my iOS are fully up to date.

Thanks.

Try removing the checkmark next to the name of the device you are using to determine your location, then save that setting, close the app and then open the app and reapply the checkmark.  I’ve had some difficulty with geofencing (especially with two devices on two people) in prior versions and tweaking the settings seemed to help.  Currently mine appears to be working ok on iOS 12.2 and Arlo app V2.7.5.

BobChadwick-GA Tutor
Tutor

I had used the geofencing feature in Arlo and found it to work for a while, then stop working.  I would play with it and get it to work again and then it would once again stop working.

 

Try this workaround using IFTTT and Life360.  I've been using it for quite a while and it works perfectly.  

 

https://homealarmreport.com/guide-using-ifttt-multi-user-geofencing/

M19add Initiate
Initiate
Thanks for your help! I’ll have a play later
AncientGeek Hero
Hero
Make sure you understand that when using these 3rd party services, you open your security and privacy up to folks outside the control of Arlo or Apple.

https://ifttt.com/privacy

For example, read about Google Analytics and cookies in IFTTT’s privacy policy.
howarmat Star
Star

Has worked fine for me for several years now with the 2.7.6 update on iPhone Xs its broke and always puts me in away mode

ShayneS Arlo Moderator
Arlo Moderator

Hi @howarmat

 

Do you have another device you can test the geofencing with? also, did you happen to make any changes to any power saving settings?

howarmat Star
Star

no changes to the power settings.  Its me and the wifes devices and once i get home I will experiment to see if its both or 1 of our devices.  Odd thing is that her device shows "in the zone" actually but still kicks it to away mode right now.

 

Thanks for the reply @ShayneS 

ShayneS Arlo Moderator
Arlo Moderator

@howarmat

 

Keep me in the loop & I will escalate this to support as soon as we get that additional information when your home.

howarmat Star
Star

So after another reboot I nothing changed.  I opened up apple maps and then it seemed to kick the GPS correctly into the zone as the mode switched instantly to the HOME mode.  Not sure what actually happened since her phone was shown as "In the Zone" the entire time.  But its working again.

AncientGeek Hero
Hero

@howarmat wrote:

So after another reboot I nothing changed.  I opened up apple maps and then it seemed to kick the GPS correctly into the zone as the mode switched instantly to the HOME mode.  Not sure what actually happened since her phone was shown as "In the Zone" the entire time.  But its working again.


Interesting.  It makes me wonder how the APIs are architected.  Is Apple Maps responsible for delivering location services to iOS apps?  Clearly they don’t have “direct” access since apps require permission to use location services.

howarmat Star
Star

@AncientGeek wrote:

@howarmat wrote:

So after another reboot I nothing changed.  I opened up apple maps and then it seemed to kick the GPS correctly into the zone as the mode switched instantly to the HOME mode.  Not sure what actually happened since her phone was shown as "In the Zone" the entire time.  But its working again.


Interesting.  It makes me wonder how the APIs are architected.  Is Apple Maps responsible for delivering location services to iOS apps?  Clearly they don’t have “direct” access since apps require permission to use location services.


I want to say it might be related to ARLO connecting with homekit feature.  I dont use homekit for anything BUT i wonder if somehow her opening up maps and getting that GPS location somehow did something with homekit and thus triggered the geofencing in ARLO.  Really grasping but it was the only thing i could think.  

Dannybear Mentor
Mentor
@ShayneS
This is not related to iOS App v2.7.6 as I am still using v2.7.5 but my geofencing spat the dummy today while I was away and partner still at home. She has since told me where I can shove the arlo.
Anyway the phone says out of zone on my iPhone and it says unavailable on her iPhone while both here or away.

So my question is, is there any news from Arlo’s management to when geofencing is expected to be rolled out to these systems?
Highlighted
justinh Initiate
Initiate

Experiencing the same issue after the 2.7.6 update with my Arlo Pro 2.  Geofencing shows my phone and the wife's phone "in the zone", however, I get "Geofencing at Home is now Away mode" and arms the system while we are home in the zone. I've rebooted the system and I am running ios 12.2.  Geofencing has been working flawlessly since I bought the system last July, something has changed.  Hopefully an update is coming to fix the issue. 

AncientGeek Hero
Hero

@justinh wrote:

Experiencing the same issue after the 2.7.6 update with my Arlo Pro 2.  Geofencing shows my phone and the wife's phone "in the zone", however, I get "Geofencing at Home is now Away mode" and arms the system while we are home in the zone. I've rebooted the system and I am running ios 12.2.  Geofencing has been working flawlessly since I bought the system last July, something has changed.  Hopefully an update is coming to fix the issue. 


I noticed that V2.7.6 prompted me to allow both location and home data.  Make sure you answered those questions in the affirmative and check Privacy -> Location Services for the Arlo app, just to be sure.  After checking (if it was all OK)  you might try toggling the check mark "off" on the device in the geofencing settings, saving and putting the check mark back and saving again.  Someone else mentioned opening the Apple Maps app made a positive difference in geofencing.

 

I've had some odd geofencing issues prior to V2.7.5, but it has worked well for me recently and correctly shows my wife and I "In Zone" here today and Out of Zone at our vacation home.  Earlier this week I was at the vacation home and she was here.  It correctly identified us as In Zone and Out of Zone at each location.

justinh Initiate
Initiate

I repeated those steps today of unchecking->saving->exiting, then re-checking->saving->exiting.  I opened Apple maps as well and all is well. Thanks!

AncientGeek Hero
Hero

@justinh wrote:

I repeated those steps today of unchecking->saving->exiting, then re-checking->saving->exiting.  I opened Apple maps as well and all is well. Thanks!


Great!  Glad to hear it helped.

Guinness835 Star
Star

Event since the last recent update, the geofencing is broken again. I am sitting at home, the system shows my phone “In Zone”, but it is still armed. I have the rule for home set to schedule, and the time to be armed is over. I’m really getting tired of the geofencing becoming non-operational all the time whenever you release an “Update”!!!

 

Also, how come in my iPad/iPhone app, when I try and change the times on the schedule it won’t let me do different times for individual day. For example, I want the cameras to disarm later in the morning on weekends in the schedule mode. When I go and select just Saturday and Sunday, and put the arm/disarm times in, it automaticllay defaults to whatever I have for the rest of the week. It simply will not let me do individual days. When I log in from a desktop, it lets me set times for individual days. This has never worked for me in the app before. Also, when I checked my schedule mode this morning, I discovered it had erased all of my times, so it wasn’t armed overnight when I am in Geofenfing with schedule mode. I don’t know when that happened, but it’s disturbing. I hadn’t gone into my setting in some time, and the last time I did check, the times were in there. I suspect it happened whenever Arlo did the last “Great” update. This is very disturbing and I am losing faith in Arlo. 

Model: VMB4000 | Arlo Pro/Pro2 Base Station
AncientGeek Hero
Hero

@Guinness835 wrote:

Event since the last recent update, the geofencing is broken again. I am sitting at home, the system shows my phone “In Zone”, but it is still armed. I have the rule for home set to schedule, and the time to be armed is over. I’m really getting tired of the geofencing becoming non-operational all the time whenever you release an “Update”!!!


Agreed.

 

Did you try the steps above to resolve your issues?

Guinness835 Star
Star

Hello,

 

I rebooted the system and It has now recognized I am in Home Mode. I didn’t know there had been an update until this morning. It’s frustrating that we have to do this whenever there’s an update!

Dannybear Mentor
Mentor
@Guinness835
Have you checked that your App version is updated? I haven’t updated mine and geofencing still fell over.
Guinness835 Star
Star

Yes it updated on the 4th.

Dannybear Mentor
Mentor
Might be worth disabling auto updates on your device so you can implement the workaround after manually updating.
CarpoDK Aspirant
Aspirant

After the software update the geofencing is not working as it should.

I am sure all settings are correct, but when i enter the home zone Arlo goes to Armed , but should be disarmed.

All was working fine before the last software update (iOS).

 

Please fix it quick!!!!

Model: VMB4000 | Arlo Pro/Pro2 Base Station
SecurityService Guide
Guide
I have exactly the same problem!