Arlo|Smart Home Security|Wireless HD Security Cameras

Bug in the New Arlo App Android (maybe iPhone)

Discussion stats
  • 0 Replies
  • 1 In Conversation
Muxika Follower

Hi all,

I finally took some time to talk with support about a bug I've experienced on the latest Android version of the Arlo App. I cannot speak to how it works on iPhones as I currently do not have one. I'm also not sure if this is an issued exclusive to those with multiple bases or not.

We installed a second base for range extension and migrated two cameras over to it. All firmware is up to date as of the day of this posting. 9/26/2019. When I log into the Arlo app from my Android Phone, the cameras on my second base station either register as offline, low battery, or some combination of the two.  The odd thing is that when I log into the web portal at, everything shows to be working perfectly fine. Additionally, I'm at least getting email notifications of video recordings on the supposed offline cameras.

I tried everything, reset all the things, uninstall/reinstall the app, clear cache/storage. Nothing worked. After mentioning this to support, I was asked to turn off wifi and see if it works on mobile. It worked! Even closing the app and turning on WiFi afterwards still worked. I then sought to re-create the issue to verify that this was what caused it, and what I found is that after clearing my cache/storage to make it essentially a brand new app again, with wifi on, on the launch and subsequent login, I once again was faced with the exact same bug as before. Fixable, of course, by turning off wifi and signing in via mobile data before turning it back on.

There is clearly a bug within the app that causes an error on the first log in if it was via wifi on the Android App. This needs to be resolved and hopefully will in a future update.

I hope this information helps any whom suffer from this issue. Hopefully if any of you iPhone users are facing the same problem, this helps you fix it as well.