Arlo|Smart Home Security|Wireless HD Security Cameras
× Urgent: Activate Two-Step Verification
Arlo requires all users to activate two-step verification to continue to access your recordings, devices, and account.
Please enable this feature now. Learn More.

Problem with Arlo Smart Premier and IFTTT Scheduled Recordings

Discussion stats
  • 3 Replies
  • 1 Like
  • 3 In Conversation



I have a number of scheduled Arlo recordings programmed on IFTTT Applets.  They were all working just fine for over a week, generating hundreds of recordings 


Then, I upgraded my Arlo subscription plan to Arlo Smart Premier.  From that moment on, all of my IFTTT Applets with scheduled Arlo recordings stopped working.


I tried stopping and restarting my IFTTT Applets, but that didn't resolve the problem.  I tried programming new IFTTT Applets, but they wouldn't work either.


So, I cancelled my Arlo Smart Premier subscription and went back to the Basic plan.  From that moment on, all of my IFTTT Applets started working again.


Has anyone else experienced anything like this?


Has anyone else managed to get IFTTT Applets to schedule recordings with an Arlo Smart Premier subscription?





Model: VMC3040|Arlo-Q HD Security Camera with Audio
Same here no solution yet. Support says they work on it on higher level 2 support and engineers.

I'm still on 'Basic' and everything is working. 


I've seen several people report problems when they subscribe to a Smart Plan so while I'd like to give Arlo some more money, I'm holding off until the issue has been resolved!


Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
Same here, I’m still waiting for getting my credits back. I have received this from the support but I told them I’m not signing up again before I have my credit for my canceled plans back. I’m not paying more money to find out that it’s still not working. All trust is lost!

Message from ARLO:
Good Day!

Thank you for your response and I really appreciate the information that you have provided.

I have looked into your case and I would suggest the following steps.

1. Login to Arlo App.
2. Go to settings > Smart Notifications > Enable People, Animal and Vehicle for all the cameras.

Let us check if you will receive other smart alerts other than Person detection.

Also, please go to settings of the iPhone, tap Arlo on the list of apps when you scroll down. Make sure Background App Refresh is enabled then tap Notifications.

1. Make sure Allow Notifications is switched on.
2. Under Alerts > make sure Lock screen, notification center, Banners are checked.
3. Sounds and badges is switched on.
4. Tap show previews and set to Always.

After this, let us observe the camera for a day and check if you will receive an alert for Person, Animal or Vehicle.

Lastly, on the library, each recording will have a label of either motion, person, vehicle, animal. After observing the cameras for a day, will the library only shows all recordings labeled as motion?

Also, can you please provide the following information:

1. Preferred callback number.
2. Preferred callback time.
3. Time zone.

Hope to hear from you soon. Have a nice day! Take care!

Again, thank you for choosing Arlo. Have a nice day! Take care!

Kind Regards,