Arlo|Smart Home Security|Wireless HD Security Cameras

Issue with Alexa routine interaction with camera.

Reply
Discussion stats
  • 27 Replies
  • 1948 Views
  • 0 Likes
  • 11 In Conversation
Cameraman22
Aspirant
Aspirant

I have both the pro2 cameras and pro 4 cameras and am having a problem in alexa carrying out routines involving arlo motion activated routines.  Most of my routines involve having a camera to activate actions due to motion detection.  When the motion occurs: 1. A push message or email is sent to my phone.  Then Alexa will turn on certain smart Kasa lights.   3. Alexa also will announce on motion on certain cameras. This worked fine until about 48 hours ago.  Now I will only get the action of a push message or email. 

 

I have been on the live chat with alexa for six hours Tuesday.  I am not certain if this is an alexa issue or a arlo issue.  After resetting my Alexa echo show two times and installing the Alexa app on my phone, I am still no better off.  I still only get push notices and just a couple of days earlier, it all worked well.  Since it did it on all cameras, I even deleted the routine in alexa two or more times and reinput them, it still changed nothing.

 

I can test the routine in alexa with the arrow you can push that runs the routine to see if it is correct.  It completely works and the light or lights will come on and alexa will announce.  It does not do it in real life time with motion. 

 

In working over and over and also reinstalling my alexa device I have come to a couple of standout things I noticed.  I am not sure, and I shared this with Alexa.  On my phone Alexa app when you select devices and then there is a refined selection of cameras and it shows each camera, which in my case are arlo cameras.  Under those it will say this camera does not support live view, which I assume is that I don’t subscribe for 24/7 live view.  You can click each camera and it open what appears to be a settings page for that camera and alexa itesm.  As it opens there is one item there that says “motion announcements” and it has a toggle on and off.  When you click and as it opens, it seems the toggle switch slides from off to on.  This is each camera that will do this.  Lets say you click on each camera again, it appears it is still on.  If I leave the app and just close it on the phone, not log out, which I rarely ever do, and then go back and open it, the toggle switch seems to slide to on when you click to see that camera.  I am only wandering if something in this action is cutting off the announcements until you open the button again.  I have done this many times.  It stays on if I leave app open, it has to be done again if I close the app, again I never log out.

 

However, the alexa camera setting being toggled to on and the app on as I stated in the previous paragraph, I can walk in front of the cameras that is armed and introduce the motion and I will immediately get the push notice on my phone, but I still am not getting the announcement and the light does not come on if set to do so. 

 

My kasa app works fine with programs such as away, timer, and schedule.  I can tell alexa to turn on any light and it does.  I can tell alexa to announce anything I want and it does.  That bottom part of the routine seems to simply not be working for some reason.  Mine worked fine two days ago, so it sure seems either Alexa or Arlo made some change.

1 ACCEPTED SOLUTION

Accepted Solutions
Cameraman22
Aspirant
Aspirant

Mine started working Wednesday morning.  I noticed early it appeared the cameras had rebooted and all.  After I got to changing back some of the settings and I noticed others saying it appeared to be working, I checked them and they were working with the routines and all.  My thanks to Arlo tech support for turning their focus to that matter, and for a lot of feedback comments pointing in a direction to get their attention of the severity and wide spread area of the problem.  

View solution in original post

27 REPLIES 27
GrumpyHuskie
Aspirant
Aspirant

I am having exactly the same issue! It worked a few days ago, I've tried everything I can to make it work but no luck. And I am also using arlo motion to trigger kasa light with alexa routine, something must be broken with either arlo or alexa.

Cameraman22
Aspirant
Aspirant

Definitely it appears something just changed.. I have noticed that Arlo used to be the icon and now it is Arlo Secure, but I read where that did not affect it and would not matter but that they were treated as the exact same.  That is something I read on one of these blogs.  I do not want to consider it, but for minimal cost it appears you can link google home to alexa devices at least to announce.  I am now playing with it a little, but to make it work you need one announcement device and then tie them through bluetooth to one of the echo speakers or maybe all of them.  I experimented yesterday with downloading the google home app on my phone, A lot like alexa on the phone app.  I did allow the arlo cameras to be reached by it, as the cameras popped right up.  I could see them cameras on both apps.  My echo will bring up the live view of any camera and did before this problem.   I did not go as far as to go further, but am sure wandering if I could get that to work on the speakers.  Looks like you can buy a google hub device for anywhere from $19 to $49 and they even have one compatible to the echo show.  It looks like that one can use the echo speakers.  May eventually try this and if I have to disable the alexa app for arlo and see if will announce.  Did your alexa camera section toggle on and off when you hit the button like mine did?  The bit I played with it, the google home appeared to not do that.  I did not readily have a google hub device or I probably have done it.

JRushton
Aspirant
Aspirant
Have exactly the same problem. Routines were working fine up until about 10 days ago. Erased them and rebuilt the routines…but no luck.
AJD8
Aspirant
Aspirant

I just started having the same problem with my 5 camera system. The announcements via Alexa seemed to have stopped about a day or so ago. 

GrumpyHuskie
Aspirant
Aspirant
Update: I tried homekit yesterday, it works fine, so the issue must be the integration between arlo and alexa routine.
Samesame
Aspirant
Aspirant
I’m having a same problem. I contacted both of Arlo and Amazon. Seems they are not aware of it as a trouble that happening for many users yet.
Cameraman22
Aspirant
Aspirant

Ok I have a ticket with Alexa and they said they would know if and when they get the announcement issue and the light coming on issue resolved.  So we know it is either the alexa app or the arlo app not performing like it should.

This sort of makes the camera non alternative for what you want when sleeping during the night and other times.   Can arlo tell us if this is an arlo communication issue or an alexa issue.  You would think arlo would make some com ment to  this link if they have any concern on the future use of their cameras.  If I have to move to google home or another product, I will eventually move to another type camera.  I would also think many others will.   I am researching the use of a google hub device and pair with echo as I have read that can work.  Has anyone used a google home device to pair with echo speakers and possibly get to announce motion events.  Of course I want it to also turn on lights too, and it is now doing either.  Anyone have the google home hub pairing to use with arlo?  And lastly, does arlo give a rip about helping us to resolve this or is their cameras becoming crap!!!!!!

Cameraman22
Aspirant
Aspirant

Does arlo support ever answer any of these?  

 

Samesame
Aspirant
Aspirant
When I had a chat with their support, they recommended to ask for Amazon. At this point I feel that Arlo doesn’t recognize it as a system issue. Rather they think it’s an issue happening for a user in unique situations. Hope they realize the problem soon.
AJD8
Aspirant
Aspirant

So, maybe this will help whoever is trying (hopefully) to fix this issue.

My system has 5 Ultra cameras and I get the Alexa notification for the one camera that I don't have record video, push notifications or email alerts enabled. Therefore, this sounds like a logic bug somewhere!

 

Cameraman22
Aspirant
Aspirant

Ok, I tried one of my cameras and I deleted the record only and left the push notification on.  I also had the routine in alexa to announce and to turn on one of my lights.  It did both.  So now my question is whether this may be an arlo, not alexa issue.  All of alexa routine part worked and I had to eliminate the recording video to get it to work.  I have a ticket number that I will send this information to Arlo, but before I do, I am now going back and eliminate push messages if I can and have it record in stead and see if that matter.  

V3nom
Aspirant
Aspirant
Please let us know how the google home is going could be a good temp fix until Arlo fixes the issue
Cameraman22
Aspirant
Aspirant

Upon reading a post on the arlo community under the thread of my post.  I changed a few of my camera settings on the Arlo App, like the post I read.  I first set the following:  Motion detection was on, record video was turned off, push message was turned on.  When I made this change, my routines ran, meaning the lights came on and alexa announced motion on the camera or the announcement I had in the routine.  The only problem was I no longer had anything recorded.   Two of my devices would never work either way with routines:  The Arlo Door Bell would not run the configured routine of making an announcement and turning on the lights (which before this issue, it would do just like a camera) and the Arlo Pro 3 Spotlight would basically not run the routine because it would not announce unless I turned off the spotlight feature completely, a lot to ask for just getting the announcement.  The pro 3 spotlight would also not turn on the other house lights of the routine.

That prompted me to change mine and try different combinations. None I tried would do any better. 

Final outcome thought was that from the Arlo perspective, something about checking or not checking the record video toggle made a difference in it reaction to the routines. 

So Until this is fixed, I have to choose between whether I want announcements and lights coming on with motion but no recording on the Pro 2 and Pro 4 cameras, or only a push notification with recording on the Pro 2 and Pro 4 cameras.  And on the Arlo Pro 3 and Arlo Door Bell, simply none of the routines of lights and announcements through alexa, only a push notification, unless I’m willing to give up the light on the Pro 3 Spotlight.  Certainly not using the cameras as they were purchased and working correctly.     

Mattera
Aspirant
Aspirant
Following this thread as I have the same issue.
SherrieB
Guide
Guide

Google-that's what I did as I happened to have a JBL Google speaker. Charged it up last night got up this morning and opened up Google home. My cameras were already there and I turned on motion announcements and voila. All the cameras are working fine. The Google home app seems to be overly simplified, not very customizable. But it's a workaround for now. I have an open ticket too. But the Arlo tech seems to be quite surprised by this issue. You should have seen all the things arlo's internal escalation department wanted from me. They ask for my type of device that the apps are on, wanted to know router type and serial numbers. Saved a screenshot of everything they wanted. Including some kind of Arlo logs from my phone to which they gave instructions on how to obtain. I responded back with a big NOPE. Told Ken, the Arlo rep, that this failure has NOTHING to do with my stuff. Not my phn or my router.  Especially since it works perfectly fine with Google. And it worked perfectly fine with Alexa until 2 weeks ago. I also suggested he read these community posts as I am not the only one this is happening to. I told them to stop having us waste more time than we already have. OMG Unreal...

V3nom
Aspirant
Aspirant
I was messing around with google home it sounds like it just will announce motion. You can’t have it play music or say something. I also can confirm Phillips hue motion outdoor sensor is not working with Alexa as well. It’s not announcing it
DaDudster
Aspirant
Aspirant
I'm having this issue as well (wired doorbell cam here). Not exactly sure when it stopped working, seems like it's been for awhile though.

Definitely thinking this is an arlo issue, but also want to point out that several of my triggers have been problematic lately, so this very well could still be Alexa related. For example, during this same timeframe (i.e., the last few weeks) my geofence triggers have essentially stopped working (or more accurately, they are delayed by like 30-45 minutes).

Regardless, it's frustrating!
DaDudster
Aspirant
Aspirant
Update: one interesting thing that I just noticed, which I thought worth sharing, is that the "no motion in X minutes" trigger does appear to be working.
Cameraman22
Aspirant
Aspirant

Upon reviewing the post and other actions that others described and especially the routines, I am supplying this info as an update to things I am doing and have discovered.  I have all but two of my cameras running on No Recording. I leave the two exceptions like they were before this started so I will know if a fix is downloaded into the system at some point.  I may change that when I go off for a while because I might want video on all and it will send a notice to my phone which I can get and see traveling.   This is not a feature problem that I want to have to continue without fix as it defeats much of the reason for having a camera security.  By checking No Recording, all but two of my cameras and even the  pro 3 spotlight are running the routines and announcing on alexa.  In reading some of the reivews, it was pointed out that the part of the routine where "no motion in x minutes"  is still working.  Mine is working with that as well and I had mentioned on earlier post that I had a customized announcement and certain lights come on when motion was detected.  I even had and have a routine that turns off those same lights that come one after X amount of time, so that if I am gone, it will turn off the lights and not leave on all day or night.  I see that part of the routine being built into the device and the routine at the top where you select the device for action.  My constant has been the routine add ons at the bottom and the selection of Record Video as the two constants that don't work as they did.  I also have the arlo doorbell and it is a little different, although it worked like the rest until this issue, as when I check no recording on it, I get the announcement of the door bell device (not from the routine)   which just says motion on the front door, but I also get the custom announcement immediately following it.  So the doorbell works all but turning on the lights. I suspect when this issue is ever corrected, it will go back to doing the lights as well.  And with all my other devices, some connected to two hub units, and some directly connected to app with wifi, when i check no recording, the push notice comes, the lights come on and the custom announcement plays.  So many variations it is difficult to pinpoint; however, I am trying to assist anyone with helping to speed up this correction.

SoundMixPro
Guide
Guide

Google did not work for me.

bigben89
Guide
Guide
I’m having the same issues.
Samesame
Aspirant
Aspirant
Seems it starts working again? Two of my cameras triggered Alexa routine from this evening. Hope it’s fixed and no problem anymore.
SherrieB
Guide
Guide
!! Out of the blue, Alexa motion announcements started working at 4:30 am!! I hadn't done anything to the system since I turned on Google as my workaround. So someone fixed something. Hope yours is working too. I am going to leave Google hooked up for a while to make sure this sticks.
AJD8
Aspirant
Aspirant

Yes, my system just started making the announcements all of a sudden also!