Arlo|Smart Home Security|Wireless HD Security Cameras
× Arlo End of Life Policy Notice
To view Arlo’s new End of Life Policy, click here.

Arlo Pro2 keeps changing mode from SmartThings to Disarmed

Discussion stats
  • 5 Replies
  • 4 In Conversation

Hello.  Over the past week or so, I've noticed that my Arlo Pro2 Cameras Base State Mode keeps switching from SmartThings to Disarmed.  I haven't made any changes to Arlo or SmartThings.  This is the exact same scenario as this ticket that unfortunately took months for Arlo to resolve with an update.  I'm really hoping that won't be the case again this time. 



Arlo App Mode:  SmartThings.  When cameras detect motion/sound, then they record. 

SmartThings app (v3):  Arlo Cameras are turned on/off with automations.  (Cannot change Arlo Mode.)  They are also supposed to record when SmartThings Home Monitor (STHM) detects an intrusion.  Nothing too fancy. 



I notice that I'm not getting any recordings in my library from my Arlo camera for a few days (which is atypical, given the wildlife around my house).  I check the Arlo Mode, and it says "Disarmed".  I change it back to "SmartThings".  I go back into the app a few hours later, and it says "Disarmed" again.  I check the Mode via a Firefox web browser, and the mode is also "Disarmed".  In Firefox, I change it to "SmartThings" again.  I go back into the app a few hours later, and it says "Disarmed" again.  I continue changing it to SmartThings mode in the app, but it eventually resets itself (time varies). 


Please review your latest updates, this previous ticket, and possibly your integration with the latest SmartThings app update, and determine a resolution.  I bought the Arlo cameras & lights over other competitors brands specifically for the integration capabilities that both SmartThings & Arlo touted, but the integration is not working once again.  Please let me know if you need any additional information.  Thank you. 



6 Arlo Pro 2 Cameras with Base Station (as well as 6 Arlo Lights with 2 light bridges - although those are staying in their correct mode). 


Hardware:  VMB4000r3

Arlo Employee Retired

Hi jsnphdrn,


I would suggest to contact Support Team to further investigate this issue. You will find several options for contacting support in the provided link.


Hello JessicaP.  Thanks for the suggestion.  I did eventually contact them via chat and they created a case for me and indicated their engineers were already working on it. 


On a side note, I hesitated to do this originally, because when I've tried this route in the past, they tell me a case is created, but I never hear anything from anyone.  When I try another chat the next week, the 2nd rep can't find any of my info from the previous case.  In the past, it could take 2-3 attempts to get a case created, and then I'm stuck clicking links sent to me in emails to "update my case"... and that's just to have some basic correspondence and fact-gathering about the issue.  Oftentimes, someone would email me with a question, and I'd click the link to update my case.  Then a few days later, someone else would send a follow-up email to me asking the same question.  I can't refer to any previous info I provided - because the user can't ever see anything they've sent in!  So, I copy and paste it again.  (I've gotten smart enough to save all my responses to avoid having to retype them every time.)  Then it's rinse & repeat... for every... single... question. It's just a terribly unfriendly support process.  I'm hoping it's improved since 9 months ago.  Cross my fingers...



So, after requesting a TON of details about my phone, Arlo System and App, and Smart Things App - all of which I provided... I never heard anything for a few weeks.  I started another IM chat, provided my case #, and the rep said my case was still being reviewed by "level 2", and she was going to try to escalate to get some sort of a status update.  A few days later, I get an update... They said my firmware was up to date, and they weren't aware of any issues with Smart Things.  So, it takes a few weeks to check my firmware and tell me it's up to date...?!?  I could have told them that when I looked in the app and it says so.  Also, why was I originally told that the engineers were already aware of the issue, and were working on a solution... yet this "level 2" group says they don't know anything is wrong...???  So frustrating... and unfortunately typical of Arlo support.  I'm not holding my breath for any real help. 


I actually just checked back on the Smart Things community to see if anyone has written some code in the past month to get Arlo - touted as "works with Smart Things" - to actually work as promised.  Go figure... someone has.  So, we have a home user writing code from the Smart Things side to get around the shortcoming in Arlo, while the Arlo engineers can't even troubleshoot a ticket correctly.  Disappointing, to say the least... but not surprising. 


Same problem here. Have been using Smartthing for years with old app and saw this problem there too, but it finally got fixed. Workaround then until it was fixed was to ignore Smartthings mode and switch to ARMED, but I've tried that this week with no success. So, now it's back in the new app, and YES, ARLO, my firmware on my hubs (V2 and V3) and cameras (Pro and Pro2) are all up to date as is my Android app. Maybe they need to hire some Russian  or Chinese hackers. As opposed to you folks, they seem to know what they're doing.


I have the same issue.  
Would you mind sharing some information re. the software that you got from the Smartthings Community?  Thanks.