Arlo|Smart Home Security|Wireless HD Security Cameras

Trying to get refund for Arlo system despite it being a new base station. Help?

Reply
Discussion stats
  • 8 Replies
  • 1076 Views
  • 0 Likes
  • 2 In Conversation
RachHClarke
Aspirant
Aspirant

Hi
Can anyone tell me how to make a formal complaint to Arlo. Been asking for a refund for a system that doesn’t work, despite a new base station, but still nothing, just keep being fobbed off and getting auto emails to tell me the case is closed (without them even having been in touch). I’m also going to raise the issue with Trading Standards. I’m a lawyer and this company is quite clearly in breach of consumer rights, action is needed!!!!
Thanks

8 REPLIES 8
TomMac
Guru Guru
Guru

Complaints can only go thru the Arlo Support or of course there is social media.... or a refund thru the place of purchase

https://www.arlo.com/en-us/support/contact.aspx

 

If you are a lawyer then you should know how to proceed legally if you want to go further.

BTW,  this is your 3rd post with the first two at the comm idea exchange.... if you have issues, there are people here willing to try and help you  with issues to get your system working if you want

--------------------------------------
Morse is faster than texting!
--------------------------------------
RachHClarke
Aspirant
Aspirant
Hey
I’d love to be able to get it working if anyone can help. Would much prefer that than the hassle of anything else. Any ideas who might be able to lend me their brains x
TomMac
Guru Guru
Guru

what's the issue you need fixed and what have you done already so not repeated.  ??

--------------------------------------
Morse is faster than texting!
--------------------------------------
RachHClarke
Aspirant
Aspirant
The base station continually drops off line. It’s absolutely not related to the WiFi.

Each time that it happens, the only way get things back online is to reset everything and add each camera back on. It refuses to reconnect with the cameras otherwise. Even then, it’s about 50/50 as to whether that works or not on any given day.

I’ve spent hours and hours on the phone to Arlo support and been through every tech troubleshoot they have. Including having a new base station sent. Issues still exactly the same after that.

I know I’m moaning my arse off but I just don’t have the time to keep trying to fix it or the time to worry about feeling safe. I’m on my own with toddlers, we had 3 blokes break into our house to take my Range Rover (to order apparently) and I’m now just really concerned about our safety. As luck would have it, the cameras were actually on that night but the notifications had failed so I woke up to watch the car driving off before seeing on the cameras that they’d been in the house for 35 minutes looking for the keys

TomMac
Guru Guru
Guru

Well I would have said that the base is defective, but a new base has the same issues....( base model or cameras unknown ?? )

So that limits the issue to prob either power or internet. ( don't know if you got a new power supply too )

 

Some basic info is needed,

So what type of service, router, model cameras/base do you have?

 

but will tell you that if power STAYS on the base, the cameras almost always stay connected. If internet goes out , it usu becomes a restart of modem, router, then base in that order otherwise the base may stay offline.

I'm thinking along the lines of router issues then power

But. also how can you say " It’s absolutely not related to the WiFi."... the base is connected by ethernet cable ... possible also to change cable or ports ?

 

 

--------------------------------------
Morse is faster than texting!
--------------------------------------
RachHClarke
Aspirant
Aspirant
So the base is VMB3000 (same as the previous one), the cameras are VMC3030.

It’s a Sky internet service and no change to the power supply. The only reason I’m thinking I can rule out internet or power is because I need to connect to a number of services via VPN for work. Any dropout in internet/power and those VPNs fail immediately. The VPNs have been functioning fine whilst the Arlo system takes an indefinite siesta.

What do you think?
TomMac
Guru Guru
Guru

Well then I might change my thoughts over to the power supply...

the base uses 12v, but the adapter converts it from your ac ( 240?)

 

could you try to get another ac adapter...or borrow one for temp to test?

otherwise it’s back to Arlo support

about 10-12$

--------------------------------------
Morse is faster than texting!
--------------------------------------
RachHClarke
Aspirant
Aspirant
I think we run on 230ac in the UK at the moment but I get where you’re coming from. I’ve only ever used the cables supplied by Arlo in the box.

Just can’t figure it out, the base unit still shows it’s powered up and connected to internet (Ethernet) but completely unresponsive.

I’m almost so stubborn that I’m not willing to admit defeat 😂. But at the same time, have spent a lot of money on something that I can’t get to work and that Arlo haven’t been able to get to work either, despite the hardware replacement and various software troubleshoots. You are clearly an absolute expert and I’m so very grateful for your help, if you ever need any legal or pharmacy advice (I’m also a pharmacist), then please do give me a shout!

It feels like it’s time for Arlo to either replace the whole lot and hopefully resolve it (I only bought the system because it came so highly recommended by a couple of friends) or refund the whole lot