Arlo|Smart Home Security|Wireless HD Security Cameras

Record without motion - Smartthings - Arlo

Reply
Discussion stats
  • 10 Replies
  • 17712 Views
  • 2 Likes
  • 2 In Conversation
gfbuyer
Guide
Guide

Is it possible to use Smartthings to start recording on the Arlo Wireless Camera ? My Use case is that I want to use the motion of another motion sensor to trigger an Arlo camera to record for 1 minute. I know in the Arlo app I can watch live and record. Really need to activate recording without having Arlo's motion detector triggering.

1 ACCEPTED SOLUTION

Accepted Solutions
gfbuyer
Guide
Guide

OK Finally got everything working working and wanted to list out the specific steps for anyone else looking in the future. My Use Case was to trigger a one minute minute recording from an external motion sensor using Smartthings Smart Home Monitor. The motion sensor I am using is the SkyBell HD doorbell integrated into Smartthings. The specific Use Case is that when there is motion at the front door, record on a camera that will capture the person answering the door and if guests enter the house they will also be recorded. 

 

Here are the specific steps to get it working:

 

1. Integrate the Arlo into Smartthings using the following: https://support.smartthings.com/hc/en-us/articles/209529506-How-to-connect-Netgear-Arlo-Cameras

2. In the Arlo App, set the Mode to Disarmed

3. In the Smartthings app, create a Smart Home Monitoring Custom Rule as follows:

- Select Device to Use as Motion Sensor

- Select the Skybell HD as the motion sensor (mine is named Front Door)

- On the next page select Camera to record as the Arlo camera you want to use

- Select Done and then finish the configuration. Press Save until you are back at the beginning. You should get a message that says Smart Home Monitor is updated.

 

Once this is done turn the camera On. This can be done in either the Arlo app or in Smartthings. I have a virtual switch setup in ST that I use to turn the camera on/off for ease of use in other automations.

 

Trigger the motion on the Skybell HD and you should have a recording start.

 

The main problem I was having was confusion about the Arlo modes and interactions with ST. Also I had an issue where the Skybell was not passing the motion event on to ST. I solved this by deleting the Skybell and re-adding. Once this was doen everything is working great. 

 

Hope that someone else finds this useful in the future.

 

BRH, thanks for the help ! 

 

   

View solution in original post

10 REPLIES 10
brh
Master
Master

@gfbuyer

I use almost every sensor that I have connected to Smartthings to trigger a camera to record video.

You must have the camera in the Active state in Smartthings. This can be done using Smartthings Routines as the active/disabled switch or, if your cameras can be powered either by ac power or solar panel, you can simply leave the cameras in the Active state in the Arlo app.

Using the Smartthings connect mode in Arlo, the default setting for Arlo cameras is to Do Nothing as Smartthings controls this feature. Also, Smartthings will control the recording time.

Simply create a Custom Rule in Smartthings to detect motion and start the camera/cameras to start recording video for the time you want to record for up to two minutes.

 

Brian

gfbuyer
Guide
Guide

Thanks for the suggestion !

 

In the Arlo Smatrthings mode do I need to turn the "When Motion is Detected" off ? I want to use a non-Arlo to dectect the motion and then have Smartthings trigger the recording on the Arlo ? 

brh
Master
Master

@gfbuyer

I am not sure, but I believe you can turn that off as Smartthings is controlling it. In my case I leave it on in case the sensor does not fire the camera still will. 

Try it and see.

I gave you very basic instructions as there are so many settings in Smartthings you can choose. Contact me later if you have difficulty.

Also, assuming the the cameras are Active, I think you can use the Smart Lighting Smart app to have even more control of the cameras.

 

Brian

gfbuyer
Guide
Guide

Are you using Smart Home Monitor to control the camera ? When I try to set up for instance a Routine, I am only able to turn the camera on or off, not turn on and start recording ? 

brh
Master
Master

@gfbuyer

You are correct. The Routines act as an on/off or Active/Disable switch.

For now to get it to record click on the gear at the top right of SHM and create a Custom rule for the sensor you wish to use.

Select the type of sensor you want to use and select Motion Sensor if that is what you are using or Open Closed sensor if you are using a multipurpose sensor. Select which sensor to use to activate the camera for recording, select the mode you want the sensor to turn on the camera, go to Notifications and choose Text Notifications give the message you want to receive and give the Rule a Name. Then go back to Notifications and select the camera you want to use when motion is recorded and for how long the recording should last.

Be sure to hit save.

Set your Routine and go activate the sensor. Wait until the time you set has elapsed then use another Routine such as Good Morning to disable the camera.

 

Brian

 

Brian

gfbuyer
Guide
Guide

HI Brian. Thank you so much for your help. I have seen your posts now in this community and the ST community working with people on this integration, and they have been very helpful. I think where I am getting hung up is what needs to be configired in Arlo Modes vs ST. LAst night I did get an ST SHM setup with an external motion sensor and trigger to record on the Arlo. The Arlo was turned on, but I got no recording. 

 

What Mode needs to be set in Arlo ?

brh
Master
Master

@gfbuyer

Do you have a Smartthings Mode in Arlo?

If not, go to the Marketplace in Smartthings > Cameras > Netgear Arlo Pro > Connect Now.

If you do have a Smartthings Mode already Then let me know what is happening.

Remember that the Routine in Smartthings GoodBye and Good Night must be set up and active to turn the cameras from the disarmed state to Active state. You can go to Things in Smartthings and if the routine is working properly, the selected cameras will show Active and any not selected cameras will show inactive.

After you have run the routine, every time you trigger the sensor the camera should record.

If you select a long record time and deactivate the camera early, you will not get a recording.

Secondly, if you switch to Live View while recording, you probably will not get a recording.

 

Brian.

brh
Master
Master

@gfbuyer

Also you did not tell me what model of Arlo cameras you have. I assumed that they were the Pro models. I don't think it matters much but if you have the original cameras select Wireless instead of Pro in the Connect Now in Smartthings.

 

Brian

brh
Master
Master

@gfbuyer

If you are still having problems tell me what type of sensor you are using and I can give you a step by step configuration.

 

Brian

gfbuyer
Guide
Guide

OK Finally got everything working working and wanted to list out the specific steps for anyone else looking in the future. My Use Case was to trigger a one minute minute recording from an external motion sensor using Smartthings Smart Home Monitor. The motion sensor I am using is the SkyBell HD doorbell integrated into Smartthings. The specific Use Case is that when there is motion at the front door, record on a camera that will capture the person answering the door and if guests enter the house they will also be recorded. 

 

Here are the specific steps to get it working:

 

1. Integrate the Arlo into Smartthings using the following: https://support.smartthings.com/hc/en-us/articles/209529506-How-to-connect-Netgear-Arlo-Cameras

2. In the Arlo App, set the Mode to Disarmed

3. In the Smartthings app, create a Smart Home Monitoring Custom Rule as follows:

- Select Device to Use as Motion Sensor

- Select the Skybell HD as the motion sensor (mine is named Front Door)

- On the next page select Camera to record as the Arlo camera you want to use

- Select Done and then finish the configuration. Press Save until you are back at the beginning. You should get a message that says Smart Home Monitor is updated.

 

Once this is done turn the camera On. This can be done in either the Arlo app or in Smartthings. I have a virtual switch setup in ST that I use to turn the camera on/off for ease of use in other automations.

 

Trigger the motion on the Skybell HD and you should have a recording start.

 

The main problem I was having was confusion about the Arlo modes and interactions with ST. Also I had an issue where the Skybell was not passing the motion event on to ST. I solved this by deleting the Skybell and re-adding. Once this was doen everything is working great. 

 

Hope that someone else finds this useful in the future.

 

BRH, thanks for the help !