Arlo|Smart Home Security|Wireless HD Security Cameras

Reply
Discussion stats
  • 4 Replies
  • 1260 Views
  • 0 Likes
  • 2 In Conversation
mhume01
Aspirant
Aspirant

Good morning!

 

This is a frustrating message.  I have had the system a yearish(Best Buy) and have had numerous calls with support.  I am on my 3rd base (The first 2 were replaced due to defect and not working correctly).  I bough extra cameras so I have 6 ( I thought more could be run at once).  Over the last year Arlo has replaced them all. (If I remember correctly I just received my 6 or 7th last week).  This is a lot of frustration. I just received my last replacement camera, it will not connect.  The one in my dining room started dropping video and needs to be reconnected daily.  The one on my covered patio just went down and will not reconnect. (yes I brought in next to base and have the most current firmware)

 

For more info, the main router and the house router are on a battery backup on a recommendation from an Arlo tech.  The batteries are a rechargeable brand that were recommended by a tech.  I have contacted my service advisor on the advice of a tech and had all ports and frequencies adjust to what Arlo needed.  All 3 lights are lit on the base.  When I try to connect I go through the process of removing and adding a new ones through my desktop.  The proper lights flash (slow Blue on camera, far right light on the base flashes).  There are not any devices in the house that have changed that would be causing interference.  Just in case, I have moved the router to different rooms to see if that changes anything.

 

I had a supervisor before the pandemic had talked about maybe it was the model system in my house and maybe a complete swap out to a different model was needed.  I have dumped $600? plus into this already and have had subpar results so far. I cannot seem to get anyone on the phone about the tech level now.

 

Any suggestions or thoughts on what the issues could be because right now I am pulling my hair out.

 

Thanks in advance.

 

Mike 

4 REPLIES 4
mhume01
Aspirant
Aspirant

*Update.  Tech support could not get the new camera to connect and upgraded my complaint to a level 2(?) and a supervisor would get in touch with me.  That was 2 days ago an I have yet to receive a call.  Lost another camera today that will not reconnect.  Down to 2 cameras now.

JessicaP
Arlo Employee Retired

Hi mhume01,

 

Are you still having problems? Let me know if you still haven't heard back from the support team.

mhume01
Aspirant
Aspirant
Thank you for the reply! At this time I only have 2 cameras working. I have not heard back from anyone in level 2 support yet.
JessicaP
Arlo Employee Retired

Let me reach out to you via private message to gather more information from you.