Arlo|Smart Home Security|Wireless HD Security Cameras
× Arlo End of Life Policy Notice
To view Arlo’s new End of Life Policy, click here.

Reply
Discussion stats
  • 6 Replies
  • 3608 Views
  • 13 Likes
  • 3 In Conversation
maddidaddi
Star
Star
The new update has killed my system. My base station goes offline constantly. My camera's lose connection constantly which kills their battery. My system is useless, I cannot trust it
6 REPLIES 6
Runner56
Guide
Guide
Agree, the new update has all but killed the Arlo system. Base station continually loses connection to cameras, cameras fail to record. Did not have any such problems prior to update. Arlo system is bricked. Will now tells businesses, friends and family who were about to purchase Arlo to forget same. Find another product. Maybe Arlo will fix this but based on overall responses in customer support, highly unlikely.
Runner56
Guide
Guide
Agree, the new update has all but killed the Arlo system. Base station continually loses connection to cameras, cameras fail to record. Did not have any such problems prior to update. Arlo system is bricked. Will now tells businesses, friends and family who were about to purchase Arlo to forget same. Find another product. Maybe Arlo will fix this but based on overall responses in customer support, highly unlikely.
ShayneS
Arlo Moderator
Arlo Moderator

maddidaddi,

 

What version is your base station & cameras currently running? Have you tried to reboot your base station?

maddidaddi
Star
Star
I was told I have a faulty base station. I have an RMA email which I completed. But I have not received the RMA information email on how to actually return my device
ShayneS
Arlo Moderator
Arlo Moderator

maddidaddi,

 

Have you contacted support regarding the case number to provide the information for the return?

Runner56
Guide
Guide
SOLUTION FOUND. Using Arlo wireless. Could not keep internet connection on Arlo base. No video recordings with cameras only notices. Contacted support. Nothing worked so support sent replacement base. New base installed. Same problems.
Then I noticed similar complaints from others on here. I researched and almost all had one same common denominator. All including myself had upgraded to the Arlo Smart plan. That subscription up grade is exactly the time my problems began.
I quickly cancelled my Smart plan subscription and went back to the free basic plan. Within 2 minutes I had full uninterrupted base station connection and video recording of all events on all cameras.
The problem is Arlos Smart Plan subscription, it wreaks havoc with internet connections and video recording. Use the free basic plan only until Arlo gets their Smart Plan software fixed.