Arlo|Smart Home Security|Wireless HD Security Cameras

"This video is not able to play in your browser. Please download to view" on Chrome and Edge

Reply
Discussion stats
  • 10 Replies
  • 124 Views
  • 0 Likes
  • 5 In Conversation
Highlighted
Aspirant
Aspirant

I have been receiving a message when I try to view my recorded videos, This is the message I am getting, Re: This video is not able to play in your browser. Please download to view. This seems to be an ongoing issue with arlo by what I have read on your site,

I have rebooted my computer, Cleared a cookies and history, I tried to run on Google chrome and Edge and get the same message on both,

I just spent a lot of money on an upgrade from Pro  2 to a 5 Camera system with Ultra, I am now like others getting very frustrated and debating whether  to change to another manufacture of cameras, When I first installed the new system, everything worked fine, Just recently  is when this issue has been occuring.

I have been a user of Arlo for about 6 years, have had glitches like most people, but for the most part I have been satisified with it, Can someone offer a suggestion,

The next step is to call Arlo direct,

Thank you!!

Highlighted
Prodigy
Prodigy

unless your still using 1080 only edge supported 2K and 4K HEVC until your updated to the new edge chromium which isn't supporting it and your stuck having to download to view.  This happened to me and I was able to restore to the day before the update.  Back to edge legacy and it's working again but I had to turn off Microsoft updates to stop the new edge update.  ( had to restore twice now)  I was gone on a trip and haven't got it done yet but some businesses had issues and there is supposed to be a reg edit that can be done to prevent the new edge download without turning off all downloads.  A search for blocking the new edge download gets instructions.

Highlighted
Prodigy
Prodigy

I should have pointed out that if I understand right you can turn on pan and zoom which will make things 1080 and then your video will play at the lower res.  That however seems pointless going to these cams.

Highlighted
Aspirant
Aspirant

I have 4 arlo ultras, have been having lots of probpems with recordings, not recordings and error messsages, I have now  been able to get  3 of my cameras working but I get an error message from one of my cameras that reads

This video is not able to play in your browser.

Arlo is beginning to not become as user friendly as it once was,

To many technicial issues,

 

any suggestions on this issue,

Thank you

 

Highlighted
Guru Guru
Guru

@margulies wrote:

I have 4 arlo ultras, have been having lots of probpems with recordings, not recordings and error messsages, I have now  been able to get  3 of my cameras working but I get an error message from one of my cameras that reads

This video is not able to play in your browser.

 


What browser are you using?  

Are you recording in 2K or 4K?  Of are you using 1080p?

Is this happening to all videos from this camera?  Or only some?

Highlighted
Aspirant
Aspirant

Hello, The browser I am using is  Google Chrome, although I have also tried running with Edge with the same results,

I am recording in 4k,

the issue is with all of the recorded videos, just from this one camera, I have other cameras that are the same, I checked all of the settings and compared the ones that are working to the one with the issue and all of the settings are the same,

hope this helps,

Thanks for responding!!

Highlighted
Guru Guru
Guru

2/4k recordings are a problem with browsers since the browsers don't support that resolution. 1080p is the highest they will go. Your other cameras must not be recording in the highest resolution.

Highlighted
Aspirant
Aspirant

Arlo needs to come up with a software fix that will correct the issue of not being able to playback videos on Google chrome and Edge Browser,

Its  Ridiculous that you  can't  view recorded videos and have to download videos just to view them, when recording in 2 or 4 K,  which doesn't work either.

 I am sure there are others out there that are just as frustrated when spending a lot of money for something that works half the time if that!!!!

Highlighted
Aspirant
Aspirant

I have to Gripe a little!!!

if Arlo is having so many problems with 4k and 2k not able to view with Google or Edge, and have to down each video individually, when even that doesnt work, 

Why would I have purchased an Ultra 5 camera system, to up grade pro a pro 2 system, when I wasn't having any problem, wanted to upgrade to a better camera, but here we are, included with all of the others who are having the same system problems.. why would they sell a system, when in fact there was a problem that they are aware of, and yet have no fix!!! 

Highlighted
Sensei Sensei
Sensei

@margulies wrote:

Arlo needs to come up with a software fix that will correct the issue of not being able to playback videos on Google chrome and Edge Browser,

Which Edge version are you on?

 

It works fine here:

 

Microsoft Edge is up to date.Version 83.0.478.58 (Official build) (64-bit)

 

and

 

Microsoft Edge is up to date.Version 85.0.552.1 (Official build) dev (64-bit)

 


Just another user
Arlo hardware: Q Plus, Pro 2 (X2), Pro 3 (X3), Pro 3 Floodlight, Security Light (X2), Ultra (X2), Doorbell, Chime
Highlighted
Prodigy
Prodigy

It may be working fine for some, if your computer handles it completely with hardware so depends on your computer.  If not, the last version of edge to work was 44.18362.449.0  If it updates to the new chromium version it no longer works.  Some do say there was a earlier version of edge chromium that did work.  I've had to restore my computer to a previous date twice now to get a working version of edge.  

Discussion stats
  • 10 Replies
  • 125 Views
  • 0 Likes
  • 5 In Conversation