Arlo|Smart Home Security|Wireless HD Security Cameras|NETGEAR

The Arlo Community

Learn, explore, ask questions, and connect with our community of customers and experts.

Discussion stats
  • 41 replies
  • 1817 views
  • 72 kudos
  • 13 in conversation
Top Contributors
Caught on Arlo Video Contest
Share Video

Share Your Video!
Caught something cool on Arlo? Share it with the Arlo Community.

Post a video
Reply
Highlighted

Arlo Ultra Problems & Feedback Thread - my criticisms so far

01/25/2019 Updated review: Update on my experience and decision to keep my Ultra 4-camera system

 

4 days into this experience and all I can say is THIS IS A JOKE! I have been a huge proponent of Arlo since the very first cams hit the market. I’m a loyal customer having owned the original cams, Pro and Pro 2. Prior to the Ultra 4 camera purchase, I had a 20 camera Pro 2 system and a Smart Elite paid subscription. I even bought a set of Arlo cameras for my mother and sister’s homes as Christmas presents 2 years ago.

 

Today, I feel CHEATED. These Ultra cams aren’t cheap, the accessories you get in the box seem stripped down/scaled back, the additional accessories (yet to be released) are incredibly expensive for what they are and an obvious way to generate additional revenue for Arlo as they likely cut margins in the cam itself to keep consumer costs down. In addition to Arlo cutting corners with accessories out of the box which incurs additional “hidden” costs to the consumer, there are more hidden costs to have your 4K cams actually record to the cloud in 4K. I could overlook these very disappointing facts IF THE CAMERAS ACTUALLY WORKED! Over the course of the last 4 days, it had gone from bad to worse. As I mentioned already, I’m a loyal Arlo customer, historically a major fan —- but can say I have now been let down in a big way. I feel deflated. I feel cheated. I’m going to continue to test the Ultra cams up until the end of the Best Buy return period - then I will likely return the Ultra cams to Best Buy. 

 

I’ve already invested a ton of money for my Arlo Pro 2 system and that system works great. Why change if the Pro 2 cams worked so well? I wanted 4K, the newest camera technology from Arlo naively thinking Arlo wouldn’t let me down. Boy was I wrong. 

 

I couldn’t have been more excited to pre order the cams and anxiously waited for the box to arrive. I was like a little kid at Christmas barely able to sleep the night before thinking about Santa dropping down the chimney with my shiny new toy. Santa (FedEx) even came early delivering the cams on Saturday in advance of the Jan 14th release date. Like a kid at Christmas, I was overly excited as I opened the box unveiling the newest Arlo technology. Just days later, I feel like someone just told me Santa wasn’t real.  Why? Bait and switch - I feel lied to! In all of the pre release info, I did not see that I would have to pay nearly $100 annually for my four 4K cameras to actually record 4K to the cloud. As mentioned, I’m a paying customer with the highest priced subscription, Smart Elite. I have 15 Pro 2 cams + 5 more on a free account that I ultimately wanted to upgrade by merging into a single account now that the Smart Elite subscription allowed up to 20 cams. And ultimately, I wanted to now upgrade a majority, if not all cams, to the new Ultras.  Now, it’s doubtful I will even keep the 4 Ultra cams. 

 

SUBSCRIPTION COSTS

To have 4K cloud recordings, it is 1.99 per camera, per month. In order to have the four 4K cams I purchased to actually record to the cloud in 4K, my monthly subscription cost goes up to 34.90/mo from 14.99/mo. Really?! This is more than disappointing, however, sucked it up and paid for the 4K upgrade despite the feeling of a total bait & switch by Arlo.  

 

As I mentioned above, I had planned to upgrade most, if not all, of my Pro 2 cams to the new Arlo Ultra. That is cost prohibitive. Let’s say I only upgrade 10 of the 20 Pro 2 cams to the new Ultra and keep my Smart Elite subscription. That’s an additional 19.99/mo totaling 238.80 in a year if you pay monthly. This is in addition to my Smart Elite subscription which is 14.99/mo totaling 180 in a year.  That’s a whopping 418.80 a year, paying monthly. There’s a slight discount if you pay for the year upfront. 

 

The additional cost is a game changer - IF I DECIDE TO KEEP THE ARLO ULTRA CAMS - I would most likely not upgrade more than the 4 Ultra cams I just purchased. 

 

 

TESTING 

I’ve been running my Pro2’s cams and Ultra cams virtually side by side to compare video quality, night vision, viewing angle, motion detection, sound quality, etc. As of last night, I was only slightly impressed with daytime video quality @ 4K (see comments in viewing angle), hugely disappointed in the motion detection and extremely annoyed that the signal strength isn’t as advertised and a mere fraction of all prior models. Connectivity issues are ongoing despite the firmware upgrade. I experienced pixelation issues once I upgraded to 4K. Ultra cams are slow to start up once triggered. 

 

Motion detection is terrible, sometimes nonexistent. Even worse, I woke up this morning to check the overnight recordings only to find that all 4 of the Ultras stopped recording at 9PM last night. Only my Pro 2 cams were recording overnight.  SERIOUSLY?!? This may be the straw that breaks this camel’s back with the Ultra cams. 

 

 

THOUGHTS ON ACCESSORIES INCLUDED IN THE ULTRA BOX

You only get 2 magnetic mounts in a set of 4 cams where my original Arlo cam multipacks included and the same # of magnetic mounts as the # of cams in a package. Check out the cost for additional magnetic mounts - 39.99 for two.  Seriously? The Ultra 4 cam system I purchased also included two Quarter Twenty Mounts which is an outdoor security mount. These mounts are worthless and cheap. Arlo should be ashamed to have included these flimsy mounts. Give me four magnetic mounts and drop the outdoor security mounts! Now onto my beef with the change to the magnetic mounting capabilities. 

 

What I LOVED about all prior Arlo cams was the flexibility to mount cams anywhere. I have several cams attached to metal doors and metal patio furniture b/c the back of the camera is a magnet. Now that has changed. The Ultra system magnetic mounting is different than all prior cams reversing the magnet side and the metal side. Now the mount is magnetic and the camera has a metal lining to attach to the magnetic mount.  All prior cameras were the reverse of this. WHY DID ARLO CHANGE THIS? I want this flexibility. 

 

One short charging cable is included making it impossible to replace the Pro 2 cams I have plugged in. I need a longer cable. Wait, Arlo will have two options! Uh oh, price? 49.99 for a 25’ power cord! Ok, maybe the 8’ indoor cord could be utilized. That’s still 24.99! Why not sell an adapter that would convert the end of a mini USB cable into the magnetic charging cable? I have a ton of Pro 2 power cables/adapters I’d pay to buy a simple adapter for the mini USB end. 

 

 

CONNECTIVITY

Signal strength is terrible and only a fraction of the advertised 300’.  There were connectivity issues right out of the box that appeared to be corrected by a firmware update. I say APPEARED as I awoke today to find all four Ultra cams offline this AM.  I’ve reset the base, power cycled the base, power cycled the cameras - NOTHING! Ultras remain offline. Pro 2’s are just fine! 

 

 

VIEWING ANGLE 

Wider viewing angle is nice to have but think it impairs clarity as objects are now, in effect, much farther away. Faces and license plates are still blurred and unclear. Why?The field of view is so wide that as soon as you get even a little bit of distance from the camera, the object such as a car or a person,  now fits into a teeny-tiny portion of the recording.  Zoom in on the object and the 4K view is just as blurry as my Pro 2 cams with a narrower viewing angle. 

 

 

NIGHT VISION

I wanted to start off without the color night vision fearing the battery drain could be significant and current placement of Ultra cams is a high traffic area with cars, dog walkers and joggers. I have landscape lighting around my home with several spot lights pointing up the walls of my home. A little light splash.  My Pro 2 cams were totally unaffected by these lights. The Ultra cams “see” the light and think it’s dusk, all night long. As a result, the Ultra cams will not changeover to night vision. Side note - none of the spotlights are directly underneath my cameras. I even moved the spotlights further away to see if I could trick the cameras into night vision to no avail. No matter the location, it’s too much light therefore I have cameras operating like it is dusk. The supposed 4K in “perma dusk” of night, is absolutely horrible! Grainy. The Pro 2 cam video quality at dusk was grainy two, as most any camera is in low light situations.  At least with the Pro 2 cams, night vision would trigger at nightfall. The Ultra cams just will not change over to night vision. I am not going to trash my investment in landscape lighting not going JUST to have regular black/white night vision on my newest cams. 

 

With standard night vision non-functional in my Ultra cams, I decided to go ahead and change the setting to add the spotlight in low light situations.  I changed the setting before bed last night activating the spotlight feature, however, unable to see the outcome as the system went offline sometime after I changed the setting. The cameras remain offline now. 

 

 

SOUND QUALITY

Haven’t tested as I am dealing with all of the other problems. Why bother. 

 

 

MOTION DETECTION

At 100% sensitivity, the Ultra cams perform significantly worse than the Pro 2 cams set to 70-80% sensitivity.  

 

25% of the time, the Ultra misses the motion all together where the Pro 2 camera picked up the activity without issue. 

 
CONCLUSION SO FAR - Ultra cams aren’t ready for prime time as there are too many bugs from the onset, features do not operate as advertised not to mention there are hidden costs that really make the Ultra cams cost prohibitive for the average person. I’d wait for the next iteration of Arlo cameras with the hope that Arlo listens to its consumers, learns from this ULTRA-failure product launch. 
 
 
1FC62138-3ED6-4A2E-A295-6810F374EC76.jpegOffline this AM888E29A0-394C-4C3D-A76F-2C844A1A1BEA.jpegStill offline93770AC3-0E83-4EC4-AAF3-198FD59554C6.jpegPixelation after 4K subscription upgrade. To think I PAID for this.
Message 1 of 42

Ultra Cams no longer connecting to base

My 4 Ultra cameras disconnected from the base sometime last night and have been unable to reconnect. The base is up, online. I have restarted the base from app, I have walked over to the base and power cycled, I have pulled the batteries from all for cams to reset them. Nothing. Still offline. Why so many bugs?! I dread calling Arlo for support and/or live chat. They tend to be condescending and unhelpful - time wasted without resolution in the end. 

Message 2 of 42
Apprentice

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

Thanks for the detail.  I lost all confidence in Arlo way back to last May.  I was a little geeked when I saw the introduction of the Ultra.  I soon discovered the Ultra hub was misrepresented as being capable of producing a stronger WiFi signal when in reality, it does not.

 

I have 7 Pros and have my issues with them.  But all of these issues were caused by Arlo developers.  Sef-inflicted if you will.  I tried the Pro 2 but felt it too was released before being ready for prime time.  Night vision was terrible.  I returned it.

 

Anyway, thanks again for your review.  I will not invest any more in Arlo and I seriously doubt they will listen to their customers as you hope they will.  They never have in the past.  I don't see them doing so now.

Message 3 of 42

Re: Ultra Cams no longer connecting to base

Because I am a glutton for punishment, I checked on the Ultra base again.  Indicator light is blue, like it’s connected. I power cycled, again.  Now the indicator light flashes orange. Viewing my cameras in the Arlo app, they now show “base not connected”.  I went into “my devices” in the app and appears the base station is up, cameras are not connected. Base still flashing orange. 

Message 4 of 42
Community Manager

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

zincyellowcobra,

 

A new firmware update for the SmartHub was released that may help with the issues being discussed here. Please make sure your SmartHub is up to date with the latest firmware (1.12.0.1_30356) and let us know if you continue experiencing issues.

 

The development team is still keeping a close eye on these reports. We appreciate your patience in this process. I will provide new information here as I find out more.

 

JamesC​​​​​​​

Message 5 of 42

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far


@RaylanC wrote:

Thanks for the detail.  I lost all confidence in Arlo way back to last May.  I was a little geeked when I saw the introduction of the Ultra.  I soon discovered the Ultra hub was misrepresented as being capable of producing a stronger WiFi signal when in reality, it does not.

 

I have 7 Pros and have my issues with them.  But all of these issues were caused by Arlo developers.  Sef-inflicted if you will.  I tried the Pro 2 but felt it too was released before being ready for prime time.  Night vision was terrible.  I returned it.

 

Anyway, thanks again for your review.  I will not invest any more in Arlo and I seriously doubt they will listen to their customers as you hope they will.  They never have in the past.  I don't see them doing so now.


The Pro 2 cams are awesome. The bugs have been worked out and think you wouldn’t be disappointed. Side note on the Pro 2 night vision —- The night vision does have a washed out appearance when the infrared reflects off certain objects like the arlo skins with a “hood” that extends forward. I tossed the Arlo skins and bought aftermarket skins without a hood and night vision was great. 

Message 6 of 42

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

@JamesC

 

I checked, Ultra base is up to date w/ latest firmware. Still unable to connect the Ultra cams. The base station indicator light keeps flashing orange.  What does that mean? 

 


 

 

AAFFC3DC-5B30-4E97-BE60-CE2F648F2F3A.jpeg

Message 7 of 42
Community Manager

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

The flashing orange on the SmartHub indicates a connection issue.

 

Try rebooting the SmartHub (unplug and plug back in) to see if you still experience the same LED pattern.

 

Given the number of issues you're experiencing, it might be best for us to open and escalate a case to further investigate.

 

JamesC

Message 8 of 42

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

@JamesC

 

I have power cycled, still same orange flashing light. The arlo app reflects the base is connected despite the orange flashing light. The app will allow me to restart the base station. The cams, they are not connected.  

 

 

 

22CBF95B-418F-4297-9797-69AE45520273.jpeg

Message 9 of 42
Community Manager

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

It may take a few minutes for the SmartHub to fully boot and connect.

 

I've sent the information you provided here over to the engineering team for analysis. I'll provide an update when I know more.

 

JamesC

Message 10 of 42

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

@JamesC Thank you

Message 11 of 42
Star

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

Your review is EPIC. Well done my friend, and you just helped a lot of people from wasting time and money on this failure of a product. I am also a big fan of my Pro2 camera system (now that they worked the bugs out which took a long time) and Arlo in general. Now I am angry at the cash grab some clueless executives made in an office who probably came from Sears. That would explain a lot.

Message 12 of 42
Apprentice

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

I couldn’t agree more. Bad to worse is an understatement. I started out with having issues with a couple of the cameras no being recognized by the base. After about 10 tries the cameras were recognized. Then I spent several hours trying to sync the doorbell only to find out it isn’t even compatible with Arlo Ultra yet. Then one of the cameras that is closest to the base (literally right outride the window) kept loosing it’s connection. Last night things seemed to be better. Then this morning things went downhill fast. First the PRO2 cameras were not connecting. Then I noticed I wasn’t receiving any notifications on any of the cameras. I try to check the status and says all the cameras are off line. I go check and the base station is blinking orange. Tried it restart, even changed the network cable and no luck. Been that way all day. I won’t even start on the fact there isn’t any more free cloud storage. It is obvious this product was not ready for release and it ruining the Arlo reputation quickly.
Message 13 of 42

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

@DRA_PA

 

I had to delete the Ultra base and cams, reset the base to factory default the re-add base, re-sync cams. Now finally up after being down last night and all today. At least I can gat back to testing, comparing. 

Message 14 of 42
Apprentice

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

Thanks. Was afraid of that after I got everything all set-up.
Message 15 of 42

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

@DRA_PA

 

Deleting equipment and re-adding removed the 4K upgrade subscription from my account. Tried to log into my account to re-add to no avail. I’m at my wits end. Bad to worse to even worser!!!!

Message 16 of 42
Community Manager

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

If you removed and readded all of your equipment. You may need to add the camera back to the premium video recording on your account (PVR).

 

(on Web) To do this, log in to your Arlo account and navigate to Settings > Subscripton > Manage camera status > Drag your Ultra camera into the PVR slot.

 

(on Mobile) To do this, log in to your Arlo account and navigate to Settings > Manage camera status > Drag your Ultra camera into the PVR slot.

JamesC

Message 17 of 42

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

@JamesC

 

after more than an hour with arlo support, it cannot be fixed. The support rep suggested I delete the Ultra cams from current account and set up a separate account to use the 1-year free premier that comes with Ultra purchase. That’s unacceptable. I want and I pay for Elite for the 60 days of cloud recordings. I am forgoing the free year b/c I want 60 days. Whatever has happened to my account, it’s preventing me from making ANY changes to subscription. Web browser login from PC, browser login from iPad, app login from iPad. I sent screenshots to support to evidence my inability to make any changes. They are scratching their heads. No one knows what to do, how to fix... 

 

below is an error I get trying to view my plan via my.arlo.com

 

408CF947-6132-4506-BC93-AC39841600BB.png

Message 18 of 42
Community Manager

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

zincyellowcobra,

 

Definitely don't create a new account. No need for that. Let me see what I can find out. I understand this whole process has been terribly frustrating. Let me find out what is going on and i'll get back to you in a private message.

 

JamesC

Message 19 of 42
Apprentice

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

James c! This is a cry for help! The app, the software, something needs fixed! I’m running the latest firmware on the smart hub, the ultras, the app, iOS, everything. I log into the app to see no videos in my cloud, no Arlo Smart settings, connection issues with the ultra, 4K local stream does not work. Please I know you guys can fix these issues! I would like to like my cams but it’s tough right now but I also understand that it’s brand new. Thank you!
Message 20 of 42
Community Manager

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

I'm working with the development team on these reports. As soon as I have more information, i'll provide an update here. I understand the frustration everyone is experiencing at the moment and appreciate your patience while we work to resolve these issues.

 

JamesC

Message 21 of 42
Apprentice

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

Thank you for the quick response! I own two arlo pros, and one pro 2, now 2 ultras! The older ones work great, I know the ultras will get there but it’s hard right now but I’m sticking with them, thank you arlo team! Can’t wait for the future updates! I know this product can be great.
Message 22 of 42
Apprentice

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

Worth looking at LIfeHackster's recent review of the Ultra on YouTube immediately following the 2019 CES.  In my humble opinion, it simply exemplifies Arlo's track record that so many of us here have become all to familiar with.  It bolsters your review and has convinced me, beyond a doubt, not to invest.  At least, not for a very long time. 

 

The cloud fees and accessory costs are enough to scare one away.  Not to mention, the poor performance.  We have seen this all before I'm afraid.

Message 23 of 42
Apprentice

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

Here’s a helpful hint I discovered today. In order to get the Ultra connected again I had to reset the base and re-add all of the cameras. The first camera added fine and allowed me to change the name of the camera. When I went to add the second camera, it was recognized by the base but then it didn’t allow me to change the camera name using the app. I tried multiple times and was ready to give up when I decided to try the web version. To my surprise I was able to add all of the cameras via the web. So I’m wondering if we now have an app issue. I’m still having significant connection and battery drain issues as well.
Message 24 of 42

Re: Arlo Ultra Problems & Feedback Thread - my criticisms so far

Do you have the 4K upgrade? I lost it when I deleted, reset and re-added. 

Message 25 of 42