Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Geofencing doesn't change status correctly based on enabled phone location

Reply
Discussion stats
  • 10 Replies
  • 3574 Views
  • 3 Likes
  • 4 In Conversation
PeterNJ Guide
Guide

I am unable to get Geofencing to work correctly, and it is extremely frustrating.   We have two iphones, and the Arlo app is able to track each of our phones correctly.    I can clearly see which phone is green “In Zone” vs red “Out of Zone”.   This is working correctly.    What is not working is that Arlo will only switch modes based on the activity of my phone.     When I leave the house,  Arlo switches to away even though my wife is home and “in zone”.    This morning my wife left the house before me, and Arlo correctly stayed in “home” mode.

 

So it appears that the arming and disarming is strictly based on my location, even though my wife’s phone is enabled and being monitored correctly by Arlo.   We have uninstalled and reinstalled the software on both phones to no avail.

 

I don’t know if this is relevant or not, but my wife’s phone died at about the same time I tried setting up Geofencing.    So on the “enabled phones” screen, I see her old phone and her new phone both with the same name.   I know that the inability to clean up “dead” phones has been discussed at great length on this forum.   It would be great if Netgear could address this obvious omission in capability.    I can verify that the correct phone is enabled as I can validate the correct in vs out of zone status.  

 

Cleaning up of old names aside, I really want to get Geofencing working correctly as manually managing the home / away status is a PIA.     Does anyone have a suggestion on how I can get Arlo to recognize the status of my wife’s phone when arming and disarming?     

Model: VMC4030| Arlo Pro Wire-Free Camera
Guru TomMac Guru
Guru

To be honest. with one phone the geo works pretty good.... throuble starts when 2 phones ( or more ) are used.

It has been this way from the start and don't think it has gotten much better.

 

Don't have much to offer as I found out a while back just to arm manually worked all the time... maye other have had better luck and will speak up.

--------------------------------------
Morse is faster than texting!
--------------------------------------
PeterNJ Guide
Guide

The way Geofencing is supposed to work (as far as I can tell) is that as long as one enabled phone is "In Zone", the system should be disarmed.   When all phones are "Out of Zone" the system should arm.

 

It is clearly not working that way, so this is a bug in the software.    I am a software development manager, and the way it works in every shop I have seen, is the support team opens a ticket.   It gets triaged and assigned to a Product Manager.   If is agreed that the issue is a bug, it should get assigeed to a developer for remediation.    If it is an enhancement, the Product Manager prioritizes it in a future release.

 

It seems that Netgear does not work this way.     Anyone care to comment on that?   Things don't seem to get fixed. 

 

I am still open to suggestions on how to get it working with the current software version.   Thank you.

 

 

Matchpoint Apprentice
Apprentice

This has been reported many times, I personally brought this up a couple of times. It used to work pretty good, I have four phones setup, 2 iphones and 2 galaxy notes. Although I will say that it doesn't work perfectly previously because it takes a while for it to recognize when a phone is in the zone or out of zone, sometimes it would not even detect it so I try to enable and disable the device until it recognizes it.

The problem now is worst because it does not put the correct mode when you set it to geofencing, it just puts it as "disarmed", this problem started happening when the dissapearing Mode Tab happened, I mentioned this in one of my posting but I haven't seen any response from Arlo at all about this, they just totally ignore the problem just like all the other problems they ignore. 

I was able to get this to work though by changing it to Armed, Disarmed, Scheduled, etc.. just keep on tinkering until it fixes itself. Geez I can't believe what kind of app is this, to make it worse Arlo just ignores the customers. : (

Model: VMC4030| Arlo Pro Wire-Free Camera
PeterNJ Guide
Guide

So, I just ran a test with one phone (my wife's) and even that is not working correctly.      I set her phone as the only enabled device.    When she came back home, Geofencing did not change state even though it clearly shows her phone as "in zone".     Is there any way to get "real" technical support for the Arlo product because it is not working as designed?  Thanks.

PeterNJ Guide
Guide

I have tried everything and have come to the conclusion that Geofencing will not work on my wife's iPhone.    The Arlo app knows whether the phone is inside or outside the zone, but it does not change from between Home and Away mode based on this information.  

 

I saw another person with the exact same issue, and that person had two phones (old and new) with the same name (as is the case with my wife's phone).    The lingering problem here is the Netgear does not provide the ability to delete retired phone (there are pages and pages on this incredibly stupid limitation).   

 

I might try renaming my wife's iPhone to remove the conflict between an active and inactive phone.   Before I go through the trouble of doing this, does anyone think this might fix the issue?   

 

Does anyone have specific recommentation on the procedure?  e.g.   Delete the app.   Rename the phone.  Reinstall the app.   Log in again,  etc?   

 

Finally,  can anyone actually called Arlo support?   How much does it cost, and is the quality of support good?

 

I am an engineer with 20+ years in the software industry.   I don't want to get a level 1 tech who only knows how to reboot.     Thank you.  

Model: VMC4030| Arlo Pro Wire-Free Camera
Highlighted
Matchpoint Apprentice
Apprentice

PeterNJ, I was chatting a couple of days ago with Arlo tech support regarding this for probably about 30 minutes, you're not gonna get anywhere. I will tell you this, when the Arlo developers themselves does not know how to fix their problem I will bet you a hundred dollars the Tech support would not know as well. Tech Support does not even know that there is a problem with the geofencing mode up to now, I don't know if they even read the postings in this forum to get an idea what is going on. They are aware of the dissapearing Mode tab problem that got fixed a few weeks ago, well I don;t even know if the Arlo developers are aware up to now about the geofencing problem or they jut don't care. This geofencing problem happened after the they fix the dissapearing mode tab. I am a software developer as well and I have been writing apps for over 30 years.

Model: VMC4030| Arlo Pro Wire-Free Camera
PeterNJ Guide
Guide

It's a miracle!!   Somehow, magically, Geofencing began working correctly for both our phones on Monday!    Regardless of who it is, the last person to leave the house arms Arlo, and the first person to arrive home disarms it.  

 

I really can't explain how it happend, but I am happy that it is now working.   Could Netgear have made a "back end" change to fix the problem?     I hope that I am not jinxing myself, but right now, things are good.   Knock on wood.

Model: VMC4030 | Arlo Pro Wire-Free Camera
lightingbryan Tutor
Tutor

Unfortunately, this is still not fixed for me. 

I am seeing this: Map in Geofencing correctly show phone location and Enabled Phones showing the phone as "In Zone" but the mode is stuck and doesn't change when entering and exiting.  

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
PeterNJ Guide
Guide

Unfortunately,  I spoke too soon.    When I go into the Mode page now, I see the Geofencing symbol, but the status is no longer shown.    Until last night, it used to display the Geofencing symbol followed by "Armed" or "Disarmbed" based on the location of our two phones.   It is broken again, but in a different way.  

 

At least it worked correctly for about 48 hours.   It must be something on the backend because nothing else in our configuration has changed.   Hopfully, Netgear can figure this out and get it fixed.

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera
PeterNJ Guide
Guide

OK..  Maybe I didn't get the scenario quite right.   My wife just got home and the system flipped to Disarmed (Home), so it is just the Geofencing Away setting that is not displaying correctly in the Mode screen.  

Model: VMC4030 | Arlo Pro Wire-Free Camera