Arlo|Smart Home Security|Wireless HD Security Cameras
× Arlo End of Life Policy Notice
To view Arlo’s new End of Life Policy, click here.

Cannot connect to Base Station. Called someone who might be a scam?

Reply
Discussion stats
  • 1 Reply
  • 833 Views
  • 1 Like
  • 2 In Conversation
Cknguyen617
Follower
Follower

I was super super excited to get my new arlo system and cameras. However, when I try to set it up, it cant connect to the base station!! I tried on my phone, followed instructions exactly. I tried on my computers also. Tried resetting the base. Nothing seems to work!! So then I called. And of course, its not someone who speaks English. The guy was on the phone w me for a long time, wanted access to my computer... which I thought was weird... but I allowed. Then he pulled up these screens and said I had like 8000 trojens/viruses, etc... and that it was EXTREMELY critical I fixed it immediatly and pay for firewall protection after. To fix would be 200, firewall would be 400 for 1 year, or 800 for 2 years, or 1200 for lifetime. I was like wtf!! I dont have that type of money. He also wanted the last 4 digits of my social which I refused to give. When I said no to the services, the guy full on went off on me!! WTF. Said I wasted his time, wasted my time and that he could easily hack me if he wanted to and get all my info and charge me and on and on and on!! I got this number from the netgear website. I had just spent like nearly 600 fot cameras and stuff anf he wanted to charge me more!! When I said I dont have that tyoe of money, he said how can you not. I am soooooooooo very upset and disappointed right now. Now my computer is stuck on safe mode and my station still wont connect!! So I searched the forums and called the number on the arlo website, different area code bc the chats were not going. It sent me through prompts which seemed more legit, but at the end, it was another Indian voice and paranoid, I hung up!!

Long story short, I spent another 30 minutes trying to trouble shoot before thinking maybe its where I am connecting the ethernet cable. I connected it to the other signal box and guess what, my arlo base showed up asap!!

Is the arlo service based overseas too?!? I want someone IN the USA helping me when I need help if there is emergeny!!

I am going to try this out for a bit now that it connects, but otherwiseI will return it bc I dont want to get scammed!!

1 REPLY 1
StephenB
Guru Guru
Guru

@Cknguyen617 wrote:
Then he pulled up these screens and said I had like 8000 trojens/viruses, etc... and that it was EXTREMELY critical I fixed it immediatly and pay for firewall protection after. 

This was a scam support site, not the real Arlo one.  You should always use https://www.arlo.com/en-us/support/contact.aspx to contact support.  Googling for support numbers will often land you on a scam site, and some of them look legit.

 

Arlo has not been part of Netgear for a long time - so don't connect to Netgear support.  But Netgear wouldn't go down that trojan/virus path either - so you weren't really talking to them.