Arlo|Smart Home Security|Wireless HD Security Cameras|NETGEAR

The Arlo Community

Learn, explore, ask questions, and connect with our community of customers and experts.

Discussion stats
  • 4 replies
  • 0 kudos
  • 2 in conversation
Top Contributors
Caught on Arlo Video Contest
Share Video

Share Your Video!
Caught something cool on Arlo? Share it with the Arlo Community.

Post a video

Base Station Wont Upgrade Firmware

My Arlo Pro has worked great for the past year until recent months. Seems to be issues from the firmware. Everything went non responsive last night so I reset the system and removed everything. Both my cameras and base station firmware are out of date. Seems I cant update the cameras until I update the base station.

I have been trying to update the firmware from to
the latest one It keeps asking me to do so and I try but after the reboot,the update doesn’t take. I e power cycled and updated and nothing works.

My base station is the Arlo Pro VMB 4000.

Could Netgears upgrade servers be down? I feel like i have done everything I can except drop kick the system. Please advise.
Message 1 of 5

Re: Base Station Wont Upgrade Firmware

Since you've already reset the system, I would take it a step further. Remove everything from Settings, My Devices (again). Press the base reset button until the LEDs flash amber. Let it reboot. When online again, claim the base and update the firmware. Any luck?

Message 2 of 5

Re: Base Station Wont Upgrade Firmware

Just tried again. Removed everything....reset w a papperclip. Added back the base station w a new name. Device Info > install latest firmware update.

It self Rebooted and still says that I have a firmware update to be installed.

I can connect cameras to base station but the messages to update the firmware fill my dashboard.

There is something preventing the firmware update.
Message 3 of 5

Re: Base Station Wont Upgrade Firmware

If possible, swap at the store.Otherwise, open a case with support here:

Message 4 of 5

Re: Base Station Wont Upgrade Firmware

Well. It finally updated on its own. Im not sure how it happened because I tried a few times with no luck. Then I just noticed an hour ago that it was complete. 🤔

I’ll take it. Now to update the camera firmware. Fingers crossed
Message 5 of 5