Arlo|Smart Home Security|Wireless HD Security Cameras
× Arlo End of Life Policy Notice
To view Arlo’s new End of Life Policy, click here.

Reply
Discussion stats
  • 11 Replies
  • 1601 Views
  • 1 Like
  • 7 In Conversation
MPayne04
Follower
Follower

Unable to login to web from laptop (windows 10); for last 24 hours and after multiple attempts, get "Request Timed Out" message. No issue logging in via iPhone App however can't update subscription plan via app or make other changes. Unable to even get to Trusted Device prompt on laptop browsers (chrome, edge). Spent hour online with 2 online Arlo chat experts and was complete waste of time. Case # created and I tried to provide update to the case as they requested using the link sent in an email from Arlo only to discover they immediately closed the case. SMH. Haven't found solution that works in the Community. Any help is appreciated that solves the problem. 

11 REPLIES 11
jguerdat
Guru Guru
Guru

What Internet antivirus/malware software are you using on the computer? Have you tried temporarily disabling it to see if that helps?

GSS888
Aspirant
Aspirant
It’s not SOLVED. Do not follow the knee jerk responses of those who tell you to delete the app and reinstall. This a problem from Arlo’s end NOT YOURS. Those simpletons follow knee jerk responses without (a) having read and (b) understood the problem comprehensively. They just like to hear themselves so they feel good that they’re out there responding. And their responses are erroneous to say the least. The solution is too keep trying until your logged back in. Again it’s a FAILURE on Arlo’s NOT yours and not the telco if you’re able to surf. It means you sure as heck should be logging in. The fact you are not is entirely due to Arlo and no one else.
ShayneS
Arlo Moderator
Arlo Moderator

Are you still experiencing this issue? 

LukeA
Aspirant
Aspirant
Yes we are too
Dannybear
Master
Master
Has anyone tried using the incognito or private window in the browser to see if it gets through ok.

Trying this would help to eliminate the browser stored cookies as the cause for the issue.
AikaneKai
Apprentice
Apprentice

it happens fairly often to me and has been happening for the last year at least.  I suspect it's due to their servers being too busy to connect, but I don't know for sure. 

Dannybear
Master
Master
If it occurs intermittently then yes can be a arlo site overload or more likely a regional arlo server issue since not everyone has the issue.
AikaneKai
Apprentice
Apprentice

@Dannybear 

I'm in HI.  I don't think they have a regional server here, which is why I get such horrible delays.

Dannybear
Master
Master
@AikaneKai,

I don’t know, maybe one of the moderators can assist. @JamesC or @ShayneS
ShayneS
Arlo Moderator
Arlo Moderator

Hi @AikaneKai

 

Do you have a firewall or anti-virus software on the pc? you can try contacting your ISP as well to see if they have started new security measures as well. 

 

Does this occur on other browsers/PCs as well? 

 

You can also try clearing your cache/cookies

AikaneKai
Apprentice
Apprentice

No firewall, or antivirus.  Not a pc, mac.  I thought about it and realized it's been happening since I first bought the cameras.  I have had several different computers in the few years I've owned these and it's been the same on each.  Yes, it happens on other browsers on my mac, my phone and ipads as well when they're on and off Wifi.  It's intermittent.  Sometimes I can connect within 5-10 seconds, or it can take a full minute to connect or it can fail multiple times in a row.